We need more python applications... add pyfits 1.0.1 and pyraf 1.2.1:
authorMichael Lauer <mickey@vanille-media.de>
Tue, 23 May 2006 08:26:54 +0000 (08:26 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Tue, 23 May 2006 08:26:54 +0000 (08:26 +0000)
PyFITS provides an interface to FITS formatted files under the Python scripting language and PyRAF, the Python-based interface to IRAF. It is useful
both for interactive data analysis and for writing analysis scripts in Python using FITS files as either input or output. PyFITS is a development
project of the Science Software Branch at the Space Telescope Science Institute.

packages/meta/task-python-everything_20060425.bb
packages/meta/task-python-sharprom_20060425.bb
packages/python/python-pyfits_1.0.1.bb [new file with mode: 0644]
packages/python/python-pyraf_1.2.1.bb [new file with mode: 0644]

index fd9bbd9..738b823 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION= "Everything Python"
 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
 HOMEPAGE = "http://www.vanille.de/projects/python.spy"
 LICENSE = "MIT"
-PR = "ml5"
+PR = "ml7"
 
 BROKEN_BECAUSE_GCC4 = "\
                python-egenix-mx-base"
@@ -32,6 +32,7 @@ RDEPENDS = "\
                python-pexpect          \
                python-pychecker        \
                python-pycodes          \
+               python-pyfits           \
                python-pyflakes         \
                python-pygame           \
                python-pygoogle         \
@@ -41,6 +42,7 @@ RDEPENDS = "\
                python-pylint           \
                python-pyqt             \
                python-pyqwt            \
+               python-pyraf            \
                python-pyreverse        \
                python-pyrex            \
                python-pyro             \
index 0c6a74f..8ce0dcf 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Everything Python for SharpROM"
 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
 HOMEPAGE = "http://www.vanille.de/projects/python.spy"
 LICENSE = "MIT"
-PR = "ml2"
+PR = "ml4"
 
 NONWORKING = "\
                python-codes            \
@@ -22,7 +22,6 @@ RDEPENDS = "\
                python-constraint       \
                python-dialog           \
                python-egenix-mx-base   \
-               python-pycurl           \
                python-fnorb            \
                python-fpconst          \
                python-gnosis           \
@@ -34,14 +33,18 @@ RDEPENDS = "\
                python-mad              \
                python-native           \
                python-numeric          \
+               python-numarray         \
                python-ogg              \
                python-pexpect          \
                python-pychecker        \
+               python-pycurl           \
+               python-pyfits           \
                python-pyflakes         \
                python-pygoogle         \
                python-pylinda          \
                python-pylint           \
                python-pyqt             \
+               python-pyraf            \
                python-pyreverse        \
                python-pyro             \
                python-pyserial         \
diff --git a/packages/python/python-pyfits_1.0.1.bb b/packages/python/python-pyfits_1.0.1.bb
new file mode 100644 (file)
index 0000000..1d1507d
--- /dev/null
@@ -0,0 +1,13 @@
+DESCRIPTION = "PyFITS provides an interface to FITS formatted files under the Python scripting language."
+HOMEPAGE = "http://www.stsci.edu/resources/software_hardware/pyfits"
+AUTHOR = "Space Telescope Science Institute"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de"
+RDEPENDS = "python-numarray"
+SECTION = "devel/python"
+LICENSE = "AURA"
+PR = "ml0"
+
+SRC_URI = "ftp://ra.stsci.edu/pub/pyfits/pyfits-${PV}.tar.gz"
+S = "${WORKDIR}/pyfits-${PV}"
+
+inherit distutils
diff --git a/packages/python/python-pyraf_1.2.1.bb b/packages/python/python-pyraf_1.2.1.bb
new file mode 100644 (file)
index 0000000..2242390
--- /dev/null
@@ -0,0 +1,14 @@
+DESCRIPTION = "PyRAF is a Python-based interface to IRAF."
+HOMEPAGE = "http://www.stsci.edu/resources/software_hardware/pyfits"
+AUTHOR = "Space Telescope Science Institute"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de"
+RDEPENDS = "python-numarray"
+SECTION = "devel/python"
+LICENSE = "AURA"
+PR = "ml0"
+
+SRC_URI = "ftp://ra.stsci.edu/pub/pyraf/v2.3/pyraf-${PV}.tar.gz"
+S = "${WORKDIR}/pyraf-${PV}"
+
+inherit distutils
+