at76c503a: move back to packages since it's working perfectly for machine it was...
authorKoen Kooi <koen@openembedded.org>
Sun, 4 May 2008 12:59:18 +0000 (12:59 +0000)
committerKoen Kooi <koen@openembedded.org>
Sun, 4 May 2008 12:59:18 +0000 (12:59 +0000)
packages/at76c503a/.mtn2git_empty [new file with mode: 0644]
packages/at76c503a/at76c503a-modules/.mtn2git_empty [new file with mode: 0644]
packages/at76c503a/at76c503a-modules/makefile.cc.patch [new file with mode: 0644]
packages/at76c503a/at76c503a-modules_0.17.bb [new file with mode: 0644]
packages/at76c503a/at76c503a-modules_cvs.bb [new file with mode: 0644]
packages/nonworking/at76c503a/.mtn2git_empty [deleted file]
packages/nonworking/at76c503a/at76c503a-modules/.mtn2git_empty [deleted file]
packages/nonworking/at76c503a/at76c503a-modules/makefile.cc.patch [deleted file]
packages/nonworking/at76c503a/at76c503a-modules_0.17.bb [deleted file]
packages/nonworking/at76c503a/at76c503a-modules_cvs.bb [deleted file]

diff --git a/packages/at76c503a/.mtn2git_empty b/packages/at76c503a/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/at76c503a/at76c503a-modules/.mtn2git_empty b/packages/at76c503a/at76c503a-modules/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/at76c503a/at76c503a-modules/makefile.cc.patch b/packages/at76c503a/at76c503a-modules/makefile.cc.patch
new file mode 100644 (file)
index 0000000..c7a4199
--- /dev/null
@@ -0,0 +1,11 @@
+--- at76c503a/Makefile.old     2005-07-29 21:57:34.000000000 +0200
++++ at76c503a/Makefile 2005-07-29 21:57:43.000000000 +0200
+@@ -9,7 +9,7 @@
+ #     the License, or (at your option) any later version.
+ #
+-CC=gcc
++#CC=gcc
+ ifneq (,$(KVERS))
+  KERNEL_VERSION=$(KVERS)
diff --git a/packages/at76c503a/at76c503a-modules_0.17.bb b/packages/at76c503a/at76c503a-modules_0.17.bb
new file mode 100644 (file)
index 0000000..58b782b
--- /dev/null
@@ -0,0 +1,22 @@
+DESCRIPTION = "Driver for at76 based usb-wifi devices"
+SECTION = "base"
+LICENSE = "GPL"
+
+PR = "r1"
+
+RDEPENDS = "at76c503-firmware"
+
+SRC_URI = "http://download.berlios.de/at76c503a/at76_usb-0.17.tar.gz"
+S = "${WORKDIR}/at76_usb-${PV}/"
+
+inherit module
+
+MODULES = "at76c503 at76_usbdfu at76c503-i3861 at76c503-rfmd at76c503-rfmd-acc \
+       at76c505-rfmd at76c503-i3863 at76c505-rfmd2958"
+
+do_install() {
+       install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/
+       for i in *${KERNEL_OBJECT_SUFFIX}; do
+               install -m 0644 $i ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/
+       done
+}
diff --git a/packages/at76c503a/at76c503a-modules_cvs.bb b/packages/at76c503a/at76c503a-modules_cvs.bb
new file mode 100644 (file)
index 0000000..7422cc6
--- /dev/null
@@ -0,0 +1,23 @@
+SECTION = "base"
+LICENSE = "GPL"
+SRC_URI = "cvs://anonymous@cvs.berlios.de/cvsroot/at76c503a;module=at76c503a \
+          file://makefile.cc.patch;patch=1"
+S = "${WORKDIR}/at76c503a"
+PR = "r4"
+PV = "0.0+cvs${SRCDATE}"
+
+inherit module
+
+MODULES = "at76c503 at76_usbdfu at76c503-i3861 at76c503-rfmd at76c503-rfmd-acc \
+       at76c505-rfmd at76c503-i3863 at76c505-rfmd2958"
+
+do_install() {
+       install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/
+       for i in ${MODULES}; do
+               install -m 0644 $i${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/
+       done
+       if [ "${MACHINE}" = "h3900" ]; then
+               install -d ${D}${sysconfdir}/modutils
+               echo "at76c503-rfmd" > ${D}${sysconfdir}/modutils/at76c503-rfmd
+       fi
+}
diff --git a/packages/nonworking/at76c503a/.mtn2git_empty b/packages/nonworking/at76c503a/.mtn2git_empty
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/packages/nonworking/at76c503a/at76c503a-modules/.mtn2git_empty b/packages/nonworking/at76c503a/at76c503a-modules/.mtn2git_empty
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/packages/nonworking/at76c503a/at76c503a-modules/makefile.cc.patch b/packages/nonworking/at76c503a/at76c503a-modules/makefile.cc.patch
deleted file mode 100644 (file)
index c7a4199..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- at76c503a/Makefile.old     2005-07-29 21:57:34.000000000 +0200
-+++ at76c503a/Makefile 2005-07-29 21:57:43.000000000 +0200
-@@ -9,7 +9,7 @@
- #     the License, or (at your option) any later version.
- #
--CC=gcc
-+#CC=gcc
- ifneq (,$(KVERS))
-  KERNEL_VERSION=$(KVERS)
diff --git a/packages/nonworking/at76c503a/at76c503a-modules_0.17.bb b/packages/nonworking/at76c503a/at76c503a-modules_0.17.bb
deleted file mode 100644 (file)
index 58b782b..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-DESCRIPTION = "Driver for at76 based usb-wifi devices"
-SECTION = "base"
-LICENSE = "GPL"
-
-PR = "r1"
-
-RDEPENDS = "at76c503-firmware"
-
-SRC_URI = "http://download.berlios.de/at76c503a/at76_usb-0.17.tar.gz"
-S = "${WORKDIR}/at76_usb-${PV}/"
-
-inherit module
-
-MODULES = "at76c503 at76_usbdfu at76c503-i3861 at76c503-rfmd at76c503-rfmd-acc \
-       at76c505-rfmd at76c503-i3863 at76c505-rfmd2958"
-
-do_install() {
-       install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/
-       for i in *${KERNEL_OBJECT_SUFFIX}; do
-               install -m 0644 $i ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/
-       done
-}
diff --git a/packages/nonworking/at76c503a/at76c503a-modules_cvs.bb b/packages/nonworking/at76c503a/at76c503a-modules_cvs.bb
deleted file mode 100644 (file)
index 7422cc6..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-SECTION = "base"
-LICENSE = "GPL"
-SRC_URI = "cvs://anonymous@cvs.berlios.de/cvsroot/at76c503a;module=at76c503a \
-          file://makefile.cc.patch;patch=1"
-S = "${WORKDIR}/at76c503a"
-PR = "r4"
-PV = "0.0+cvs${SRCDATE}"
-
-inherit module
-
-MODULES = "at76c503 at76_usbdfu at76c503-i3861 at76c503-rfmd at76c503-rfmd-acc \
-       at76c505-rfmd at76c503-i3863 at76c505-rfmd2958"
-
-do_install() {
-       install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/
-       for i in ${MODULES}; do
-               install -m 0644 $i${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/
-       done
-       if [ "${MACHINE}" = "h3900" ]; then
-               install -d ${D}${sysconfdir}/modutils
-               echo "at76c503-rfmd" > ${D}${sysconfdir}/modutils/at76c503-rfmd
-       fi
-}