u-boot-mkimage-native: added 1.3.2 (from Poky)
authorMarcin Juszkiewicz <hrw@openembedded.org>
Thu, 23 Oct 2008 15:48:58 +0000 (17:48 +0200)
committerMarcin Juszkiewicz <hrw@openembedded.org>
Thu, 23 Oct 2008 15:48:58 +0000 (17:48 +0200)
This version can be used instead of u-boot-mkimage-openmoko-native
recipe (which contains lot of patches not required for mkimage tool).

packages/u-boot/u-boot-mkimage-native-1.3.2/fix-arm920t-eabi.patch [new file with mode: 0644]
packages/u-boot/u-boot-mkimage-native_1.3.2.bb [new file with mode: 0644]

diff --git a/packages/u-boot/u-boot-mkimage-native-1.3.2/fix-arm920t-eabi.patch b/packages/u-boot/u-boot-mkimage-native-1.3.2/fix-arm920t-eabi.patch
new file mode 100644 (file)
index 0000000..69cb758
--- /dev/null
@@ -0,0 +1,22 @@
+---
+ cpu/arm920t/config.mk |    4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- u-boot-1.3.2.orig/cpu/arm920t/config.mk
++++ u-boot-1.3.2/cpu/arm920t/config.mk
+@@ -22,13 +22,13 @@
+ #
+ PLATFORM_RELFLAGS += -fno-strict-aliasing  -fno-common -ffixed-r8 \
+       -msoft-float
+-PLATFORM_CPPFLAGS += -march=armv4
++#PLATFORM_CPPFLAGS += -march=armv4
+ # =========================================================================
+ #
+ # Supply options according to compiler version
+ #
+ # =========================================================================
+-PLATFORM_CPPFLAGS +=$(call cc-option,-mapcs-32,-mabi=apcs-gnu)
++PLATFORM_CPPFLAGS +=$(call cc-option)
+ PLATFORM_RELFLAGS +=$(call cc-option,-mshort-load-bytes,$(call cc-option,-malignment-traps,))
diff --git a/packages/u-boot/u-boot-mkimage-native_1.3.2.bb b/packages/u-boot/u-boot-mkimage-native_1.3.2.bb
new file mode 100644 (file)
index 0000000..38dd700
--- /dev/null
@@ -0,0 +1,22 @@
+DESCRIPTION = "U-boot bootloader mkimage tool"
+LICENSE = "GPL"
+SECTION = "bootloader"
+
+SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
+           file://fix-arm920t-eabi.patch;patch=1"
+
+S = "${WORKDIR}/u-boot-${PV}"
+
+inherit native
+
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
+
+do_compile () {
+       oe_runmake smdk2410_config
+        oe_runmake tools
+}
+
+do_stage () {
+        install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/uboot-mkimage
+        ln -sf ${STAGING_BINDIR_NATIVE}/uboot-mkimage ${STAGING_BINDIR_NATIVE}/mkimage
+}