merge of '9dc7779dad5b6a6762c08a60de1c3cba24575356'
authorMichael Lauer <mickey@vanille-media.de>
Sun, 27 Jul 2008 16:46:17 +0000 (16:46 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Sun, 27 Jul 2008 16:46:17 +0000 (16:46 +0000)
     and 'a08c13e1d6c50600fb85844f3940034870cd26ad'

packages/classpath/classpath-native.inc
packages/jamvm/files/jamvm_1.4.5-initial.patch [new file with mode: 0644]
packages/jamvm/jamvm-initial_1.4.5.bb [new file with mode: 0644]
packages/openchrome/openchrome.inc
packages/openchrome/openchrome_svn.bb
packages/openchrome/xf86-video-openchrome_0.2.902.bb
packages/tasks/task-mythfront.bb

index 94eac96..3094dca 100644 (file)
@@ -6,7 +6,7 @@ S = "${WORKDIR}/classpath-${PV}"
 
 SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz"
 
-DEPENDS = "ecj-initial fastjar-native zip-native"
+DEPENDS = "ecj-initial fastjar-native zip-nativei gettext-native"
 
 inherit autotools native
 
@@ -29,6 +29,12 @@ EXTRA_OECONF = "\
   --includedir=${STAGING_INCDIR}/classpath \
   --with-vm=java \
   "
+# hack to get config.rpath in, it comes from gettext
+do_configure_prepend () {
+
+        ${@['','cp ${STAGING_DATADIR}/automake-1.10/config.rpath ${S}'][bb.data.getVar('PREFERRED_VERSION_automake-native',d,1) == '1.10']}
+
+}
 
 do_stage() {
        oe_runmake install
diff --git a/packages/jamvm/files/jamvm_1.4.5-initial.patch b/packages/jamvm/files/jamvm_1.4.5-initial.patch
new file mode 100644 (file)
index 0000000..3c68818
--- /dev/null
@@ -0,0 +1,73 @@
+Index: jamvm-1.4.5/configure.ac
+===================================================================
+--- jamvm-1.4.5.orig/configure.ac
++++ jamvm-1.4.5/configure.ac
+@@ -1,6 +1,6 @@
+ dnl Process this file with autoconf to produce a configure script.
+ AC_INIT(src/jam.c)
+-AM_INIT_AUTOMAKE(jamvm, 1.4.5)
++AM_INIT_AUTOMAKE(jamvm-initial, 1.4.5)
+ AC_CONFIG_HEADERS([src/config.h])
+ AC_PREFIX_DEFAULT(/usr/local/jamvm)
+Index: jamvm-1.4.5/java-initial
+===================================================================
+--- /dev/null
++++ jamvm-1.4.5/java-initial
+@@ -0,0 +1,5 @@
++#!/bin/sh
++#
++# Wrapper script inspired by the one provided by cacao.
++
++exec jamvm-initial ${1+"$@"}
+Index: jamvm-1.4.5/lib/Makefile.am
+===================================================================
+--- jamvm-1.4.5.orig/lib/Makefile.am
++++ jamvm-1.4.5/lib/Makefile.am
+@@ -1,4 +1,4 @@
+-@use_zip_yes@ GLIBJ_ZIP = ${with_classpath_install_dir}/share/classpath/glibj.zip
++@use_zip_yes@ GLIBJ_ZIP = ${with_classpath_install_dir}/share/classpath-initial/glibj.zip
+ @use_zip_no@ GLIBJ_ZIP = ${with_classpath_install_dir}/share/classpath/
+ SUBDIRS = jamvm java gnu sun
+Index: jamvm-1.4.5/src/dll.c
+===================================================================
+--- jamvm-1.4.5.orig/src/dll.c
++++ jamvm-1.4.5/src/dll.c
+@@ -294,7 +294,7 @@ char *getDllPath() {
+ }
+ char *getBootDllPath() {
+-    return CLASSPATH_INSTALL_DIR"/lib/classpath";
++    return CLASSPATH_INSTALL_DIR"/lib/classpath-initial";
+ }
+ char *getDllName(char *name) {
+Index: jamvm-1.4.5/src/Makefile.am
+===================================================================
+--- jamvm-1.4.5.orig/src/Makefile.am
++++ jamvm-1.4.5/src/Makefile.am
+@@ -2,7 +2,7 @@ SUBDIRS = os
+ DIST_SUBDIRS = os arch
+ bin_PROGRAMS = jamvm
+-include_HEADERS = jni.h
++noinst_HEADERS = jni.h
+ lib_LTLIBRARIES = libjvm.la
+ noinst_LTLIBRARIES = libcore.la
+Index: jamvm-1.4.5/src/class.c
+===================================================================
+--- jamvm-1.4.5.orig/src/class.c
++++ jamvm-1.4.5/src/class.c
+@@ -1653,8 +1653,8 @@ void scanDirsForJars(char *directories) 
+ }
+ #ifdef USE_ZIP
+-#define JAMVM_CLASSES INSTALL_DIR"/share/jamvm/classes.zip"
+-#define CLASSPATH_CLASSES CLASSPATH_INSTALL_DIR"/share/classpath/glibj.zip"
++#define JAMVM_CLASSES INSTALL_DIR"/share/jamvm-initial/classes.zip"
++#define CLASSPATH_CLASSES CLASSPATH_INSTALL_DIR"/share/classpath-initial/glibj.zip"
+ #else
+ #define JAMVM_CLASSES INSTALL_DIR"/share/jamvm/classes"
+ #define CLASSPATH_CLASSES CLASSPATH_INSTALL_DIR"/share/classpath"
diff --git a/packages/jamvm/jamvm-initial_1.4.5.bb b/packages/jamvm/jamvm-initial_1.4.5.bb
new file mode 100644 (file)
index 0000000..c71811d
--- /dev/null
@@ -0,0 +1,38 @@
+SUMMARY = "A compact Java Virtual Machine which conforms to the JVM specification version 2."
+HOMEPAGE = "http://jamvm.sourceforge.net/"
+LICENSE = "GPL"
+
+DEPENDS = "zlib-native classpath-initial jikes-initial"
+
+PR = "r0"
+
+PROVIDES = "virtual/java-initial"
+
+S = "${WORKDIR}/jamvm-${PV}"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/jamvm/jamvm-${PV}.tar.gz \
+          file://jamvm_${PV}-initial.patch;patch=1;pnum=1 \
+          "
+
+# This uses 32 bit arm, so force the instruction set to arm, not thumb
+ARM_INSTRUCTION_SET = "arm"
+
+inherit native autotools
+
+EXTRA_OECONF = "\
+  --with-classpath-install-dir=${prefix} \
+  --program-suffix=-initial \
+  "
+
+CFLAGS += "-DDEFAULT_MAX_HEAP=16*MB"
+
+do_compile() {
+  oe_runmake \
+    JAVAC=jikes-initial \
+    GLIBJ_ZIP=${STAGING_DATADIR_NATIVE}/classpath-initial/glibj.zip
+}
+
+do_stage_append() {
+  install -d ${STAGING_BINDIR}
+  install -m 0755 java-initial ${STAGING_BINDIR}
+}
index 914601c..e88f322 100644 (file)
@@ -1,5 +1,4 @@
 PACKAGES = "libviaXvMC libviaXvMCPro libviaXvMC-dev libviaXvMCPro-dev libviaXvMC-dbg libviaXvMCPro-dbg ${PN}-doc"
-PACKAGES_DYNAMIC = "xorg-driver-via"
 
 FILES_libviaXvMC = "${libdir}/libviaXvMC.so.*"
 FILES_libviaXvMCPro = "${libdir}/libviaXvMCPro.so.*"
index 4e5933a..c1d8052 100644 (file)
@@ -1,4 +1,5 @@
 SRC_URI = "svn://svn.openchrome.org/svn;module=trunk;proto=http"
 S = "${WORKDIR}/trunk"
+PACKAGES_DYNAMIC = "xorg-driver-via"
 
 include openchrome.inc
index a8d0ac0..5792f72 100644 (file)
@@ -1,3 +1,4 @@
 SRC_URI = "http://www.openchrome.org/releases/xf86-video-openchrome-${PV}.tar.gz file://configure.patch;patch=1 file://configure-dri.patch;patch=1"
+PACKAGES_DYNAMIC = "xorg-driver-openchrome"
 
 include openchrome.inc
index 37e0fa0..1a89d1b 100644 (file)
@@ -1,11 +1,11 @@
 DESCRIPTION = "Meta-package for MythTV diskless frontend"
-PR = "r14"
+PR = "r16"
 
 inherit task
 
-RDEPENDS_${PN} = "xserver-xorg mythtv-frontend mythtv-filters mythtv-theme-g.a.n.t. mythtv-theme-default lirc lirc-modules ttf-bitstream-vera fontconfig-utils setserial snes9x ntp mythfront-config gpe-dm mythfront-session bootlogd font-cursor-misc font-misc-misc xf86-input-keyboard xf86-input-mouse"
+RDEPENDS_${PN} = "xserver-xorg mythtv-frontend mythtv-filters mythtv-theme-g.a.n.t mythtv-theme-default lirc lirc-modules ttf-bitstream-vera fontconfig-utils setserial snes9x ntp mythfront-config gpe-dm mythfront-session bootlogd font-cursor-misc font-misc-misc xf86-input-keyboard xf86-input-mouse"
 
-RDEPENDS_${PN}_append_epia = " xorg-driver-via mesa-dri-driver-unichrome"
+RDEPENDS_${PN}_append_epia = " xorg-driver-openchrome mesa-dri-driver-unichrome"
 
 PACKAGE_ARCH_epia = "${MACHINE_ARCH}"