Ahead of 7425B0
authorschon <schon@dev03-server>
Tue, 1 May 2012 04:55:36 +0000 (13:55 +0900)
committerschon <schon@dev03-server>
Tue, 1 May 2012 04:55:36 +0000 (13:55 +0900)
recipes/enigma2/enigma2.bb
recipes/images/vuplus-image.bb
recipes/libdreamdvd/libdreamdvd.bb
recipes/tasks/task-vuplus-wlan.bb
recipes/tuxbox/tuxbox-libtuxtxt.bb
recipes/udev/udev_124.bb

index 67c6f31..7ad25cf 100644 (file)
@@ -31,6 +31,8 @@ RDEPENDS_append_vusolo = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-a
 RDEPENDS_append_vuuno = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
 RDEPENDS_append_vuultimo = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
 RDEPENDS_append_vu7425 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
+RDEPENDS_append_vuduo2 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
+RDEPENDS_append_vusolo2 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
 RDEPENDS_append_dm7020hd = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
 
 # 'forward depends' - no two providers can have the same PACKAGES_DYNAMIC, however both
@@ -141,6 +143,11 @@ SRC_URI_append_vu7425 = " \
            file://skin_user.xml \
            file://vfd_icons \
 "
+SRC_URI_append_vuduo2 = " \
+           file://analog.ttf \
+           file://skin_user.xml \
+           file://vfd_icons \
+"
 
 def change_po():
         import os
@@ -219,6 +226,12 @@ do_install_append_vu7425() {
         install -d ${D}/usr/share/enigma2/vfd_icons/
         install -m 0755 ${WORKDIR}/vfd_icons/*.png ${D}/usr/share/enigma2/vfd_icons/
 }
+do_install_append_vuduo2() {
+        install -m 0755 ${WORKDIR}/analog.ttf ${D}/usr/share/fonts/
+        install -m 0755 ${WORKDIR}/skin_user.xml ${D}/usr/share/enigma2/defaults/
+        install -d ${D}/usr/share/enigma2/vfd_icons/
+        install -m 0755 ${WORKDIR}/vfd_icons/*.png ${D}/usr/share/enigma2/vfd_icons/
+}
 
 python populate_packages_prepend () {
        enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
index dcac40d..af63928 100755 (executable)
@@ -78,3 +78,9 @@ do_rootfs_append_vuultimo() {
 do_rootfs_append_vu7425() {
     generate_nfo
 }
+do_rootfs_append_vuduo2() {
+    generate_nfo
+}
+do_rootfs_append_vusolo2() {
+    generate_nfo
+}
index 5437724..2f56355 100755 (executable)
@@ -22,6 +22,8 @@ CFLAGS_bm750_append = " -DHARDWARE_SUPPORT_LPCM"
 CFLAGS_vusolo_append = " -DHARDWARE_SUPPORT_LPCM"
 CFLAGS_vuuno_append = " -DHARDWARE_SUPPORT_LPCM"
 CFLAGS_vuultimo_append = " -DHARDWARE_SUPPORT_LPCM"
+CFLAGS_vuduo2_append = " -DHARDWARE_SUPPORT_LPCM"
+CFLAGS_vusolo2_append = " -DHARDWARE_SUPPORT_LPCM"
 
 S = "${WORKDIR}/git"
 
index c0960bc..df9ebf0 100644 (file)
@@ -56,7 +56,13 @@ RDEPENDS_${PN}_append_vuultimo = "\
   ${@base_contains('PREFERRED_VERSION_linux-vuultimo', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
 "
 RDEPENDS_${PN}_append_vu7425 = "\
-  ${@base_contains('PREFERRED_VERSION_linux-vuultimo', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
+  ${@base_contains('PREFERRED_VERSION_linux-vuvu7425', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
+"
+RDEPENDS_${PN}_append_vuduo2 = "\
+  ${@base_contains('PREFERRED_VERSION_linux-vuduo2', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
+"
+RDEPENDS_${PN}_append_vuduo2 = "\
+  ${@base_contains('PREFERRED_VERSION_linux-vusolo2', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
 "
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
index 1cfccd7..30c5b92 100755 (executable)
@@ -69,6 +69,14 @@ SRC_URI_append_vu7425 = " \
        file://32bpp.diff;patch=1 \
        file://resize_framebuffer.diff;patch=1 \
        file://allow_different_demux.diff;patch=1"
+SRC_URI_append_vuduo2 = " \
+       file://32bpp.diff;patch=1 \
+       file://resize_framebuffer.diff;patch=1 \
+       file://allow_different_demux.diff;patch=1"
+SRC_URI_append_vusolo2 = " \
+       file://32bpp.diff;patch=1 \
+       file://resize_framebuffer.diff;patch=1 \
+       file://allow_different_demux.diff;patch=1"
 
 S = "${WORKDIR}/libs"
 EXTRA_OECONF = "--with-target=native"
index eb574fc..28733cd 100755 (executable)
@@ -37,6 +37,8 @@ SRC_URI_append_vusolo = " file://41-od-linux-2.6.18-misc.rules"
 SRC_URI_append_vuuno = " file://41-od-linux-2.6.18-misc.rules"
 SRC_URI_append_vuultimo = " file://41-od-linux-2.6.18-misc.rules"
 SRC_URI_append_vu7425 = " file://41-od-linux-2.6.18-misc.rules"
+SRC_URI_append_vuduo2 = " file://41-od-linux-2.6.18-misc.rules"
+SRC_URI_append_vusolo2 = " file://41-od-linux-2.6.18-misc.rules"
 
 
 require udev.inc