libssh: add libssh-native
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>
Tue, 7 Apr 2009 07:56:17 +0000 (09:56 +0200)
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>
Tue, 7 Apr 2009 08:41:47 +0000 (10:41 +0200)
recipes/libssh/libssh-native_0.2.bb [new file with mode: 0644]
recipes/libssh/libssh_0.11.bb [deleted file]
recipes/libssh/libssh_0.2.bb

diff --git a/recipes/libssh/libssh-native_0.2.bb b/recipes/libssh/libssh-native_0.2.bb
new file mode 100644 (file)
index 0000000..289161d
--- /dev/null
@@ -0,0 +1,4 @@
+require libssh_${PV}.bb
+inherit native
+DEPENDS = ""
+
diff --git a/recipes/libssh/libssh_0.11.bb b/recipes/libssh/libssh_0.11.bb
deleted file mode 100644 (file)
index 833567e..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-SECTION = "libs"
-DESCRIPTION = "The SSH library is a C library to authenticate in a \
-simple manner to one or more SSH servers. The goal of this project \
-is to provide a library much simpler to use than OpenSSHs one. It \
-includes SFTP support, and a sample SSH client is provided."
-DEPENDS = "openssl"
-LICENSE = "LGPL"
-
-DEFAULT_PREFERENCE="-1"
-
-SRC_URI = "http://www.0xbadc0de.be/libssh/libssh-${PV}.tgz"
-
-inherit autotools
-
-EXTRA_OECONF = "--cache-file=${S}/config.cache"
-
-do_stage () {
-       set -x
-       install -d ${STAGING_INCDIR}/libssh
-       for i in crypto.h libssh.h sftp.h ssh2.h; do
-               install -m 0644 ${S}/include/libssh/$i ${STAGING_INCDIR}/libssh/
-       done
-       oe_libinstall -so -C libssh libssh ${STAGING_LIBDIR}
-}
-
-do_install () {
-       oe_runmake "prefix=${D}${prefix}" \
-                  "exec_prefix=${D}${exec_prefix}" \
-                  "bindir=${D}${bindir}" \
-                  "incldir=${D}${includedir}" \
-                  "infodir=${D}${infodir}" \
-                  "mandir=${D}${mandir}/man1" \
-                  "libdir=${D}${libdir}" \
-                  install
-}
index b776094..fb0c4c3 100644 (file)
@@ -1,24 +1,25 @@
-# Released under the MIT license (see COPYING.MIT for the terms)
-
 DESCRIPTION = "The SSH library is a C library to authenticate in a \
 simple manner to one or more SSH servers. The goal of this project \
 is to provide a library much simpler to use than OpenSSHs one. It \
 includes SFTP support, and a sample SSH client is provided."
-
 HOMEPAGE = "http://0xbadc0de.be/wiki/libssh:libssh"
 LICENSE = "LGPL"
 SECTION = "libs"
 DEPENDS = "openssl"
-SRC_URI = "http://www.0xbadc0de.be/libssh/libssh-${PV}.tgz \
-          file://libssh_libdir_fix.patch;patch=1 \
-         "
+
+SRC_URI = "\
+  http://www.0xbadc0de.be/libssh/libssh-${PV}.tgz \
+  file://libssh_libdir_fix.patch;patch=1 \
+"
 inherit autotools
 
 EXTRA_OECONF = "--cache-file=${S}/config.cache"
+
 do_compile () {
        oenote make "$@"
        make "$@" || die "oe_runmake failed"
 }
+
 do_stage () {
        install -d ${STAGING_INCDIR}/libssh
        for i in crypto.h libssh.h sftp.h ssh2.h; do