keymaps: wildcard in SRC_URI doesn't work anymore, specify files
authorAndrea Adami <andrea.adami@gmail.com>
Sun, 22 Mar 2009 17:13:43 +0000 (18:13 +0100)
committerAndrea Adami <andrea.adami@gmail.com>
Sun, 22 Mar 2009 17:13:43 +0000 (18:13 +0100)
- skip linux-2.4 keymaps
- bump PR

recipes/keymaps/keymaps_1.0.bb

index 89b1cfa..5b48fd0 100644 (file)
@@ -3,22 +3,29 @@ SECTION = "base"
 RDEPENDS = "initscripts console-tools"
 LICENSE = "GPL"
 PACKAGE_ARCH = "${MACHINE}"
-PR = "r20"
+PR = "r21"
 
 inherit update-rc.d
 
 SRC_URI = "file://keymap"
 
-SRC_URI_append_c7x0         = " file://keymap-*.map"
-SRC_URI_append_tosa         = " file://keymap-*.map"
-SRC_URI_append_akita        = " file://keymap-*.map"
-SRC_URI_append_spitz        = " file://keymap-*.map"
-SRC_URI_append_collie       = " file://keymap-*.map"
-SRC_URI_append_poodle       = " file://keymap-*.map"
-SRC_URI_append_jornada6xx   = " file://keymap-*.map"
-SRC_URI_append_h2200        = " file://keymap-*.map"
-SRC_URI_append_htcuniversal = " file://keymap-*.map"
-SRC_URI_append_qemux86      = " file://keymap-*.map"
+SRC_URI_append_c7x0         = " file://keymap-2.6.map"
+SRC_URI_append_tosa         = " file://keymap-2.6.map"
+SRC_URI_append_akita        = " file://keymap-2.6.map"
+SRC_URI_append_spitz        = " file://keymap-2.6.map"
+SRC_URI_append_collie       = " file://keymap-2.6.map"
+SRC_URI_append_poodle       = " file://keymap-2.6.map"
+SRC_URI_append_h2200        = " file://keymap-2.6.map"
+SRC_URI_append_htcuniversal = " file://keymap-2.6.map"
+SRC_URI_append_qemux86      = " file://keymap-2.6.map"
+
+SRC_URI_append_jornada6xx   = " file://keymap-620lx-660lx \
+                               file://keymap-br.map \
+                               file://keymap-de.map \
+                               file://keymap-sp.map \
+                               file://keymap-uk.map \
+                               "
+
 
 INITSCRIPT_NAME = "keymap"
 INITSCRIPT_PARAMS = "start 01 S ."