btsco: added bb files for 0.42
authorFrans Meulenbroeks <fransmeulenbroeks@yahoo.com>
Sat, 20 May 2006 19:33:32 +0000 (19:33 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Sat, 20 May 2006 19:33:32 +0000 (19:33 +0000)
packages/btsco/btsco-module-0.42/.mtn2git_empty [new file with mode: 0644]
packages/btsco/btsco-module-0.42/makefile.patch [new file with mode: 0644]
packages/btsco/btsco-module_0.42.bb [new file with mode: 0644]
packages/btsco/btsco_0.42.bb [new file with mode: 0644]

diff --git a/packages/btsco/btsco-module-0.42/.mtn2git_empty b/packages/btsco/btsco-module-0.42/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/btsco/btsco-module-0.42/makefile.patch b/packages/btsco/btsco-module-0.42/makefile.patch
new file mode 100644 (file)
index 0000000..a7beb54
--- /dev/null
@@ -0,0 +1,16 @@
+--- kernel/Makefile.orig       2006-01-13 00:32:58.000000000 +0100
++++ kernel/Makefile    2006-01-13 00:33:35.000000000 +0100
+@@ -10,10 +10,10 @@
+ default:
+-      @make -C /lib/modules/`uname -r`/build M=`pwd` modules
++      $(MAKE) -C $(KERNEL_SRC) M=`pwd` modules
+ install:
+-      @make -C /lib/modules/`uname -r`/build M=`pwd` modules_install
++      $(MAKE) -C $(KERNEL_SRC) M=`pwd` modules_install
+ clean:
+-      @make -C /lib/modules/`uname -r`/build M=`pwd` clean
++      $(MAKE) -C $(KERNEL_SRC) M=`pwd` clean
diff --git a/packages/btsco/btsco-module_0.42.bb b/packages/btsco/btsco-module_0.42.bb
new file mode 100644 (file)
index 0000000..68c13a3
--- /dev/null
@@ -0,0 +1,20 @@
+DESCRIPTION = "Bluetooth-alsa headset module"
+SECTION = "kernel/modules"
+HOMEPAGE = "http://bluetooth-alsa.sourceforge.net/"
+LICENSE = "GPL"
+DEPENDS = "alsa-lib bluez-libs"
+PR = "r0"
+
+inherit module
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bluetooth-alsa/btsco-${PV}.tar.gz \
+          file://makefile.patch;patch=1"
+
+S = "${WORKDIR}/btsco-${PV}/kernel"
+
+MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e'"
+
+do_install() {
+       install -m 0755 -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra
+       install -m 0644 ${S}/snd-bt-sco${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra/
+}
diff --git a/packages/btsco/btsco_0.42.bb b/packages/btsco/btsco_0.42.bb
new file mode 100644 (file)
index 0000000..8411046
--- /dev/null
@@ -0,0 +1,12 @@
+DESCRIPTION = "Bluetooth-alsa headset tool"
+HOMEPAGE = "http://bluetooth-alsa.sourceforge.net/"
+LICENSE = "GPL"
+MAINTAINER = "Robert Woerle <robert@linuxdevelopment.de>"
+DEPENDS = "alsa-lib bluez-libs"
+PR = "r0"
+
+inherit autotools pkgconfig
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bluetooth-alsa/btsco-${PV}.tar.gz"
+
+S = "${WORKDIR}/${PN}-${PV}"