packages/asterisk/asterisk_1.2.18.bb: Enable speex support for asterisk
authorStelios Koroneos <skoroneos@digital-opsis.com>
Sun, 29 Apr 2007 08:25:19 +0000 (08:25 +0000)
committerStelios Koroneos <skoroneos@digital-opsis.com>
Sun, 29 Apr 2007 08:25:19 +0000 (08:25 +0000)
If using a cpu with no fpu make sure that speex compiles with fix-point support

packages/asterisk/asterisk-1.2.18/enable-speex.patch [new file with mode: 0644]
packages/asterisk/asterisk_1.2.18.bb

diff --git a/packages/asterisk/asterisk-1.2.18/enable-speex.patch b/packages/asterisk/asterisk-1.2.18/enable-speex.patch
new file mode 100644 (file)
index 0000000..0f5c578
--- /dev/null
@@ -0,0 +1,21 @@
+--- /codecs/orig-Makefile      2005-11-29 13:24:39.000000000 -0500
++++ /codecs/Makefile   2007-02-28 09:54:42.000000000 -0500
+@@ -29,7 +29,7 @@
+ endif
+ UI_SPEEX=$(wildcard $(CROSS_COMPILE_TARGET)/usr/include/speex.h)
+-UIS_SPEEX=$(wildcard $(CROSS_COMPILE_TARGET)/usr/include/speex/speex.h)
++UIS_SPEEX=$(wildcard $(CROSS_COMPILE_TARGET)/include/speex/speex.h)
+ ULI_SPEEX=$(wildcard $(CROSS_COMPILE_TARGET)/usr/local/include/speex.h)
+ ULIS_SPEEX=$(wildcard $(CROSS_COMPILE_TARGET)/usr/local/include/speex/speex.h)
+ ifneq (${UI_SPEEX},)
+@@ -38,7 +38,8 @@
+ endif
+ ifneq (${UIS_SPEEX},)
+   MODSPEEX=codec_speex.so
+-  CFLAGS+=-I$(CROSS_COMPILE_TARGET)/usr/include/speex
++  CFLAGS+=-I$(CROSS_COMPILE_TARGET)/include/speex
++  LIBSPEEX=-L$(CROSS_COMPILE_TARGET)/lib
+   LIBSPEEX+=-lspeex -lm
+ endif
+ ifneq (${ULI_SPEEX},)
index 0ec55f8..20d20a0 100644 (file)
@@ -1,14 +1,15 @@
 DESCRIPTION="The Asterisk open source software PBX"
 HOMEPAGE="www.asterisk.org"
 LICENSE="GPL"
-DEPENDS="ncurses zlib openssl curl alsa-lib libogg libvorbis popt"
+DEPENDS="ncurses zlib openssl curl alsa-lib libogg libvorbis speex"
 SECTION = "console/telephony"
-PR = "r4"
+PR = "r5"
 
 SRC_URI="http://ftp.digium.com/pub/asterisk/releases/asterisk-${PV}.tar.gz \
         file://uclibc-compat-getloadavg.patch;patch=1 \
         file://uclibc-dsn.patch;patch=1 \
-         file://asterisk.patch;patch=1"
+         file://asterisk.patch;patch=1 \
+         file://enable-speex.patch;patch=1"
 
 S = "${WORKDIR}/asterisk-${PV}"