add tcl (tool command language) and the tk (toolkit) extension
authorMichael Lauer <mickey@vanille-media.de>
Sat, 24 Sep 2005 22:25:03 +0000 (22:25 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Sat, 24 Sep 2005 22:25:03 +0000 (22:25 +0000)
packages/tcltk/.mtn2git_empty [new file with mode: 0644]
packages/tcltk/files/.mtn2git_empty [new file with mode: 0644]
packages/tcltk/files/disable-xim.patch [new file with mode: 0644]
packages/tcltk/tcl_8.4.11.bb [new file with mode: 0644]
packages/tcltk/tk_8.4.11.bb [new file with mode: 0644]

diff --git a/packages/tcltk/.mtn2git_empty b/packages/tcltk/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/tcltk/files/.mtn2git_empty b/packages/tcltk/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/tcltk/files/disable-xim.patch b/packages/tcltk/files/disable-xim.patch
new file mode 100644 (file)
index 0000000..bc11d3b
--- /dev/null
@@ -0,0 +1,20 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- ../generic/tk.h~disable-xim
++++ ../generic/tk.h
+@@ -109,9 +109,9 @@
+  * Decide whether or not to use input methods.
+  */
+-#ifdef XNQueryInputStyle
+-#define TK_USE_INPUT_METHODS
+-#endif
++//#ifdef XNQueryInputStyle
++#undef TK_USE_INPUT_METHODS
++//#endif
+ /*
+  * Dummy types that are used by clients:
diff --git a/packages/tcltk/tcl_8.4.11.bb b/packages/tcltk/tcl_8.4.11.bb
new file mode 100644 (file)
index 0000000..f469130
--- /dev/null
@@ -0,0 +1,36 @@
+DESCRIPTION = "Tool Command Language"
+LICENSE = "tcl"
+SECTION = "devel/tcltk"
+HOMEPAGE = "http://tcl.sourceforge.net"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/tcl/tcl${PV}-src.tar.gz"
+S = "${WORKDIR}/tcl${PV}/unix"
+
+inherit autotools
+
+EXTRA_OECONF = "--enable-threads"
+
+do_configure() {
+       gnu-configize
+       oe_runconf
+}
+
+do_compile_prepend() {
+       echo > ../compat/fixstrtod.c
+}
+
+do_stage() {
+       oe_libinstall -a libtclstub8.4 ${STAGING_LIBDIR}
+       oe_libinstall -so libtcl8.4 ${STAGING_LIBDIR}
+       install -m 0755 tclConfig.sh ${STAGING_BINDIR}
+}
+
+do_install() {
+       autotools_do_install
+       oe_libinstall -so libtcl8.4 ${D}${libdir}
+       ln -sf ./tclsh8.4 ${D}${bindir}/tclsh
+}
+
+FILES_${PN} += "${libdir}/tcl8.4"
+
diff --git a/packages/tcltk/tk_8.4.11.bb b/packages/tcltk/tk_8.4.11.bb
new file mode 100644 (file)
index 0000000..db44a33
--- /dev/null
@@ -0,0 +1,34 @@
+DESCRIPTION = "Tool Command Language ToolKit Extension"
+LICENSE = "tcl"
+SECTION = "devel/tcltk"
+HOMEPAGE = "http://tcl.sourceforge.net"
+DEPENDS = "tcl x11"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/tcl/tk${PV}-src.tar.gz \
+           file://disable-xim.patch;patch=1;pnum=0"
+S = "${WORKDIR}/tk${PV}/unix"
+
+inherit autotools
+
+EXTRA_OECONF = "--enable-threads --with-tcl=${STAGING_BINDIR} \
+               --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR}"
+
+do_configure() {
+       gnu-configize
+       oe_runconf
+}
+
+do_stage() {
+        oe_libinstall -a libtkstub8.4 ${STAGING_LIBDIR}
+        oe_libinstall -so libtk8.4 ${STAGING_LIBDIR}
+        install -m 0755 tkConfig.sh ${STAGING_BINDIR}
+}
+
+do_install() {
+       autotools_do_install
+       oe_libinstall -so libtk8.4 ${D}${libdir}
+       ln -sf ./wish8.4 ${D}${bindir}/wish
+}
+
+FILES_${PN} += "${libdir}/tk8.4"