dpkg: rm rcS.d/S98configure to not run it on non-first boot (from Poky)
authorMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 3 Jul 2008 10:46:27 +0000 (10:46 +0000)
committerMarcin Juszkiewicz <hrw@openembedded.org>
Thu, 23 Oct 2008 18:59:10 +0000 (20:59 +0200)
packages/dpkg/dpkg.inc
packages/dpkg/dpkg_1.13.22.bb
packages/dpkg/dpkg_1.13.25.bb
packages/dpkg/dpkg_1.14.19.bb

index 1065f2c..dfbdf71 100644 (file)
@@ -24,6 +24,7 @@ if [ "x$D" != "x" ]; then
        # this happens at S98 where our good 'ole packages script used to run
        printf "#!/bin/sh
        dpkg --configure -a
+       rm -f /${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}configure
 \n" > ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}configure
        chmod 0755 ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}configure
 fi
index 67d8010..e4e7a3b 100644 (file)
@@ -1,5 +1,5 @@
 require dpkg.inc
-PR = "r4"
+PR = "r5"
 DEPENDS += "zlib bzip2"
 SRC_URI += "file://noman.patch;patch=1"
 
index 96840c9..8a2c8ab 100644 (file)
@@ -1,5 +1,5 @@
 require dpkg.inc
-PR = "r0"
+PR = "r1"
 DEPENDS += "zlib bzip2"
 SRC_URI += "file://noman.patch;patch=1"
 
index b1f84fa..29e718a 100644 (file)
@@ -1,4 +1,5 @@
 require dpkg.inc
+PR = "r1"
 DEPENDS += "zlib bzip2"
 RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives}"
 SRC_URI += "file://noman.patch;patch=1"