perl-native 5.8.8: Fix for cross-compile badness in the perl build. The
authorJamie Lenehan <lenehan@twibble.org>
Sun, 6 May 2007 23:52:01 +0000 (23:52 +0000)
committerJamie Lenehan <lenehan@twibble.org>
Sun, 6 May 2007 23:52:01 +0000 (23:52 +0000)
perl-native configure script was added -I/usr/include/gdbm to the ccflags if
you host had a /usr/include/gdbm/ndbm.h header, even though gdbm support is
disabled. This patch stops the configure script adding that even if it finds
the header there.

packages/perl/perl-5.8.8/native-no-gdbminc.patch [new file with mode: 0644]
packages/perl/perl-native_5.8.8.bb

diff --git a/packages/perl/perl-5.8.8/native-no-gdbminc.patch b/packages/perl/perl-5.8.8/native-no-gdbminc.patch
new file mode 100644 (file)
index 0000000..f00fa2c
--- /dev/null
@@ -0,0 +1,18 @@
+If you have a /usr/include/gdbm/ndbm.h host on the header then the configure
+script adds -I/usr/include/gdbm to the ccflags even though gdbm support is
+disabled. Prevent perl from doing this so we don't get cross compile badness
+errors while building perl.
+
+--- perl-5.8.8/Configure       2007/05/06 23:42:18     1.1
++++ perl-5.8.8/Configure       2007/05/06 23:42:48
+@@ -20033,8 +20033,8 @@
+     # ndbm.h header in /usr/include/gdbm/ndbm.h.
+     if $test -f /usr/include/gdbm/ndbm.h; then
+       echo '<gdbm/ndbm.h> found.'
+-        ccflags="$ccflags -I/usr/include/gdbm"
+-        cppflags="$cppflags -I/usr/include/gdbm"
++#        ccflags="$ccflags -I/usr/include/gdbm"
++#        cppflags="$cppflags -I/usr/include/gdbm"
+         t_ndbm=$define
+     fi
+     ;;
index d6a3dc6..84311d3 100644 (file)
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.perl.org/"
 SECTION = "libs"
 LICENSE = "Artistic|GPL"
 DEPENDS = "virtual/db-native gdbm-native"
-PR = "r4"
+PR = "r6"
 
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/perl-${PV}"
 
@@ -13,7 +13,8 @@ SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
            file://perl-5.8.8-gcc-4.2.patch;patch=1 \
            file://Configure-multilib.patch;patch=1 \
            file://perl-configpm-switch.patch;patch=1 \
-           file://native-nopacklist.patch;patch=1"
+           file://native-nopacklist.patch;patch=1 \
+           file://native-no-gdbminc.patch;patch=1"
 
 S = "${WORKDIR}/perl-${PV}"