linux-2.6.26: add cdc ether support for boc01
authorJeremy Lainé <jeremy.laine@m4x.org>
Wed, 26 Nov 2008 17:10:47 +0000 (18:10 +0100)
committerJeremy Lainé <jeremy.laine@m4x.org>
Wed, 26 Nov 2008 17:10:47 +0000 (18:10 +0100)
packages/linux/linux-2.6.26/boc01/020-cdc-ether-hack.patch [new file with mode: 0644]
packages/linux/linux-2.6.26/boc01/defconfig
packages/linux/linux_2.6.26.bb

diff --git a/packages/linux/linux-2.6.26/boc01/020-cdc-ether-hack.patch b/packages/linux/linux-2.6.26/boc01/020-cdc-ether-hack.patch
new file mode 100644 (file)
index 0000000..ca0ce72
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/drivers/usb/host/ehci-q.c.orig   2008-10-30 15:17:27.000000000 +0100
++++ b/drivers/usb/host/ehci-q.c        2008-10-30 15:23:41.000000000 +0100
+@@ -799,7 +799,7 @@
+                        * to help them do so.  So now people expect to use
+                        * such nonconformant devices with Linux too; sigh.
+                        */
+-                      info1 |= max_packet(maxp) << 16;
++                      info1 |= 256 << 16;
+                       info2 |= (EHCI_TUNE_MULT_HS << 30);
+               } else {                /* PIPE_INTERRUPT */
+                       info1 |= max_packet (maxp) << 16;
index 4b57ab4..42f33db 100644 (file)
@@ -907,7 +907,17 @@ CONFIG_HOSTAP_PCI=m
 # CONFIG_USB_KAWETH is not set
 # CONFIG_USB_PEGASUS is not set
 # CONFIG_USB_RTL8150 is not set
-# CONFIG_USB_USBNET is not set
+CONFIG_USB_USBNET=m
+# CONFIG_USB_NET_AX8817X is not set
+CONFIG_USB_NET_CDCETHER=m
+# CONFIG_USB_NET_DM9601 is not set
+# CONFIG_USB_NET_GL620A is not set
+# CONFIG_USB_NET_NET1080 is not set
+# CONFIG_USB_NET_PLUSB is not set
+# CONFIG_USB_NET_MCS7830 is not set
+# CONFIG_USB_NET_RNDIS_HOST is not set
+# CONFIG_USB_NET_CDC_SUBSET is not set
+# CONFIG_USB_NET_ZAURUS is not set
 # CONFIG_WAN is not set
 CONFIG_ATM_DRIVERS=y
 # CONFIG_ATM_DUMMY is not set
index da84be1..75881ba 100644 (file)
@@ -23,6 +23,7 @@ SRC_URI_append_boc01 = "\
        file://010-081105-mii.patch;patch=1 \
        file://011-081105-gpio.patch;patch=1 \
        file://012-081121-cy3218-btns.patch;patch=1 \
+       file://020-cdc-ether-hack.patch;patch=1 \
        "
 
 SRC_URI_append_mpc8313e-rdb = "\