canadian-sdk: We DO want DEPENDS_prepend to always bring in host virtual gcc/binutils
authorTom Rini <trini@embeddedalley.com>
Fri, 17 Apr 2009 19:58:58 +0000 (12:58 -0700)
committerTom Rini <trini@embeddedalley.com>
Fri, 17 Apr 2009 21:38:39 +0000 (14:38 -0700)
Without this gdb-canadian-sdk would try and build without a host compiler as
it wasn't fixing up this missing dep itself. The comment in the bbclass was
wrong (checked -g on all recipes using this bbclass).

classes/canadian-sdk.bbclass
recipes/binutils/binutils-canadian-sdk_2.18.bb
recipes/make/mingw-make-canadian-sdk_3.81.bb

index 6b4fdf8..a6c5552 100644 (file)
@@ -19,11 +19,7 @@ CFLAGS = "${SDK_CFLAGS}"
 CXXFLAGS = "${SDK_CFLAGS}"
 LDFLAGS = "${SDK_LDFLAGS}"
 
-# TODO: add logic to add the following unless PN ~= gcc*
-#DEPENDS_prepend = "virtual/${HOST_PREFIX}binutils virtual/${HOST_PREFIX}gcc "
-# and otherwise just
-DEPENDS_prepend = "virtual/${HOST_PREFIX}binutils "
-
+DEPENDS_prepend = "virtual/${HOST_PREFIX}binutils virtual/${HOST_PREFIX}gcc "
 
 # On mingw systems we want to have the real sysroot default to c:/... and
 # assume that the default install will be on the C drive.  This can be changed
index e44e7b7..96726f8 100644 (file)
@@ -2,11 +2,7 @@ SECTION = "devel"
 require binutils_${PV}.bb
 inherit canadian-sdk
 
-DEPENDS="\
-       virtual/${HOST_PREFIX}binutils \
-       virtual/${HOST_PREFIX}gcc \
-       flex-native bison-native \
-"
+DEPENDS = "flex-native bison-native"
 
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/binutils-${PV}"
 # On MinGW hosts we want to prepend a drive letter, in ${SDK_REALPATH_MINGW}
index 3479dad..a4b1f72 100644 (file)
@@ -9,8 +9,6 @@ interdependent files, and, if necessary, issues commands \
 to bring them up-to-date - MinGW port."
 HOMEPAGE = "http://www.mingw.org/"
 
-DEPENDS = "virtual/${HOST_PREFIX}binutils virtual/${HOST_PREFIX}gcc"
-
 SRC_URI = "${SOURCEFORGE_MIRROR}/mingw/mingw32-make-3.81-20080326-src.tar.gz"
 
 S = "${WORKDIR}/make-${PV}-patched"