altboot: Update to -wip-20061029
authorMatthias Hentges <oe@hentges.net>
Sun, 29 Oct 2006 12:18:17 +0000 (12:18 +0000)
committerMatthias Hentges <oe@hentges.net>
Sun, 29 Oct 2006 12:18:17 +0000 (12:18 +0000)
- Added a work-around for the broken OUT_TTY assignment on Collie

packages/altboot/altboot_0.0.0.bb
packages/altboot/altboot_1.1.0-wip.bb
packages/altboot/files/init.altboot

index 7130af5..06cf246 100644 (file)
@@ -20,7 +20,7 @@ RDEPENDS_${PN} = "${PN}-conf"
 
 ######################################################################################
 
-PR = "r46"
+PR = "r47"
 
 ######################################################################################
 
index a60e735..38912dc 100644 (file)
@@ -23,7 +23,7 @@ RDEPENDS_${PN}-conf = "${PN}"
 
 ######################################################################################
 
-WIP_DATE = "20061028"
+WIP_DATE = "20061029"
 PR = "${WIP_DATE}-r0"
 
 ######################################################################################
index dc3ff07..b872af2 100644 (file)
@@ -6,7 +6,7 @@
 #
 
 test -e /etc/altboot.func && . /etc/altboot.func || die "ERROR: /etc/altboot.func not found. Check your installation!"
-
 CURRENT_ENV="`set`"
 VERSION="DEVELOPER SNAPSHOT"
 
@@ -17,8 +17,21 @@ REAL_INIT="/sbin/init.sysvinit"
 INIT_RUNLEVEL="`cat /etc/inittab | sed -n "/^id\:/s/id\:\([0-9]\)\:.*$/\1/p"`"
 test -z "$INIT_RUNLEVEL" && INIT_RUNLEVEL=5
 
+# If this step fails the results are fatal. Seen on Collie / kernel 2.4 (where else...)
 OUT_TTY="`tty`" ; test -z "$OUT_TTY" && OUT_TTY="/dev/tty1"
 
+if test -z "$OUT_TTY"
+then
+       OUT_TTY="/dev/tty1"
+       echo "WARNING: Assgnment of OUT_TTY failed!" > "$OUT_TTY"
+fi
+
+if ( echo "$OUT_TTY" | grep -q "not" )
+then
+       OUT_TTY="/dev/tty1"
+       echo "WARNING: Assignment of OUT_TTY failed (2)!" > "$OUT_TTY"
+fi
+
 case "`uname -r`" in
 2.6*)  ALTBOOT_CFG_FILE="/etc/altboot-2.6.cfg";;
 2.4*)  ALTBOOT_CFG_FILE="/etc/altboot-2.4.cfg";;
@@ -34,6 +47,8 @@ then
        rm "${ALTBOOT_CFG_FILE}.next-reboot"
 fi
 
+test "$ENABLE_DEBUGGING" = "yes" && ENABLE_DEBUG="yes"
+
 C_RED="\033[31m"
 C_YELLOW="\033[33m"
 C_BLUE="\033[34m"
@@ -167,9 +182,7 @@ show_sub_menu() {
        #echo "[$d_entries]"
        
        echo -e "\naltboot v$VERSION: $dirname menu\n" 
-       
-       #debug_echo "show_sub_menu(): ping"
-       
+               
        for d_entry in $d_entries
        do
                d_entry_number="`echo "$d_entry"| sed -n "s/\(.*\)\#\#\(.*\)\#\#\#/\1/p"`"
@@ -416,7 +429,7 @@ else
                exec $REAL_INIT $INIT_RUNLEVEL
                exit 0
        fi
-
+       
        # Execute scripts in /etc/altboot.rc before doing anything else.
        # Required in special situations, like booting spitz
        RC_FILES=`ls /etc/altboot.rc | grep \.sh$`