orbit2-native_2.14.0.bb, orbit2_2.14.0.bb : new version
authorGraeme Gregory <dp@xora.org.uk>
Mon, 3 Apr 2006 11:55:03 +0000 (11:55 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Mon, 3 Apr 2006 11:55:03 +0000 (11:55 +0000)
packages/gnome/orbit2-native_2.14.0.bb [new file with mode: 0644]
packages/gnome/orbit2/.mtn2git_empty [new file with mode: 0644]
packages/gnome/orbit2/configure-lossage.patch [new file with mode: 0644]
packages/gnome/orbit2_2.14.0.bb [new file with mode: 0644]

diff --git a/packages/gnome/orbit2-native_2.14.0.bb b/packages/gnome/orbit2-native_2.14.0.bb
new file mode 100644 (file)
index 0000000..c10afb5
--- /dev/null
@@ -0,0 +1,22 @@
+DESCRIPTION = "CORBA ORB"
+LICENSE = "LGPL GPL"
+SECTION = "x11/gnome/libs"
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/ORBit2/2.13/ORBit2-${PV}.tar.bz2 \
+           file://configure-lossage.patch;patch=1;pnum=1 \
+          file://gtk-doc.m4 \
+          file://gtk-doc.make"
+DEPENDS = "libidl-native popt-native gtk-doc"
+
+S = "${WORKDIR}/ORBit2-${PV}"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/orbit2"
+
+PARALLEL_MAKE = ""
+inherit autotools native pkgconfig
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+do_configure_prepend() {
+       mkdir -p m4
+       install ${WORKDIR}/gtk-doc.m4 ./m4/
+       install ${WORKDIR}/gtk-doc.make ./
+}
diff --git a/packages/gnome/orbit2/.mtn2git_empty b/packages/gnome/orbit2/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/gnome/orbit2/configure-lossage.patch b/packages/gnome/orbit2/configure-lossage.patch
new file mode 100644 (file)
index 0000000..7485a0c
--- /dev/null
@@ -0,0 +1,35 @@
+--- orbit/configure.in~        2004-05-07 09:31:32.000000000 +0100
++++ orbit/configure.in 2004-05-08 19:27:35.000000000 +0100
+@@ -193,19 +193,19 @@
+ dnl   So many people with broken linking setups asked about this
+ dnl it turned out to be necessary to check for this.
+ dnl
+-dofus_save_libs="$LIBS"
+-LIBS="$ORBIT_LIBS $LIBS"
+-AC_TRY_RUN([ #include <stdio.h>
+-             main ()
+-             {
+-               return 0;
+-             } ],,
+-           AC_MSG_ERROR([
+-Linking is badly borked on your system. Please ensure your library path is correct
+-Check config.log for details - check near the end of the log above 'failed program was'
+-Alternatively ensure that your /etc/ld.so.conf (and/or LD_LIBRARY_PATH) includes the
+-prefix you're compiling on: '${prefix}' ]))
+-LIBS="$dofus_save_libs"
++dnl dofus_save_libs="$LIBS"
++dnl LIBS="$ORBIT_LIBS $LIBS"
++dnl AC_TRY_RUN([ #include <stdio.h>
++dnl              main ()
++dnl              {
++dnl                return 0;
++dnl              } ],,
++dnl            AC_MSG_ERROR([
++dnl Linking is badly borked on your system. Please ensure your library path is correct
++dnl Check config.log for details - check near the end of the log above 'failed program was'
++dnl Alternatively ensure that your /etc/ld.so.conf (and/or LD_LIBRARY_PATH) includes the
++dnl prefix you're compiling on: '${prefix}' ]))
++dnl LIBS="$dofus_save_libs"
+ orig_CPPFLAGS=$CPPFLAGS
+ CPPFLAGS="$CPPFLAGS $ORBIT_CFLAGS"
diff --git a/packages/gnome/orbit2_2.14.0.bb b/packages/gnome/orbit2_2.14.0.bb
new file mode 100644 (file)
index 0000000..008ec2c
--- /dev/null
@@ -0,0 +1,46 @@
+LICENSE = "GPL"
+PR = "r2"
+DESCRIPTION = "CORBA ORB"
+SECTION = "x11/gnome/libs"
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/ORBit2/2.14/ORBit2-${PV}.tar.bz2 \
+           file://configure-lossage.patch;patch=1;pnum=1 \
+          file://gtk-doc.m4 \
+          file://gtk-doc.make"
+DEPENDS = "libidl popt orbit2-native gtk-doc"
+
+FILES_${PN} += "${libdir}/orbit-2.0/*.so"
+
+S = "${WORKDIR}/ORBit2-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-gtk-doc"
+EXTRA_OEMAKE = "IDL_COMPILER='${STAGING_BINDIR}/orbit-idl-2'"
+
+do_configure_prepend() {
+       mkdir -p m4
+       install ${WORKDIR}/gtk-doc.m4 ./m4/
+       install ${WORKDIR}/gtk-doc.make ./
+}
+
+do_compile_append () {
+       sed 's:^orbit_idl=.*/:orbit_idl=${STAGING_BINDIR}/:' < ORBit-2.0.pc > ORBit-2.0.pc.new
+       mv ORBit-2.0.pc.new ORBit-2.0.pc
+}
+
+do_stage() {
+       oe_libinstall -so -C src/orb libORBit-2 ${STAGING_LIBDIR}
+       oe_libinstall -so -C src/services/name libORBitCosNaming-2 ${STAGING_LIBDIR}
+       oe_libinstall -so -C src/services/imodule libORBit-imodule-2 ${STAGING_LIBDIR}
+       install -m 0644 src/services/name/libname-server-2.a ${STAGING_LIBDIR}/
+
+       for dir in orbit orbit/poa orbit/orb-core orbit/util orbit/dynamic; do
+               install -d ${STAGING_INCDIR}/orbit-2.0/$dir
+               ( cd include/$dir; for i in *.h; do install -m 0644 $i ${STAGING_INCDIR}/orbit-2.0/$dir/$i; done )
+       done
+
+       install -d ${STAGING_INCDIR}/orbit-2.0/ORBitservices
+       install -m 0644 src/services/name/CosNaming.h ${STAGING_INCDIR}/orbit-2.0/ORBitservices/
+       install -m 0644 src/services/name/CosNaming_impl.h ${STAGING_INCDIR}/orbit-2.0/ORBitservices/
+       install -m 0644 src/services/imodule/orbit-imodule.h ${STAGING_INCDIR}/orbit-2.0/ORBitservices/
+}