blackbox: fix path in libbt.pc and bump PR
authorBernhard Guillon <Bernhard.Guillon@opensimpad.org>
Tue, 10 Feb 2009 22:32:52 +0000 (23:32 +0100)
committerBernhard Guillon <Bernhard.Guillon@opensimpad.org>
Tue, 10 Feb 2009 22:32:52 +0000 (23:32 +0100)
packages/blackbox/blackbox_0.70.1.bb

index 50dc5a6..05010f9 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Blackbox Window Manager"
 SECTION = "x11/wm"
 LICENSE = "GPL"
 DEPENDS = "libx11 libxext libxcomposite libxfixes libxdamage libxrender libxinerama libxpm xrandr xft"
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/blackboxwm/blackbox-0.70.1.tar.gz \
   file://remove-host-includes.patch;patch=1"
@@ -12,3 +12,10 @@ inherit autotools pkgconfig
 
 EXTRA_OECONF = "--disable-i18n --without-imlib --with-xpm --with-gnome-menus"
 
+#fix path of pc file
+do_install_append() {
+       sed -i s#${STAGING_LIBDIR}#${libdir}#g ${D}/${libdir}/pkgconfig/libbt.pc
+}
+do_stage_append () {
+       sed -i s#${STAGING_LIBDIR}#${libdir}#g ${STAGING_LIBDIR}/pkgconfig/libbt.pc
+}