autofoo no longer needed
authorHolger Schurig <schurig@mn-solutions.de>
Thu, 10 Mar 2005 10:23:30 +0000 (10:23 +0000)
committerHolger Schurig <schurig@mn-solutions.de>
Thu, 10 Mar 2005 10:23:30 +0000 (10:23 +0000)
don't install your man pages to /usr/share/man !

BKrev: 42302022C7TFAAyEOV3Daq_vopSRBQ

packages/damageext/damageext_cvs.bb
packages/libxrandr/libxrandr_cvs.bb
packages/libxrender/libxrender_cvs.bb
packages/xau/xau_cvs.bb
packages/xdmcp/libxdmcp_cvs.bb

index 95a0d7d..6c68c45 100644 (file)
@@ -6,8 +6,7 @@ DEPENDS = "xextensions fixesext"
 DESCRIPTION = "X Damage extension headers and specification"
 PR = "r1"
 
-SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xlibs;module=DamageExt \
-          file://autofoo.patch;patch=1"
+SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xlibs;module=DamageExt"
 S = "${WORKDIR}/DamageExt"
 
 inherit autotools pkgconfig
index c5b4cff..4e8c96d 100644 (file)
@@ -5,8 +5,7 @@ DEPENDS = "randrext x11 libxrender xext"
 DESCRIPTION = "X Resize and Rotate extension library."
 PR = "r1"
 
-SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xlibs;module=Xrandr \
-          file://autofoo.patch;patch=1"
+SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xlibs;module=Xrandr"
 S = "${WORKDIR}/Xrandr"
 
 inherit autotools pkgconfig 
index e69de29..c04163a 100644 (file)
@@ -0,0 +1,19 @@
+PV = "0.0cvs${CVSDATE}"
+PR = "r1"
+SECTION = "libs"
+DEPENDS = "renderext x11"
+DESCRIPTION = "X Render extension library."
+LICENSE = "BSD"
+
+SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xlibs;module=Xrender"
+S = "${WORKDIR}/Xrender"
+
+inherit autotools pkgconfig 
+
+do_stage() {
+       oe_runmake install prefix=${STAGING_DIR} \
+              bindir=${STAGING_BINDIR} \
+              includedir=${STAGING_INCDIR} \
+              libdir=${STAGING_LIBDIR} \
+              datadir=${STAGING_DATADIR}
+}
index 9e84f8d..ca44359 100644 (file)
@@ -7,8 +7,7 @@ MAINTAINER = "Greg Gilbert <greg@treke.net>"
 DEPENDS = "xproto"
 DESCRIPTION = "Authorization Protocol for X."
 
-SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xlibs;module=Xau \
-          file://autofoo.patch;patch=1"
+SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xlibs;module=Xau"
 S = "${WORKDIR}/Xau"
 
 inherit autotools pkgconfig 
@@ -18,5 +17,6 @@ do_stage() {
               bindir=${STAGING_BINDIR} \
               includedir=${STAGING_INCDIR} \
               libdir=${STAGING_LIBDIR} \
-              datadir=${STAGING_DATADIR}
+              datadir=${STAGING_DATADIR} \
+              mandir=${STAGING_DATADIR}/man
 }
index f59725c..51aa252 100644 (file)
@@ -8,8 +8,7 @@ DEPENDS = "xproto"
 PROVIDES = "xdmcp"
 DESCRIPTION = "X Display Manager Control Protocol library."
 
-SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xlibs;module=Xdmcp \
-          file://autofoo.patch;patch=1"
+SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xlibs;module=Xdmcp"
 S = "${WORKDIR}/Xdmcp"
 
 inherit autotools pkgconfig