qte: fix build failure with modern kernels due to removal of asm/page.h
authorPaul Eggleton <bluelightning@bluelightning.org>
Sun, 8 Nov 2009 15:23:09 +0000 (15:23 +0000)
committerPaul Eggleton <bluelightning@bluelightning.org>
Sun, 8 Nov 2009 15:23:09 +0000 (15:23 +0000)
recipes/qte/qte-2.3.10/fix-qte-asm-include.patch [new file with mode: 0644]
recipes/qte/qte-2.3.10/kernel-asm-page.patch [deleted file]
recipes/qte/qte-common_2.3.10.inc
recipes/qte/qte-mt-static_2.3.10.bb
recipes/qte/qte-mt_2.3.10.bb
recipes/qte/qte_2.3.10.bb

diff --git a/recipes/qte/qte-2.3.10/fix-qte-asm-include.patch b/recipes/qte/qte-2.3.10/fix-qte-asm-include.patch
new file mode 100644 (file)
index 0000000..951bd82
--- /dev/null
@@ -0,0 +1,19 @@
+--- a/src/kernel/qpixmapcache.cpp      2005-01-23 14:00:46.000000000 +0000
++++ b/src/kernel/qpixmapcache.cpp      2009-11-05 22:49:44.000000000 +0000
+@@ -119,13 +119,13 @@
+ #include <time.h>
+ #include <stdio.h>
+ #include <signal.h>
++#include <unistd.h>
+ #ifdef THROW_AWAY_UNUSED_PAGES
+ # include <sys/mman.h> // madvise
+-# include <asm/page.h> // PAGE_SIZE,PAGE_MASK,PAGE_ALIGN
+-# ifndef PAGE_ALIGN
++# define PAGE_SIZE            getpagesize()
++# define PAGE_MASK            (~(PAGE_SIZE-1))
+ # define PAGE_ALIGN(addr)     (((addr)+PAGE_SIZE-1)&PAGE_MASK)
+-# endif // PAGE_ALIGN
+ #endif // THROW_AWAY_UNUSED_PAGES 
diff --git a/recipes/qte/qte-2.3.10/kernel-asm-page.patch b/recipes/qte/qte-2.3.10/kernel-asm-page.patch
deleted file mode 100644 (file)
index bad2d95..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/src/kernel/qpixmapcache.cpp b/src/kernel/qpixmapcache.cpp
-index c2e7d9b..8d39585 100644
---- a/src/kernel/qpixmapcache.cpp
-+++ b/src/kernel/qpixmapcache.cpp
-@@ -123,9 +123,13 @@ void cleanup_pixmap_cache();
- #ifdef THROW_AWAY_UNUSED_PAGES
- # include <sys/mman.h> // madvise
- # include <asm/page.h> // PAGE_SIZE,PAGE_MASK,PAGE_ALIGN
-+# include <unistd.h>  // getpagesize()
-+# if (!defined(PAGE_ALIGN)) && defined(PAGE_SIZE) && defined(PAGE_MASK)
-+#  define PAGE_ALIGN(addr)    (((addr)+PAGE_SIZE-1)&PAGE_MASK)
-+# endif
- # ifndef PAGE_ALIGN
--# define PAGE_ALIGN(addr)     (((addr)+PAGE_SIZE-1)&PAGE_MASK)
--# endif // PAGE_ALIGN
-+#  define PAGE_ALIGN(addr)      (((addr)+getpagesize()-1)&~(getpagesize()-1))
-+# endif
- #endif // THROW_AWAY_UNUSED_PAGES 
index f24a265..cd2aa4f 100644 (file)
@@ -45,9 +45,9 @@ SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-${PV}-free.tar.gz;m
            file://keyboardless-buttonmap.patch;patch=1 \
            file://kernel-keymap.patch;patch=1 \
           file://kernel-keymap-corgi.patch;patch=1 \
-          file://kernel-asm-page.patch;patch=1 \
           file://remove-unused-kbdhandler.patch;patch=1 \
           file://disable-dup-rotation.patch;patch=1 \
+          file://fix-qte-asm-include.patch;patch=1 \
           file://sharp_char.h \
           file://switches.h "
 
index 68ab2ac..35640e5 100644 (file)
@@ -1,5 +1,5 @@
 require qte-common_${PV}.inc
-PR = "r8"
+PR = "r9"
 
 DEFAULT_PREFERENCE = "-1"
 
index 71873dc..00e5d72 100644 (file)
@@ -1,5 +1,5 @@
 require qte-common_${PV}.inc
-PR = "r28"
+PR = "r29"
 
 EXTRA_OECONF += "-thread"
 
index 1183bc2..9a8be94 100644 (file)
@@ -1,3 +1,3 @@
 require qte-common_${PV}.inc
-PR = "r53"
+PR = "r54"