pngcrash 1.6.4: Add tool to optimize PNGs (mostly by size).
authorPaul Sokolovsky <pmiscml@gmail.com>
Sun, 13 Jan 2008 16:32:42 +0000 (16:32 +0000)
committerPaul Sokolovsky <pmiscml@gmail.com>
Sun, 13 Jan 2008 16:32:42 +0000 (16:32 +0000)
* Both target and native versions.

packages/pngcrush/.mtn2git_empty [new file with mode: 0644]
packages/pngcrush/pngcrush-native_1.6.4.bb [new file with mode: 0644]
packages/pngcrush/pngcrush_1.6.4.bb [new file with mode: 0644]

diff --git a/packages/pngcrush/.mtn2git_empty b/packages/pngcrush/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/pngcrush/pngcrush-native_1.6.4.bb b/packages/pngcrush/pngcrush-native_1.6.4.bb
new file mode 100644 (file)
index 0000000..4e119a1
--- /dev/null
@@ -0,0 +1,9 @@
+require pngcrush_${PV}.bb
+
+inherit native
+
+S = "${WORKDIR}/pngcrush-${PV}"
+
+do_stage() {
+        install -m 755 ${S}/pngcrush ${STAGING_BINDIR}/
+}
diff --git a/packages/pngcrush/pngcrush_1.6.4.bb b/packages/pngcrush/pngcrush_1.6.4.bb
new file mode 100644 (file)
index 0000000..9f0413a
--- /dev/null
@@ -0,0 +1,14 @@
+DESCRIPTION = "Tool to optimize PNG images"
+SECTION = "console/graphics"
+HOMEPAGE = "http://pmt.sourceforge.net/pngcrush"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/pmt/pngcrush-${PV}.tar.gz"
+
+#DEPENDS += "libsdl-net smpeg"
+
+EXTRA_OEMAKE = "CC='${CC}' CFLAGS='${CFLAGS}' LD='${CC}'"
+
+do_install () {
+        install -d ${D}${bindir}
+        install -m 755 ${PN} ${D}${bindir}
+}