dreambox-dvb-modules.bb: update dm800/dm8000/dm500hd drivers
authorghost <andreas.monzner@multimedia-labs.de>
Fri, 28 May 2010 19:33:40 +0000 (21:33 +0200)
committerghost <andreas.monzner@multimedia-labs.de>
Fri, 28 May 2010 19:33:40 +0000 (21:33 +0200)
- fix more deadlocks introduced with SMP changes
- better recording/playback/demux performance
- add aspectratio signaling via hdmi avi info frame for 576i/p and 480i
/p
- add vtuner support for multi type tuners
- some internal fixes/changes to improve stability
dm8000:
- generic videooutput, hdmi and videodecoder code update
dm500hd:
- generic videooutput, demux, audio-/videodecoder, hdmi code update
dm800:
- some work on videooutput and hdmi code
  (this hopefully fixes the hdmi connection lost problem)

conf/checksums.ini
recipes/dreambox/dreambox-dvb-modules.bb

index 0e7265b..a129949 100644 (file)
@@ -6122,6 +6122,10 @@ sha256=2578819cea075bca8a463727a1c0699794eb78aa955f8b7b07d4ea9a9c51db08
 md5=e6e449b908aee10869660d429d365b8e
 sha256=524b2897b34d551ee73e7d3588c799ca43e3b226d6fa11b5d5a0bd44016f8db5
 
+[http://sources.dreamboxupdate.com/snapshots/dreambox-dvb-modules-dm500hd-2.6.18-7.3-dm500hd-20100528.tar.bz2]
+md5=77ccb33b076edf6dd12b6daa7097a44f
+sha256=45d18b883b57a38ba28cff9e7c091937c1f832384c0cb1247900da35dbc1150b
+
 [http://sources.dreamboxupdate.com/snapshots/dreambox-dvb-modules-dm500hd-2.6.30-dm500hd-20090727.tar.bz2]
 md5=af8928a01a8f11fa5845821be05774ef
 sha256=be98fe6dab366479f6aefb2bb7c516258cb03e67e718735f2b7787577c7ea188
@@ -6178,6 +6182,10 @@ sha256=fc633ab24920ff143d8bfd5cec30ba7922c015da834da8534cf9ddab80dbc467
 md5=ec53610c0a2fd0bc4d88db0ce4b3f3b4
 sha256=870db75e312456e9659ec8693f7526b1ce60fdfe2bc36d2e64a0b2750c850644
 
+[http://sources.dreamboxupdate.com/snapshots/dreambox-dvb-modules-dm800-2.6.18-7.3-dm800-20100528.tar.bz2]
+md5=a1fe146e3fb5d71beb398625bc345f66
+sha256=bb10585ea69385a56e3612df7e5ea314125b9163a3f1091a4c0b8031e2af4dcb
+
 [http://sources.dreamboxupdate.com/snapshots/dreambox-dvb-modules-dm800-2.6.30-dm800-20090723.tar.bz2]
 md5=41cee549349eb264823d8605525f7d82
 sha256=a7125978936a877238e96683e297da56ebc45bfa91d6a1f6d3ae075fb3cdcff6
@@ -6210,6 +6218,10 @@ sha256=d831e03be6db15ca2723ebb797a8a2643324bb3994dbb221f0033e25ffe2744f
 md5=0b143b8d1347311d20dbd79919f43c5c
 sha256=55f3b98fdccde2177cd4b4debab020cf218e080b2e78ace153f89bf07e1fc788
 
+[http://sources.dreamboxupdate.com/snapshots/dreambox-dvb-modules-dm8000-2.6.18-7.3-dm8000-20100528.tar.bz2]
+md5=9da2625dd15f06bbacccfbe506111b4e
+sha256=952f62668cfc650b8d8a1f2e60060c0c540ee1aaa2f13271117e4c0d2e18781e
+
 [http://sources.dreamboxupdate.com/snapshots/dreambox-dvb-modules-dm8000-2.6.30-dm8000-20090722.tar.bz2]
 md5=1958814f60d0076b0a6192cffef5a99f
 sha256=40a002f33134c97b19b0430d9bbdf4e1cab854d2075df1f5d9b2f275821552f6
index 882ff32..0677a04 100644 (file)
@@ -20,16 +20,16 @@ KV_dm7025 = "2.6.32-dm7025"
 PV_dm7025 = "${KV}-20100303"
 
 KV_dm500hd = "${@base_contains('PREFERRED_VERSION_linux-dm500hd', '2.6.18', '2.6.18-7.3-dm500hd', '2.6.30-dm500hd', d)}"
-PV_dm500hd = "${KV}-${@base_contains('PREFERRED_VERSION_linux-dm500hd', '2.6.18', '20100413', '20090727', d)}"
+PV_dm500hd = "${KV}-${@base_contains('PREFERRED_VERSION_linux-dm500hd', '2.6.18', '20100528', '20090727', d)}"
 
 KV_dm800 = "${@base_contains('PREFERRED_VERSION_linux-dm800', '2.6.18', '2.6.18-7.3-dm800', '2.6.30-dm800', d)}"
-PV_dm800 = "${KV}-${@base_contains('PREFERRED_VERSION_linux-dm800', '2.6.18', '20100414', '20090723', d)}"
+PV_dm800 = "${KV}-${@base_contains('PREFERRED_VERSION_linux-dm800', '2.6.18', '20100528', '20090723', d)}"
 
 KV_dm8000 = "${@base_contains('PREFERRED_VERSION_linux-dm8000', '2.6.18', '2.6.18-7.3-dm8000', '2.6.30-dm8000', d)}"
-PV_dm8000 = "${KV}-${@base_contains('PREFERRED_VERSION_linux-dm8000', '2.6.18', '20100413', '20090820', d)}"
+PV_dm8000 = "${KV}-${@base_contains('PREFERRED_VERSION_linux-dm8000', '2.6.18', '20100528', '20090820', d)}"
 
 RDEPENDS = "kernel (${KV})"
-PR = "r1"
+PR = "r0"
 
 SRC_URI = "http://sources.dreamboxupdate.com/snapshots/dreambox-dvb-modules-${MACHINE}-${PV}.tar.bz2 "
 SRC_URI_append_dm7025 = "http://sources.dreamboxupdate.com/download/7020/fpupgrade-${MACHINE}-v7"
@@ -61,5 +61,20 @@ do_install_mipsel_append_dm8000() {
        install -m 0755 ${WORKDIR}/fpupgrade-${MACHINE}-v7 ${D}${sbindir}/fpupgrade
 }
 
+pkg_postinst_dreambox-dvb-modules () {
+       if [ -d /proc/stb ]; then
+               depmod -ae
+               update-modules
+       fi
+       true
+}
+
+pkg_postrm_dreambox-dvb-modules () {
+       if [ -d /proc/stb ]; then
+               update-modules
+       fi
+       true
+}
+
 PACKAGE_ARCH := "${MACHINE_ARCH}"
 FILES_${PN} = "/"