merge of '00ee303d8d48b4b6a0a7480dea928c8d02252f80'
authorMatt Reimer <mattjreimer@gmail.com>
Tue, 14 Nov 2006 23:09:05 +0000 (23:09 +0000)
committerMatt Reimer <mattjreimer@gmail.com>
Tue, 14 Nov 2006 23:09:05 +0000 (23:09 +0000)
     and '376cbb96ee80de7e5cc9e7ceff199d6f09fe42d8'

packages/python/python-sword_1.5.9.bb [new file with mode: 0644]
packages/sword/sword_1.5.9.bb [new file with mode: 0644]

diff --git a/packages/python/python-sword_1.5.9.bb b/packages/python/python-sword_1.5.9.bb
new file mode 100644 (file)
index 0000000..6c777bb
--- /dev/null
@@ -0,0 +1,31 @@
+DESCRIPTION = "Python bindings for the sword library"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "python-core sword"
+DEPENDS = "sword-${PV} swig-native"
+SRCNAME = "sword"
+PR = "r0"
+
+SRC_URI = "http://crosswire.org/ftpmirror/pub/sword/source/v1.5/sword-${PV}.tar.gz"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}/bindings/swig/package"
+
+EXTRA_OECONF = "--with-sword-dir=${STAGING_DIR}/${HOST_SYS}"
+
+inherit distutils autotools
+
+PARALLEL_MAKE = ""
+
+#do_configure_prepend() {
+#      ./autogen.sh
+#}
+
+do_compile() {
+        oe_runmake BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} pythonswig python_make
+}
+
+do_install() {
+       cd ${S}/python
+       distutils_do_install
+}
diff --git a/packages/sword/sword_1.5.9.bb b/packages/sword/sword_1.5.9.bb
new file mode 100644 (file)
index 0000000..362b75e
--- /dev/null
@@ -0,0 +1,27 @@
+DESCRIPTION = "The SWORD Project is an open source, cross-platform \
+(Linux, Windows, Solaris, MacOSX etc.) API and library for \
+Bible software with a constantly growing list of front-ends \
+(GUI, textmode, web-based, etc.) and a library of over 200 text modules"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.crosswire.org/ftpmirror/pub/sword/source/v1.5/sword-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--without-clucene --without-curl"
+
+do_stage() {
+       oe_libinstall -so -C lib libsword ${STAGING_LIBDIR}
+
+       install -d ${STAGING_INCDIR}/sword/
+       for f in include/*.h
+       do
+               install -m 0644 $f ${STAGING_INCDIR}/sword/
+       done
+
+}
+
+FILES_${PN} = "${libdir}/libsword*so ${sysconfdir} ${bindir} ${datadir}"