merge of '5205c4bbe6c22164549099dae6ac17f506611c18'
authorOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Wed, 17 Sep 2008 16:02:12 +0000 (16:02 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Wed, 17 Sep 2008 16:02:12 +0000 (16:02 +0000)
     and '53a39bdeb01bc91193b8a56e10450806ba2f759a'

25 files changed:
packages/angstrom/angstrom-gpe-task-base.bb
packages/efl1/eet_svn.bb
packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-eeprom.patch [new file with mode: 0644]
packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-lm75.patch [new file with mode: 0644]
packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-spi.patch [new file with mode: 0644]
packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-watchdog.patch [new file with mode: 0644]
packages/u-boot/u-boot_1.3.2.bb
packages/xorg-xserver/xorg-xserver-common.inc
packages/xorg-xserver/xserver-kdrive-common.inc
packages/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb
packages/xorg-xserver/xserver-kdrive-imageon_1.2.0.bb
packages/xorg-xserver/xserver-kdrive-xomap_1.1.99.3.bb
packages/xorg-xserver/xserver-kdrive_1.1.0.bb
packages/xorg-xserver/xserver-kdrive_1.2.0.bb
packages/xorg-xserver/xserver-kdrive_1.3.0.0.bb
packages/xorg-xserver/xserver-kdrive_1.4.0.90.bb
packages/xorg-xserver/xserver-kdrive_1.4.2.bb
packages/xorg-xserver/xserver-kdrive_1.4.99.901.bb
packages/xorg-xserver/xserver-kdrive_1.4.bb
packages/xorg-xserver/xserver-kdrive_git.bb
packages/xorg-xserver/xserver-xorg_1.2.0.bb
packages/xorg-xserver/xserver-xorg_1.3.0.0.bb
packages/xorg-xserver/xserver-xorg_1.4.2.bb
packages/xorg-xserver/xserver-xorg_1.4.bb
packages/xorg-xserver/xserver-xorg_cvs.bb

index 3762d78..656180d 100644 (file)
@@ -1,5 +1,5 @@
 DESCRIPTION = "Task packages for the Angstrom distribution"
-PR = "r35"
+PR = "r36"
 
 inherit task
 
@@ -28,7 +28,6 @@ RDEPENDS_${PN} = "\
     gpe-confd \
     gpe-autostarter \
     ${@base_contains("MACHINE_FEATURES", "touchscreen", "libgtkstylus", "",d)} \
-    ${@base_contains("MACHINE_FEATURES", "keyboard", "", "libgtkinput",d)} \
     suspend-desktop \
     teleport \
     xauth \
index 2fa24cc..20f4946 100644 (file)
@@ -1,5 +1,5 @@
 DESCRIPTION = "EET is the Enlightenment data storage library"
-DEPENDS = "zlib jpeg"
+DEPENDS = "zlib jpeg openssl"
 LICENSE = "MIT BSD"
 PV = "1.0.1+svnr${SRCREV}"
 PR = "r1"
diff --git a/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-eeprom.patch b/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-eeprom.patch
new file mode 100644 (file)
index 0000000..bdc69d9
--- /dev/null
@@ -0,0 +1,21 @@
+Index: u-boot-1.3.2/include/configs/MPC8313ERDB.h
+===================================================================
+--- u-boot-1.3.2.orig/include/configs/MPC8313ERDB.h    2008-09-12 18:52:50.000000000 +0200
++++ u-boot-1.3.2/include/configs/MPC8313ERDB.h 2008-09-12 18:52:58.000000000 +0200
+@@ -263,6 +263,16 @@
+ #define CFG_I2C_OFFSET                0x3000
+ #define CFG_I2C2_OFFSET               0x3100
++/*
++ * EEPROM configuration
++ */
++#define CONFIG_CMD_EEPROM
++#define CFG_I2C_EEPROM_ADDR_LEN               2       /* 16-bit EEPROM address */
++#define CFG_I2C_EEPROM_ADDR           0x50    /* Atmel: AT24C256*/
++#define CFG_EEPROM_PAGE_WRITE_DELAY_MS        10      /* 10ms of delay */
++#define CFG_EEPROM_PAGE_WRITE_BITS    6       /* 64-Byte Page Write Mode */
++#define CFG_EEPROM_PAGE_WRITE_ENABLE
++
+ /* TSEC */
+ #define CFG_TSEC1_OFFSET      0x24000
+ #define CFG_TSEC1             (CFG_IMMR+CFG_TSEC1_OFFSET)
diff --git a/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-lm75.patch b/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-lm75.patch
new file mode 100644 (file)
index 0000000..d9331dd
--- /dev/null
@@ -0,0 +1,23 @@
+Index: u-boot-1.3.2/include/configs/MPC8313ERDB.h
+===================================================================
+--- u-boot-1.3.2.orig/include/configs/MPC8313ERDB.h    2008-09-12 18:52:58.000000000 +0200
++++ u-boot-1.3.2/include/configs/MPC8313ERDB.h 2008-09-12 18:53:10.000000000 +0200
+@@ -370,6 +370,7 @@
+ #define CONFIG_CMD_PCI
+ #define CONFIG_CMD_NAND
+ #define CONFIG_CMD_SPI
++#define CONFIG_CMD_DTT
+ #if defined(CFG_RAMBOOT)
+     #undef CONFIG_CMD_ENV
+@@ -392,6 +393,10 @@
+ #define MTDPARTS_DEFAULT      "mtdparts=physmap-flash.0:384k(uboot),64k(env)"
++/* Digital Thermometer and Thermostat */
++#define CONFIG_DTT_LM75               1
++#define CONFIG_DTT_SENSORS    { 0x48 }
++
+ /*
+  * Miscellaneous configurable options
+  */
diff --git a/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-spi.patch b/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-spi.patch
new file mode 100644 (file)
index 0000000..039996c
--- /dev/null
@@ -0,0 +1,70 @@
+Index: u-boot-1.3.2/board/freescale/mpc8313erdb/mpc8313erdb.c
+===================================================================
+--- u-boot-1.3.2.orig/board/freescale/mpc8313erdb/mpc8313erdb.c        2008-09-12 18:48:23.000000000 +0200
++++ u-boot-1.3.2/board/freescale/mpc8313erdb/mpc8313erdb.c     2008-09-12 18:50:10.000000000 +0200
+@@ -28,6 +28,7 @@
+ #endif
+ #include <pci.h>
+ #include <mpc83xx.h>
++#include <spi.h> 
+ DECLARE_GLOBAL_DATA_PTR;
+@@ -107,3 +108,33 @@
+ #endif
+ }
+ #endif
++
++
++/*
++ * The following are used to control the SPI chip selects for the SPI command.
++ */
++#ifdef CONFIG_HARD_SPI
++
++#define SPI_CS_MASK   0x80000000
++
++void spi_eeprom_chipsel(int cs)
++{
++      volatile gpio83xx_t *iopd = &((immap_t *)CFG_IMMR)->gpio[0];
++
++      if (cs)
++              iopd->dat &= ~SPI_CS_MASK;
++      else
++              iopd->dat |=  SPI_CS_MASK;
++}
++
++/*
++ * The SPI command uses this table of functions for controlling the SPI
++ * chip selects.
++ */
++spi_chipsel_type spi_chipsel[] = {
++      spi_eeprom_chipsel,
++};
++int spi_chipsel_cnt = sizeof(spi_chipsel) / sizeof(spi_chipsel[0]);
++
++#endif /* CONFIG_HARD_SPI */
++
+Index: u-boot-1.3.2/include/configs/MPC8313ERDB.h
+===================================================================
+--- u-boot-1.3.2.orig/include/configs/MPC8313ERDB.h    2008-09-12 18:50:09.000000000 +0200
++++ u-boot-1.3.2/include/configs/MPC8313ERDB.h 2008-09-12 18:50:50.000000000 +0200
+@@ -359,6 +359,7 @@
+ #define CONFIG_CMD_DATE
+ #define CONFIG_CMD_PCI
+ #define CONFIG_CMD_NAND
++#define CONFIG_CMD_SPI
+ #if defined(CFG_RAMBOOT)
+     #undef CONFIG_CMD_ENV
+@@ -367,6 +368,11 @@
+ #define CONFIG_CMDLINE_EDITING 1
++/* SPI */
++#define CONFIG_MPC8XXX_SPI
++#define CONFIG_HARD_SPI                       /* SPI with hardware support */
++#undef CONFIG_SOFT_SPI                        /* SPI bit-banged */
++
+ /*
+  * JFFS2 partitions (mtdparts command line support)
+  */
diff --git a/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-watchdog.patch b/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-watchdog.patch
new file mode 100644 (file)
index 0000000..db92fea
--- /dev/null
@@ -0,0 +1,15 @@
+Index: u-boot-1.3.2/include/configs/MPC8313ERDB.h
+===================================================================
+--- u-boot-1.3.2.orig/include/configs/MPC8313ERDB.h    2008-09-12 18:47:22.000000000 +0200
++++ u-boot-1.3.2/include/configs/MPC8313ERDB.h 2008-09-12 18:48:11.000000000 +0200
+@@ -460,6 +460,10 @@
+       HRCWH_BIG_ENDIAN |\
+       HRCWH_LALE_NORMAL)
++/* Watchdog */
++#define CONFIG_WATCHDOG
++#define CFG_WATCHDOG_VALUE 0xFFFF
++
+ /* System IO Config */
+ #define CFG_SICRH     (SICRH_TSOBI1 | SICRH_TSOBI2)   /* RGMII */
+ #define CFG_SICRL     SICRL_USBDR                     /* Enable Internal USB Phy  */
index 8e806ef..d610526 100644 (file)
@@ -2,7 +2,7 @@ require u-boot.inc
 
 DEFAULT_PREFERENCE = "-1"
 
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2"
 
@@ -10,6 +10,9 @@ SRC_URI_append_mpc8313e-rdb = "\
            file://mpc8313e-rdb-autoboot.patch;patch=1 \
            file://mpc8313e-rdb-mtdparts.patch;patch=1 \
            file://mpc8313e-rdb-nand.patch;patch=1 \
+           file://mpc8313e-rdb-spi.patch;patch=1 \
+           file://mpc8313e-rdb-eeprom.patch;patch=1 \
+           file://mpc8313e-rdb-lm75.patch;patch=1 \
            file://u-boot-fsl-1.3.0-mpc8313erdb-vsc7385-support.patch;patch=1 \
            file://u-boot-fsl-1.3.0-mpc8313erdb-fix-vitesse-7385-firmware.patch;patch=1 \
            file://u-boot-fsl-1.3.0-mpc8313erdb-performance-tuning-for-TSEC.patch;patch=1 \
index 8e7c5d7..0b06425 100644 (file)
@@ -23,12 +23,16 @@ S = "${WORKDIR}/${XORG_PN}-${PV}"
 
 inherit autotools pkgconfig
 
+PACKAGES =+ "xserver-security-policy"
+FILES_xserver-security-policy += "${libdir}/xserver/SecurityPolicy"
+RRECOMMENDS_${PN} += "xserver-security-policy"
+
 PACKAGES =+ "${PN}-xprint ${PN}-xvfb ${PN}-utils"
 
 FILES_${PN}-xprint = "${libdir}/X11/xserver/*/print"
 FILES_${PN}-xvfb = "${bindir}/Xvfb"
 FILES_${PN}-utils = "${bindir}/scanpci ${bindir}/pcitweak ${bindir}/ioport ${bindir}/in[bwl] ${bindir}/out[bwl] ${bindir}/mmap[rw] ${bindir}/gtf ${bindir}/getconfig ${bindir}/getconfig.pl"
-FILES_${PN} = "${bindir} ${libdir}/X11/Options ${libdir}/X11/Cards ${libdir}/X11/getconfig ${libdir}/X11/etc ${libdir}/xserver/SecurityPolicy ${libdir}/modules ${libdir}/xorg/modules /etc/X11 "
+FILES_${PN} = "${bindir} ${libdir}/X11/Options ${libdir}/X11/Cards ${libdir}/X11/getconfig ${libdir}/X11/etc ${libdir}/modules ${libdir}/xorg/modules /etc/X11 "
 FILES_${PN}-doc += "${libdir}/X11/doc /usr/share/X11/xkb/compiled/README.compiled"
 
 FILES_${PN}-dbg += "${libdir}/xorg/modules/.debug \
index bfa4380..3db7db4 100644 (file)
@@ -45,7 +45,9 @@ DESCRIPTION_xserver-kdrive-smi = "X server from freedesktop.org, supporting Sili
 DESCRIPTION_xserver-kdrive-vesa = "X server from freedesktop.org, supporting any card with a VESA, VGA or even EGA BIOS. x86 hardware only"
 DESCRIPTION_xserver-kdrive-via = "X server from freedesktop.org, supporting VIA chipsets"
 
-FILES_${PN} += "${libdir}/xserver/SecurityPolicy"
+PACKAGES =+ "xserver-security-policy"
+FILES_xserver-security-policy += "${libdir}/xserver/SecurityPolicy"
+RRECOMMENDS_${PN} += "xserver-security-policy"
 
 FILES_xserver-kdrive-fbdev = "${bindir}/Xfbdev"
 FILES_xserver-kdrive-fake = "${bindir}/Xfake"
index 8c285b7..cb29cfd 100644 (file)
@@ -11,7 +11,7 @@ PROVIDES = "virtual/xserver"
 
 PE = "1"
 PV = "1.3.0.0+gitr${SRCREV}"
-PR = "r0"
+PR = "r1"
 
 COMPATIBLE_HOST = "arm.*-linux"
 COMPATIBLE_MACHINE = 'om-gta02'
index 54fe19d..aef08c8 100644 (file)
@@ -7,7 +7,7 @@ DEPENDS += "libxkbfile libxcalibrate"
 PROVIDES = "virtual/xserver"
 
 PE = "1"
-PR = "r4"
+PR = "r5"
 
 FILESPATH = "${FILE_DIRNAME}/xserver-kdrive-${PV}:${FILE_DIRNAME}/xserver-kdrive:${FILE_DIRNAME}/files"
 SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
index c87f4ab..57f7050 100644 (file)
@@ -7,7 +7,7 @@ SECTION = "x11/base"
 DESCRIPTION = "X server from freedesktop.org"
 DESCRIPTION_xserver-kdrive-xomap = "X server for the OMAP in the Nokia 800"
 
-PR = "r1"
+PR = "r2"
 PE = "1"
 
 COMPATIBLE_MACHINE = "nokia(800|770)"
index 5fdf7c4..be6fc82 100644 (file)
@@ -10,6 +10,7 @@ DESCRIPTION_xserver-kdrive-fake = "Fake X server"
 DESCRIPTION_xserver-kdrive-xephyr = "X server in an X window"
 
 PE = "1"
+PR = "r1"
 
 FILES_${PN} = "${libdir}/xserver"
 FILES_xserver-kdrive-fbdev = "${bindir}/Xfbdev"
index 3b5e62c..e1b898e 100644 (file)
@@ -3,7 +3,7 @@ require xserver-kdrive-common.inc
 DEPENDS += "libxkbfile libxcalibrate"
 
 PE = "1"
-PR = "r9"
+PR = "r10"
 
 SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
        ${KDRIVE_COMMON_PATCHES} \
index 4a1a709..19669e4 100644 (file)
@@ -3,7 +3,7 @@ require xserver-kdrive-common.inc
 DEPENDS += "libxkbfile libxcalibrate"
 
 PE = "1"
-PR = "r25"
+PR = "r26"
 
 SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
        ${KDRIVE_COMMON_PATCHES} \
index 1583cc3..922d8f5 100644 (file)
@@ -3,7 +3,7 @@ require xserver-kdrive-common.inc
 DEPENDS += "hal libxkbfile libxcalibrate pixman"
 
 PE = "1"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
        ${KDRIVE_COMMON_PATCHES} \
index 1583cc3..922d8f5 100644 (file)
@@ -3,7 +3,7 @@ require xserver-kdrive-common.inc
 DEPENDS += "hal libxkbfile libxcalibrate pixman"
 
 PE = "1"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
        ${KDRIVE_COMMON_PATCHES} \
index ea6179a..04470d3 100644 (file)
@@ -5,7 +5,7 @@ DEPENDS += "hal libxkbfile libxcalibrate pixman"
 DEFAULT_PREFERENCE = "-99" 
 
 PE = "1"
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
        ${KDRIVE_COMMON_PATCHES} \
index 30ae4a2..5a46d7d 100644 (file)
@@ -3,7 +3,7 @@ require xserver-kdrive-common.inc
 DEPENDS += "hal libxkbfile libxcalibrate pixman"
 
 PE = "1"
-PR = "r4"
+PR = "r5"
 
 SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
        ${KDRIVE_COMMON_PATCHES} \
index ce48c0e..2e1da5c 100644 (file)
@@ -6,6 +6,7 @@ PV = "1.4+git${SRCDATE}"
 DEPENDS += "libxkbfile libxcalibrate pixman"
 
 PE = "1"
+PR = "r1"
 
 FILESPATH = "${FILE_DIRNAME}/xserver-kdrive-git:${FILE_DIRNAME}/xserver-kdrive"
 SRC_URI = "git://anongit.freedesktop.org/xorg/xserver;protocol=git \
index 421e044..f63f19c 100644 (file)
@@ -2,6 +2,7 @@ MESA_VER = "6.5.2"
 
 require xorg-xserver-common.inc
 PE = "1"
+PR = "r1"
 
 EXTRA_OECONF += " ac_cv_file__usr_share_sgml_X11_defs_ent=no "
 
index a9b8afc..572c434 100644 (file)
@@ -2,7 +2,7 @@ MESA_VER = "6.5.2"
 
 require xorg-xserver-common.inc
 PE = "1"
-PR = "r4"
+PR = "r5"
 
 SRC_URI += "file://drmfix.patch;patch=1 \
             file://glyphstr.patch;patch=1"
index c9f6e3d..716c432 100644 (file)
@@ -3,7 +3,7 @@ require xorg-xserver-common.inc
 DESCRIPTION = "the X.Org X server"
 DEPENDS += "pixman"
 PE = "1"
-PR = "r4"
+PR = "r5"
 
 SRC_URI += "file://drmfix.patch;patch=1 \
             file://pkgconfig_fix.patch;patch=1 \
index c9f6e3d..716c432 100644 (file)
@@ -3,7 +3,7 @@ require xorg-xserver-common.inc
 DESCRIPTION = "the X.Org X server"
 DEPENDS += "pixman"
 PE = "1"
-PR = "r4"
+PR = "r5"
 
 SRC_URI += "file://drmfix.patch;patch=1 \
             file://pkgconfig_fix.patch;patch=1 \
index e8e19aa..cc027fd 100644 (file)
@@ -1,7 +1,7 @@
 SECTION = "x11/base"
 LICENSE = "Xorg"
 PROVIDES = "virtual/xserver"
-PR = "r3"
+PR = "r4"
 PV = "6.8.1+cvs${SRCDATE}"
 
 DEPENDS = "fontconfig freetype libxi libxmu flex-2.5.4-native"