packages/libpcap/libpcap_0.9.6.bb : Add libpcap 0.9.6
authorStelios Koroneos <skoroneos@digital-opsis.com>
Tue, 19 Jun 2007 10:33:42 +0000 (10:33 +0000)
committerStelios Koroneos <skoroneos@digital-opsis.com>
Tue, 19 Jun 2007 10:33:42 +0000 (10:33 +0000)
packages/libpcap/libpcap-0.9.6/.mtn2git_empty [new file with mode: 0644]
packages/libpcap/libpcap_0.9.6.bb [new file with mode: 0644]

diff --git a/packages/libpcap/libpcap-0.9.6/.mtn2git_empty b/packages/libpcap/libpcap-0.9.6/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/libpcap/libpcap_0.9.6.bb b/packages/libpcap/libpcap_0.9.6.bb
new file mode 100644 (file)
index 0000000..d68cd31
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+DESCRIPTION = "Network Packet Capture Library"
+HOMEPAGE = "http://www.tcpdump.org/"
+LICENSE = "BSD"
+SECTION = "libs/network"
+PR = "r0"
+
+SRC_URI = "http://www.tcpdump.org/release/libpcap-${PV}.tar.gz \
+           file://shared.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-pcap=linux"
+
+CPPFLAGS_prepend = "-I${S} "
+CFLAGS_prepend = "-I${S} "
+CXXFLAGS_prepend = "-I${S} "
+
+do_configure_prepend () {
+       if [ ! -e acinclude.m4 ]; then
+               cat aclocal.m4 > acinclude.m4
+       fi
+}
+
+do_stage () {
+       install -m 0644 pcap.h ${STAGING_INCDIR}/pcap.h
+       install -m 0644 pcap-namedb.h ${STAGING_INCDIR}/pcap-namedb.h
+       install -m 0644 pcap-bpf.h ${STAGING_INCDIR}/pcap-bpf.h
+       oe_libinstall -a -so libpcap ${STAGING_LIBDIR}
+       install -d ${STAGING_INCDIR}/net
+       ln -sf ${STAGING_INCDIR}/pcap-bpf.h ${STAGING_INCDIR}/net/bpf.h
+       install -m 0644 acinclude.m4 ${STAGING_DATADIR}/aclocal/libpcap.m4
+}