enigma2 : fix choicebox summarytext.
authorchang <chang@dev3>
Fri, 25 Jan 2013 10:11:31 +0000 (19:11 +0900)
committerchang <chang@dev3>
Fri, 25 Jan 2013 10:11:31 +0000 (19:11 +0900)
14 files changed:
recipes/enigma2/enigma2.bb
recipes/enigma2/enigma2/vuduo2/enigma2_choicebox_duo2.patch [deleted file]
recipes/enigma2/enigma2/vuduo2/skin_user.xml [deleted file]
recipes/enigma2/enigma2/vuduo2/vfd_icons/crypt.png [deleted file]
recipes/enigma2/enigma2/vuduo2/vfd_icons/dolby.png [deleted file]
recipes/enigma2/enigma2/vuduo2/vfd_icons/format.png [deleted file]
recipes/enigma2/enigma2/vuduo2/vfd_icons/rec.png [deleted file]
recipes/enigma2/enigma2/vuduo2/vfd_icons/teletext.png [deleted file]
recipes/enigma2/enigma2/vuplus/skin_user_vuduo2.xml [new file with mode: 0644]
recipes/enigma2/enigma2/vuplus/vfd_icons_vuduo2/crypt.png [new file with mode: 0755]
recipes/enigma2/enigma2/vuplus/vfd_icons_vuduo2/dolby.png [new file with mode: 0755]
recipes/enigma2/enigma2/vuplus/vfd_icons_vuduo2/format.png [new file with mode: 0755]
recipes/enigma2/enigma2/vuplus/vfd_icons_vuduo2/rec.png [new file with mode: 0755]
recipes/enigma2/enigma2/vuplus/vfd_icons_vuduo2/teletext.png [new file with mode: 0755]

index 4400603..ba10958 100644 (file)
@@ -77,7 +77,7 @@ RDEPENDS_enigma2-plugin-extensions-hbbtv = "tslib-conf libts-1.0-0 libsysfs2 lib
 RDEPENDS_enigma2-plugin-systemplugins-devicemanager = "util-linux-ng-blkid ntfs-3g dosfstools"
 
 PN = "enigma2"
-PR = "r68"
+PR = "r69"
 
 SRCDATE = "20110922"
 SRCREV = "5e19a3f8a5e8ce8a4e2cb2b601a1b8ef3554e4be"
@@ -152,9 +152,8 @@ SRC_URI_append_vuultimo = " \
 "
 
 SRC_URI_append_vuduo2 = " \
-           file://enigma2_choicebox_duo2.patch;patch=1;pnum=1 \
-           file://skin_user.xml \
-           file://vfd_icons \
+           file://skin_user_vuduo2.xml \
+           file://vfd_icons_vuduo2 \
 "
 
 def change_po():
@@ -230,9 +229,9 @@ do_install_append_vuultimo() {
 }
 
 do_install_append_vuduo2() {
-        install -m 0755 ${WORKDIR}/skin_user.xml ${D}/usr/share/enigma2/defaults/
+        install -m 0755 ${WORKDIR}/skin_user_vuduo2.xml ${D}/usr/share/enigma2/defaults/skin_user.xml
         install -d ${D}/usr/share/enigma2/vfd_icons/
-        install -m 0755 ${WORKDIR}/vfd_icons/*.png ${D}/usr/share/enigma2/vfd_icons/
+        install -m 0755 ${WORKDIR}/vfd_icons_vuduo2/*.png ${D}/usr/share/enigma2/vfd_icons/
 }
 
 python populate_packages_prepend () {
diff --git a/recipes/enigma2/enigma2/vuduo2/enigma2_choicebox_duo2.patch b/recipes/enigma2/enigma2/vuduo2/enigma2_choicebox_duo2.patch
deleted file mode 100644 (file)
index 70313f4..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-diff --git a/lib/python/Plugins/SystemPlugins/WirelessAccessPoint/plugin.py b/lib/python/Plugins/SystemPlugins/WirelessAccessPoint/plugin.py
-index ff6849d..1416e31 100755
---- a/lib/python/Plugins/SystemPlugins/WirelessAccessPoint/plugin.py
-+++ b/lib/python/Plugins/SystemPlugins/WirelessAccessPoint/plugin.py
-@@ -523,9 +523,12 @@ class WirelessAccessPoint(Screen,ConfigListScreen):
-               sysctlList = {}
-               for line in sysctlLines:
-                       line = line.strip()
--                      (key,value) = line.split("=")
--                      key=key.strip()
--                      value=value.strip()
-+                      try:
-+                              (key,value) = line.split("=")
-+                              key=key.strip()
-+                              value=value.strip()
-+                      except:
-+                              continue
-                       sysctlList[key] = value
-               sysctlList["net.ipv4.ip_forward"] = str(setValue)
-               fp = file(sysctlPath, "w")
-diff --git a/lib/python/Screens/ChoiceBox.py b/lib/python/Screens/ChoiceBox.py
-old mode 100644
-new mode 100755
-index 7c8b142..bd22582
---- a/lib/python/Screens/ChoiceBox.py
-+++ b/lib/python/Screens/ChoiceBox.py
-@@ -121,12 +121,9 @@ class ChoiceBox(Screen):
-               pos = 0
-               summarytext = ""
-               for entry in self.summarylist:
--                      if pos > curpos-2 and pos < curpos+5:
--                              if pos == curpos:
--                                      summarytext += ">"
--                              else:
--                                      summarytext += entry[0]
--                              summarytext += ' ' + entry[1] + '\n'
-+                      if pos == curpos:
-+                              summarytext += entry[0]+' ' + entry[1]
-+                              break
-                       pos += 1
-               self["summary_list"].setText(summarytext)
diff --git a/recipes/enigma2/enigma2/vuduo2/skin_user.xml b/recipes/enigma2/enigma2/vuduo2/skin_user.xml
deleted file mode 100644 (file)
index fbd35b8..0000000
+++ /dev/null
@@ -1,186 +0,0 @@
-<skin>
-       <fonts>
-               <font filename="nmsbd.ttf" name="VFD" scale="100"/>
-       </fonts>
-       <screen name="InfoBarSummary" position="0,0" size="140,32" id="1">
-               <widget source="session.CurrentService" render="Label" position="5,10" size="130,20" font="VFD;16" halign="center" valign="top" >
-                       <convert type="ServiceName">Name</convert>
-               </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/teletext.png" position="5,0" size="8,7">
-                        <convert type="ServiceInfo">HasTelext</convert>
-                       <convert type="ConditionalShowHide" />
-                </widget>
-                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/crypt.png" position="15,0"  size="8,7">
-                        <convert type="ServiceInfo">IsCrypted</convert>
-                       <convert type="ConditionalShowHide" />
-                </widget>
-                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/dolby.png" position="25,0" size="10,7">
-                        <convert type="ServiceInfo">IsMultichannel</convert>
-                       <convert type="ConditionalShowHide" />
-                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/format.png" position="37,0" size="15,7">
-                       <convert type="ServiceInfo">IsWidescreen</convert>
-                       <convert type="ConditionalShowHide" />
-               </widget>
-                <widget source="session.RecordState" render="Pixmap" pixmap="vfd_icons/rec.png" position="54,0"  size="12,7">
-                       <convert type="ConditionalShowHide" />
-                </widget>
-        </screen>
-        <screen name="ChannelSelection_summary" position="0,0" size="140,32" id="1">
-               <widget source="parent.ServiceEvent" render="Label" position="5,10" size="130,20" font="VFD;16" halign="center" valign="top" >
-                       <convert type="ServiceName">Name</convert>
-               </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/teletext.png" position="5,0" size="8,7">
-                        <convert type="ServiceInfo">HasTelext</convert>
-                       <convert type="ConditionalShowHide" />
-                </widget>
-                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/crypt.png" position="15,0"  size="8,7">
-                        <convert type="ServiceInfo">IsCrypted</convert>
-                       <convert type="ConditionalShowHide" />
-                </widget>
-                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/dolby.png" position="25,0" size="10,7">
-                        <convert type="ServiceInfo">IsMultichannel</convert>
-                       <convert type="ConditionalShowHide" />
-                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/format.png" position="37,0" size="15,7">
-                       <convert type="ServiceInfo">IsWidescreen</convert>
-                       <convert type="ConditionalShowHide" />
-               </widget>
-                <widget source="session.RecordState" render="Pixmap" pixmap="vfd_icons/rec.png" position="54,0"  size="12,7">
-                       <convert type="ConditionalShowHide" />
-                </widget>
-       </screen>
-       <screen name="InfoBarMoviePlayerSummary" position="0,0" size="140,32" id="1">
-               <widget source="session.CurrentService" render="Label" position="5,10" size="130,20" font="VFD;20" halign="center" valign="top" >
-                       <convert type="ServiceName">Name</convert>
-               </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/teletext.png" position="5,0" size="8,7">
-                        <convert type="ServiceInfo">HasTelext</convert>
-                       <convert type="ConditionalShowHide" />
-                </widget>
-                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/crypt.png" position="15,0"  size="8,7">
-                        <convert type="ServiceInfo">IsCrypted</convert>
-                       <convert type="ConditionalShowHide" />
-                </widget>
-                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/dolby.png" position="25,0" size="10,7">
-                        <convert type="ServiceInfo">IsMultichannel</convert>
-                       <convert type="ConditionalShowHide" />
-                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/format.png" position="37,0" size="15,7">
-                       <convert type="ServiceInfo">IsWidescreen</convert>
-                       <convert type="ConditionalShowHide" />
-               </widget>
-                <widget source="session.RecordState" render="Pixmap" pixmap="vfd_icons/rec.png" position="54,0"  size="12,7">
-                       <convert type="ConditionalShowHide" />
-                </widget>
-       </screen>
-       <screen name="ChoiceBox_summary" position="0,0" size="140,32" id="1">
-               <widget source="parent.summary_list" render="Label" position="10,0" size="130,32" font="VFD;15" halign="center" valign="top" />
-       </screen>
-       <screen name="MessageBox_summary" position="0,0" size="140,32" id="1">
-               <widget source="parent.selectedChoice" render="Label" position="5,5" size="130,20" font="VFD;20" halign="center" valign="top" />
-       </screen>
-       <screen name="MenuSummary" position="0,0" size="140,32" id="1">
-               <widget source="parent.menu" render="Label" position="5,10" size="130,20" font="VFD;16" halign="center" valign="top">
-                       <convert type="StringListSelection" />
-               </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/teletext.png" position="5,0" size="8,7">
-                        <convert type="ServiceInfo">HasTelext</convert>
-                       <convert type="ConditionalShowHide" />
-                </widget>
-                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/crypt.png" position="15,0"  size="8,7">
-                        <convert type="ServiceInfo">IsCrypted</convert>
-                       <convert type="ConditionalShowHide" />
-                </widget>
-                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/dolby.png" position="25,0" size="10,7">
-                        <convert type="ServiceInfo">IsMultichannel</convert>
-                       <convert type="ConditionalShowHide" />
-                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/format.png" position="37,0" size="15,7">
-                       <convert type="ServiceInfo">IsWidescreen</convert>
-                       <convert type="ConditionalShowHide" />
-               </widget>
-                <widget source="session.RecordState" render="Pixmap" pixmap="vfd_icons/rec.png" position="54,0"  size="12,7">
-                       <convert type="ConditionalShowHide" />
-                </widget>
-       </screen>
-       <screen name="SetupSummary" position="0,0" size="140,32" id="1">
-               <widget source="SetupTitle" render="Label" position="5,10" size="130,20" font="VFD;16" halign="center" valign="top" />
-               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/teletext.png" position="5,0" size="8,7">
-                        <convert type="ServiceInfo">HasTelext</convert>
-                       <convert type="ConditionalShowHide" />
-                </widget>
-                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/crypt.png" position="15,0"  size="8,7">
-                        <convert type="ServiceInfo">IsCrypted</convert>
-                       <convert type="ConditionalShowHide" />
-                </widget>
-                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/dolby.png" position="25,0" size="10,7">
-                        <convert type="ServiceInfo">IsMultichannel</convert>
-                       <convert type="ConditionalShowHide" />
-                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/format.png" position="37,0" size="15,7">
-                       <convert type="ServiceInfo">IsWidescreen</convert>
-                       <convert type="ConditionalShowHide" />
-               </widget>
-                <widget source="session.RecordState" render="Pixmap" pixmap="vfd_icons/rec.png" position="54,0"  size="12,7">
-                       <convert type="ConditionalShowHide" />
-                </widget>
-       </screen>
-       <screen name="StandbySummary" position="0,0" size="140,32" id="1">
-               <widget source="global.CurrentTime" render="Label" position="13,7" size="90,22" font="VFD;28" halign="right" valign="center" transparent="1">
-                       <convert type="ClockToText">Format:%H:%M</convert>
-               </widget>
-               <widget source="global.CurrentTime" render="Label" position="105,5" zPosition="1" size="40,16" font="VFD;16" halign="left" valign="top" transparent="1">
-                       <convert type="ClockToText">Format:%S</convert>
-               </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/teletext.png" position="5,0" size="8,7">
-                        <convert type="ServiceInfo">HasTelext</convert>
-                       <convert type="ConditionalShowHide" />
-                </widget>
-                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/crypt.png" position="15,0"  size="8,7">
-                        <convert type="ServiceInfo">IsCrypted</convert>
-                       <convert type="ConditionalShowHide" />
-                </widget>
-                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/dolby.png" position="25,0" size="10,7">
-                        <convert type="ServiceInfo">IsMultichannel</convert>
-                       <convert type="ConditionalShowHide" />
-                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/format.png" position="37,0" size="15,7">
-                       <convert type="ServiceInfo">IsWidescreen</convert>
-                       <convert type="ConditionalShowHide" />
-               </widget>
-                <widget source="session.RecordState" render="Pixmap" pixmap="vfd_icons/rec.png" position="54,0"  size="12,7">
-                       <convert type="ConditionalShowHide" />
-                </widget>
-       </screen>
-       <screen name="SimpleSummary" position="0,0" size="140,32" id="1">
-               <widget source="parent.Title" render="Label" position="5,10" size="130,20" font="VFD;16" halign="center" valign="top" />
-               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/teletext.png" position="5,0" size="8,7">
-                        <convert type="ServiceInfo">HasTelext</convert>
-                       <convert type="ConditionalShowHide" />
-                </widget>
-                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/crypt.png" position="15,0"  size="8,7">
-                        <convert type="ServiceInfo">IsCrypted</convert>
-                       <convert type="ConditionalShowHide" />
-                </widget>
-                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/dolby.png" position="25,0" size="10,7">
-                        <convert type="ServiceInfo">IsMultichannel</convert>
-                       <convert type="ConditionalShowHide" />
-                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/format.png" position="37,0" size="15,7">
-                       <convert type="ServiceInfo">IsWidescreen</convert>
-                       <convert type="ConditionalShowHide" />
-               </widget>
-                <widget source="session.RecordState" render="Pixmap" pixmap="vfd_icons/rec.png" position="54,0"  size="12,7">
-                       <convert type="ConditionalShowHide" />
-                </widget>
-       </screen>
-       <screen name="MediaPlayerLCDScreen" position="0,0" size="140,32" id="1">
-               <widget name="text1" position="6,8" size="134,18" font="VFD;16"/>
-       </screen>
-       <screen name="WizardSummary" position="0,0" size="140,32" id="1">
-               <widget source="parent.list" render="Label" position="6,6" size="134,16" font="VFD;16" valign="top" halign="left" >
-                       <convert type="StringListSelection" />
-               </widget>
-       </screen>
-</skin>
diff --git a/recipes/enigma2/enigma2/vuduo2/vfd_icons/crypt.png b/recipes/enigma2/enigma2/vuduo2/vfd_icons/crypt.png
deleted file mode 100755 (executable)
index 1be23f6..0000000
Binary files a/recipes/enigma2/enigma2/vuduo2/vfd_icons/crypt.png and /dev/null differ
diff --git a/recipes/enigma2/enigma2/vuduo2/vfd_icons/dolby.png b/recipes/enigma2/enigma2/vuduo2/vfd_icons/dolby.png
deleted file mode 100755 (executable)
index 4ed3d88..0000000
Binary files a/recipes/enigma2/enigma2/vuduo2/vfd_icons/dolby.png and /dev/null differ
diff --git a/recipes/enigma2/enigma2/vuduo2/vfd_icons/format.png b/recipes/enigma2/enigma2/vuduo2/vfd_icons/format.png
deleted file mode 100755 (executable)
index 46eef16..0000000
Binary files a/recipes/enigma2/enigma2/vuduo2/vfd_icons/format.png and /dev/null differ
diff --git a/recipes/enigma2/enigma2/vuduo2/vfd_icons/rec.png b/recipes/enigma2/enigma2/vuduo2/vfd_icons/rec.png
deleted file mode 100755 (executable)
index f2cec07..0000000
Binary files a/recipes/enigma2/enigma2/vuduo2/vfd_icons/rec.png and /dev/null differ
diff --git a/recipes/enigma2/enigma2/vuduo2/vfd_icons/teletext.png b/recipes/enigma2/enigma2/vuduo2/vfd_icons/teletext.png
deleted file mode 100755 (executable)
index 81e6485..0000000
Binary files a/recipes/enigma2/enigma2/vuduo2/vfd_icons/teletext.png and /dev/null differ
diff --git a/recipes/enigma2/enigma2/vuplus/skin_user_vuduo2.xml b/recipes/enigma2/enigma2/vuplus/skin_user_vuduo2.xml
new file mode 100644 (file)
index 0000000..fbd35b8
--- /dev/null
@@ -0,0 +1,186 @@
+<skin>
+       <fonts>
+               <font filename="nmsbd.ttf" name="VFD" scale="100"/>
+       </fonts>
+       <screen name="InfoBarSummary" position="0,0" size="140,32" id="1">
+               <widget source="session.CurrentService" render="Label" position="5,10" size="130,20" font="VFD;16" halign="center" valign="top" >
+                       <convert type="ServiceName">Name</convert>
+               </widget>
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/teletext.png" position="5,0" size="8,7">
+                        <convert type="ServiceInfo">HasTelext</convert>
+                       <convert type="ConditionalShowHide" />
+                </widget>
+                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/crypt.png" position="15,0"  size="8,7">
+                        <convert type="ServiceInfo">IsCrypted</convert>
+                       <convert type="ConditionalShowHide" />
+                </widget>
+                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/dolby.png" position="25,0" size="10,7">
+                        <convert type="ServiceInfo">IsMultichannel</convert>
+                       <convert type="ConditionalShowHide" />
+                </widget>
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/format.png" position="37,0" size="15,7">
+                       <convert type="ServiceInfo">IsWidescreen</convert>
+                       <convert type="ConditionalShowHide" />
+               </widget>
+                <widget source="session.RecordState" render="Pixmap" pixmap="vfd_icons/rec.png" position="54,0"  size="12,7">
+                       <convert type="ConditionalShowHide" />
+                </widget>
+        </screen>
+        <screen name="ChannelSelection_summary" position="0,0" size="140,32" id="1">
+               <widget source="parent.ServiceEvent" render="Label" position="5,10" size="130,20" font="VFD;16" halign="center" valign="top" >
+                       <convert type="ServiceName">Name</convert>
+               </widget>
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/teletext.png" position="5,0" size="8,7">
+                        <convert type="ServiceInfo">HasTelext</convert>
+                       <convert type="ConditionalShowHide" />
+                </widget>
+                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/crypt.png" position="15,0"  size="8,7">
+                        <convert type="ServiceInfo">IsCrypted</convert>
+                       <convert type="ConditionalShowHide" />
+                </widget>
+                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/dolby.png" position="25,0" size="10,7">
+                        <convert type="ServiceInfo">IsMultichannel</convert>
+                       <convert type="ConditionalShowHide" />
+                </widget>
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/format.png" position="37,0" size="15,7">
+                       <convert type="ServiceInfo">IsWidescreen</convert>
+                       <convert type="ConditionalShowHide" />
+               </widget>
+                <widget source="session.RecordState" render="Pixmap" pixmap="vfd_icons/rec.png" position="54,0"  size="12,7">
+                       <convert type="ConditionalShowHide" />
+                </widget>
+       </screen>
+       <screen name="InfoBarMoviePlayerSummary" position="0,0" size="140,32" id="1">
+               <widget source="session.CurrentService" render="Label" position="5,10" size="130,20" font="VFD;20" halign="center" valign="top" >
+                       <convert type="ServiceName">Name</convert>
+               </widget>
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/teletext.png" position="5,0" size="8,7">
+                        <convert type="ServiceInfo">HasTelext</convert>
+                       <convert type="ConditionalShowHide" />
+                </widget>
+                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/crypt.png" position="15,0"  size="8,7">
+                        <convert type="ServiceInfo">IsCrypted</convert>
+                       <convert type="ConditionalShowHide" />
+                </widget>
+                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/dolby.png" position="25,0" size="10,7">
+                        <convert type="ServiceInfo">IsMultichannel</convert>
+                       <convert type="ConditionalShowHide" />
+                </widget>
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/format.png" position="37,0" size="15,7">
+                       <convert type="ServiceInfo">IsWidescreen</convert>
+                       <convert type="ConditionalShowHide" />
+               </widget>
+                <widget source="session.RecordState" render="Pixmap" pixmap="vfd_icons/rec.png" position="54,0"  size="12,7">
+                       <convert type="ConditionalShowHide" />
+                </widget>
+       </screen>
+       <screen name="ChoiceBox_summary" position="0,0" size="140,32" id="1">
+               <widget source="parent.summary_list" render="Label" position="10,0" size="130,32" font="VFD;15" halign="center" valign="top" />
+       </screen>
+       <screen name="MessageBox_summary" position="0,0" size="140,32" id="1">
+               <widget source="parent.selectedChoice" render="Label" position="5,5" size="130,20" font="VFD;20" halign="center" valign="top" />
+       </screen>
+       <screen name="MenuSummary" position="0,0" size="140,32" id="1">
+               <widget source="parent.menu" render="Label" position="5,10" size="130,20" font="VFD;16" halign="center" valign="top">
+                       <convert type="StringListSelection" />
+               </widget>
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/teletext.png" position="5,0" size="8,7">
+                        <convert type="ServiceInfo">HasTelext</convert>
+                       <convert type="ConditionalShowHide" />
+                </widget>
+                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/crypt.png" position="15,0"  size="8,7">
+                        <convert type="ServiceInfo">IsCrypted</convert>
+                       <convert type="ConditionalShowHide" />
+                </widget>
+                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/dolby.png" position="25,0" size="10,7">
+                        <convert type="ServiceInfo">IsMultichannel</convert>
+                       <convert type="ConditionalShowHide" />
+                </widget>
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/format.png" position="37,0" size="15,7">
+                       <convert type="ServiceInfo">IsWidescreen</convert>
+                       <convert type="ConditionalShowHide" />
+               </widget>
+                <widget source="session.RecordState" render="Pixmap" pixmap="vfd_icons/rec.png" position="54,0"  size="12,7">
+                       <convert type="ConditionalShowHide" />
+                </widget>
+       </screen>
+       <screen name="SetupSummary" position="0,0" size="140,32" id="1">
+               <widget source="SetupTitle" render="Label" position="5,10" size="130,20" font="VFD;16" halign="center" valign="top" />
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/teletext.png" position="5,0" size="8,7">
+                        <convert type="ServiceInfo">HasTelext</convert>
+                       <convert type="ConditionalShowHide" />
+                </widget>
+                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/crypt.png" position="15,0"  size="8,7">
+                        <convert type="ServiceInfo">IsCrypted</convert>
+                       <convert type="ConditionalShowHide" />
+                </widget>
+                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/dolby.png" position="25,0" size="10,7">
+                        <convert type="ServiceInfo">IsMultichannel</convert>
+                       <convert type="ConditionalShowHide" />
+                </widget>
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/format.png" position="37,0" size="15,7">
+                       <convert type="ServiceInfo">IsWidescreen</convert>
+                       <convert type="ConditionalShowHide" />
+               </widget>
+                <widget source="session.RecordState" render="Pixmap" pixmap="vfd_icons/rec.png" position="54,0"  size="12,7">
+                       <convert type="ConditionalShowHide" />
+                </widget>
+       </screen>
+       <screen name="StandbySummary" position="0,0" size="140,32" id="1">
+               <widget source="global.CurrentTime" render="Label" position="13,7" size="90,22" font="VFD;28" halign="right" valign="center" transparent="1">
+                       <convert type="ClockToText">Format:%H:%M</convert>
+               </widget>
+               <widget source="global.CurrentTime" render="Label" position="105,5" zPosition="1" size="40,16" font="VFD;16" halign="left" valign="top" transparent="1">
+                       <convert type="ClockToText">Format:%S</convert>
+               </widget>
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/teletext.png" position="5,0" size="8,7">
+                        <convert type="ServiceInfo">HasTelext</convert>
+                       <convert type="ConditionalShowHide" />
+                </widget>
+                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/crypt.png" position="15,0"  size="8,7">
+                        <convert type="ServiceInfo">IsCrypted</convert>
+                       <convert type="ConditionalShowHide" />
+                </widget>
+                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/dolby.png" position="25,0" size="10,7">
+                        <convert type="ServiceInfo">IsMultichannel</convert>
+                       <convert type="ConditionalShowHide" />
+                </widget>
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/format.png" position="37,0" size="15,7">
+                       <convert type="ServiceInfo">IsWidescreen</convert>
+                       <convert type="ConditionalShowHide" />
+               </widget>
+                <widget source="session.RecordState" render="Pixmap" pixmap="vfd_icons/rec.png" position="54,0"  size="12,7">
+                       <convert type="ConditionalShowHide" />
+                </widget>
+       </screen>
+       <screen name="SimpleSummary" position="0,0" size="140,32" id="1">
+               <widget source="parent.Title" render="Label" position="5,10" size="130,20" font="VFD;16" halign="center" valign="top" />
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/teletext.png" position="5,0" size="8,7">
+                        <convert type="ServiceInfo">HasTelext</convert>
+                       <convert type="ConditionalShowHide" />
+                </widget>
+                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/crypt.png" position="15,0"  size="8,7">
+                        <convert type="ServiceInfo">IsCrypted</convert>
+                       <convert type="ConditionalShowHide" />
+                </widget>
+                <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/dolby.png" position="25,0" size="10,7">
+                        <convert type="ServiceInfo">IsMultichannel</convert>
+                       <convert type="ConditionalShowHide" />
+                </widget>
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/format.png" position="37,0" size="15,7">
+                       <convert type="ServiceInfo">IsWidescreen</convert>
+                       <convert type="ConditionalShowHide" />
+               </widget>
+                <widget source="session.RecordState" render="Pixmap" pixmap="vfd_icons/rec.png" position="54,0"  size="12,7">
+                       <convert type="ConditionalShowHide" />
+                </widget>
+       </screen>
+       <screen name="MediaPlayerLCDScreen" position="0,0" size="140,32" id="1">
+               <widget name="text1" position="6,8" size="134,18" font="VFD;16"/>
+       </screen>
+       <screen name="WizardSummary" position="0,0" size="140,32" id="1">
+               <widget source="parent.list" render="Label" position="6,6" size="134,16" font="VFD;16" valign="top" halign="left" >
+                       <convert type="StringListSelection" />
+               </widget>
+       </screen>
+</skin>
diff --git a/recipes/enigma2/enigma2/vuplus/vfd_icons_vuduo2/crypt.png b/recipes/enigma2/enigma2/vuplus/vfd_icons_vuduo2/crypt.png
new file mode 100755 (executable)
index 0000000..1be23f6
Binary files /dev/null and b/recipes/enigma2/enigma2/vuplus/vfd_icons_vuduo2/crypt.png differ
diff --git a/recipes/enigma2/enigma2/vuplus/vfd_icons_vuduo2/dolby.png b/recipes/enigma2/enigma2/vuplus/vfd_icons_vuduo2/dolby.png
new file mode 100755 (executable)
index 0000000..4ed3d88
Binary files /dev/null and b/recipes/enigma2/enigma2/vuplus/vfd_icons_vuduo2/dolby.png differ
diff --git a/recipes/enigma2/enigma2/vuplus/vfd_icons_vuduo2/format.png b/recipes/enigma2/enigma2/vuplus/vfd_icons_vuduo2/format.png
new file mode 100755 (executable)
index 0000000..46eef16
Binary files /dev/null and b/recipes/enigma2/enigma2/vuplus/vfd_icons_vuduo2/format.png differ
diff --git a/recipes/enigma2/enigma2/vuplus/vfd_icons_vuduo2/rec.png b/recipes/enigma2/enigma2/vuplus/vfd_icons_vuduo2/rec.png
new file mode 100755 (executable)
index 0000000..f2cec07
Binary files /dev/null and b/recipes/enigma2/enigma2/vuplus/vfd_icons_vuduo2/rec.png differ
diff --git a/recipes/enigma2/enigma2/vuplus/vfd_icons_vuduo2/teletext.png b/recipes/enigma2/enigma2/vuplus/vfd_icons_vuduo2/teletext.png
new file mode 100755 (executable)
index 0000000..81e6485
Binary files /dev/null and b/recipes/enigma2/enigma2/vuplus/vfd_icons_vuduo2/teletext.png differ