Make 2.6.25omap1 build with gcc 4.3
authorKhem Raj <raj.khem@gmail.com>
Fri, 22 Aug 2008 01:30:42 +0000 (01:30 +0000)
committerKhem Raj <raj.khem@gmail.com>
Fri, 22 Aug 2008 01:30:42 +0000 (01:30 +0000)
Booted the kernel on osk5912

packages/linux/linux-omap1-2.6.25-omap1/gcc43-arm-fix-inline-asm-constraints-for-preload.patch [new file with mode: 0644]
packages/linux/linux-omap1_2.6.25-omap1.bb

diff --git a/packages/linux/linux-omap1-2.6.25-omap1/gcc43-arm-fix-inline-asm-constraints-for-preload.patch b/packages/linux/linux-omap1-2.6.25-omap1/gcc43-arm-fix-inline-asm-constraints-for-preload.patch
new file mode 100644 (file)
index 0000000..4695917
--- /dev/null
@@ -0,0 +1,22 @@
+Source:
+http://www.arm.linux.org.uk/developer/patches/viewpatch.php?id=5196/1
+
+Description: 
+This patch is already submitted upstream. So it will not be needed in 2.6.27 onwards I guess but anyone interested in compiling prior versions of kernels with gcc 4.3 for ARM would need this patch.
+diff --git a/include/asm-arm/processor.h b/include/asm-arm/processor.h
+index b01d5e7..517a4d6 100644
+--- a/include/asm-arm/processor.h
++++ b/include/asm-arm/processor.h
+@@ -112,9 +112,9 @@ extern int kernel_thread(int (*fn)(void *), void *arg, unsigned long flags);
+ static inline void prefetch(const void *ptr)
+ {
+       __asm__ __volatile__(
+-              "pld\t%0"
++              "pld\t%a0"
+               :
+-              : "o" (*(char *)ptr)
++              : "p" (ptr)
+               : "cc");
+ }
+
index 1d2d0be..2f3f3ce 100644 (file)
@@ -4,6 +4,7 @@ COMPATIBLE_MACHINE = "omap5912osk"
 
 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.25.tar.bz2 \
            http://www.muru.com/linux/omap/patches/patch-2.6.25-omap1.bz2;patch=1 \
+          file://gcc43-arm-fix-inline-asm-constraints-for-preload.patch;patch=1 \
           file://defconfig"
 
 S = "${WORKDIR}/linux-2.6.25"