webkit-gtk: bump SRCREV, fix gtk-doc, fix packaging
authorKoen Kooi <koen@openembedded.org>
Sat, 9 May 2009 09:55:33 +0000 (11:55 +0200)
committerKoen Kooi <koen@openembedded.org>
Sat, 9 May 2009 09:55:33 +0000 (11:55 +0200)
* runtime tested on beagleboard with midori and epiphany

conf/distro/include/sane-srcrevs.inc
recipes/webkit/webkit-gtk/GNUmakefile.am
recipes/webkit/webkit-gtk/autogen.sh
recipes/webkit/webkit-gtk/configure.ac
recipes/webkit/webkit-gtk/gtk-doc.make [new file with mode: 0644]
recipes/webkit/webkit-gtk_svn.bb

index 3b24ce6..49326f4 100644 (file)
@@ -249,7 +249,7 @@ SRCREV_pn-usbpath-native ?= "3172"
 SRCREV-pn-vala-dbus-binding-tool-native ?= "55a6bc5dd032731d89c238d274b2898ef02d12f8"
 SRCREV_pn-vala-terminal ?= "94117f453ce884e9c30b611fae6fc19f85f98f2b"
 SRCREV_pn-vala-native ?= "6cf030120cd7f6a76a5d766d7420aea847e02cfd"
-SRCREV_pn-webkit-gtk ?= "42127"
+SRCREV_pn-webkit-gtk ?= "43434"
 SRCREV_pn-wlan-ng-modules ?= "1859"
 SRCREV_pn-wlan-ng-utils ?= "1859"
 SRCREV_pn-wmiconfig ?= "4522"
index 13cf5ee..957078f 100644 (file)
@@ -49,6 +49,11 @@ IDL_BINDINGS :=
 
 TEST_PROGS :=
 
+# Gettext stuff
+POFILES :=
+
+MOFILES :=
+
 # Global flags to CPP
 global_cppflags :=
 
@@ -183,6 +188,7 @@ libWebCore_la_CFLAGS = \
        $(LIBXSLT_CFLAGS) \
        $(COVERAGE_CFLAGS) \
        $(HILDON_CFLAGS) \
+       $(ENCHANT_CFLAGS) \
        $(GEOCLUE_CFLAGS)
 
 libWebCore_la_CPPFLAGS = \
@@ -252,6 +258,7 @@ libwebkit_1_0_la_LDFLAGS = \
 
 libwebkit_1_0_la_LIBADD = \
        libWebCore.la \
+       $(ENCHANT_LIBS) \
        $(GNOMEKEYRING_LIBS)
 
 #
@@ -259,7 +266,8 @@ libwebkit_1_0_la_LIBADD = \
 global_cppflags += \
        -DBUILDING_CAIRO__=1 \
        -DBUILDING_GTK__=1 \
-       -DWTF_CHANGES
+       -DWTF_CHANGES \
+       -DPACKAGE_LOCALE_DIR=\"$(localedir)\"
 
 if !ENABLE_FAST_MALLOC
 global_cppflags += \
@@ -307,6 +315,7 @@ webkitgtk_h_api += \
        WebKit/gtk/webkit/webkit.h \
        WebKit/gtk/webkit/webkitdefines.h \
        WebKit/gtk/webkit/webkitdownload.h \
+       WebKit/gtk/webkit/webkiterror.h \
        WebKit/gtk/webkit/webkitnetworkrequest.h \
        WebKit/gtk/webkit/webkitsoupauthdialog.h \
        WebKit/gtk/webkit/webkitversion.h \
@@ -341,6 +350,8 @@ webkitgtk_sources += \
        WebKit/gtk/WebCoreSupport/InspectorClientGtk.h \
        WebKit/gtk/WebCoreSupport/PasteboardHelperGtk.cpp \
        WebKit/gtk/WebCoreSupport/PasteboardHelperGtk.h \
+       WebKit/gtk/webkit/webkitdownload.cpp \
+       WebKit/gtk/webkit/webkiterror.cpp \
        WebKit/gtk/webkit/webkitnetworkrequest.cpp \
        WebKit/gtk/webkit/webkitprivate.cpp \
        WebKit/gtk/webkit/webkitprivate.h \
@@ -353,7 +364,6 @@ webkitgtk_sources += \
        WebKit/gtk/webkit/webkitwebnavigationaction.cpp \
        WebKit/gtk/webkit/webkitwebpolicydecision.cpp \
        WebKit/gtk/webkit/webkitwebsettings.cpp \
-       WebKit/gtk/webkit/webkitdownload.cpp \
        WebKit/gtk/webkit/webkitwebview.cpp \
        WebKit/gtk/webkit/webkitwebwindowfeatures.cpp
 
@@ -443,27 +453,41 @@ DerivedSources/webkitenumtypes.cpp: $(webkitgtk_h_api) GNUmakefile
        && cp xgen-gtc $@ \
        && rm -f xgen-gtc
 
-# END WEBKIT GTK+
-#
 # Files that will be distributed
 EXTRA_DIST = \
+       $(srcdir)/gtk-doc.make \
        WebKit/LICENSE \
        $(javascriptcore_dist) \
        $(webcore_dist) \
        $(srcdir)/autotools/symbols.filter \
        $(srcdir)/WebKit/gtk/ChangeLog \
        $(srcdir)/WebKit/gtk/NEWS \
-       $(srcdir)/WebKit/gtk/webkitmarshal.list
+       $(srcdir)/WebKit/gtk/webkitmarshal.list \
+       $(srcdir)/WebKit/gtk/docs/GNUmakefile.* \
+       $(srcdir)/WebKit/gtk/docs/webkitenvironment.xml \
+       $(srcdir)/WebKit/gtk/docs/webkitgtk-docs.sgml \
+       $(srcdir)/WebKit/gtk/docs/webkitgtk-sections.txt \
+       $(srcdir)/WebKit/gtk/docs/version.xml.in \
+       $(srcdir)/WebKit/gtk/po/* \
+       $(srcdir)/WebKit/gtk/resources/*
+
+# extra resource files
+resourcesdir = ${datadir}/webkit-1.0/resources
+dist_resources_DATA = \
+       $(shell ls $(srcdir)/WebKit/gtk/resources/*.html)
+
+# END WEBKIT GTK+
 
 # Files that will be cleaned
-MAINTAINERCLEANFILES := $(stamp_files) $(BUILT_SOURCES) doltcompile doltlibtool
-DISTCLEANFILES := $(stamp_files) $(BUILT_SOURCES) doltcompile doltlibtool
-CLEANFILES := $(stamp_files) $(BUILT_SOURCES)
+MAINTAINERCLEANFILES := $(stamp_files) $(BUILT_SOURCES) doltcompile doltlibtool WebKit/gtk/docs/version.xml WebKit/gtk/docs/GNUmakefile
+DISTCLEANFILES := $(stamp_files) $(BUILT_SOURCES) doltcompile doltlibtool WebKit/gtk/docs/version.xml WebKit/gtk/docs/GNUmakefile
+CLEANFILES := $(stamp_files) $(BUILT_SOURCES) WebKit/gtk/docs/GNUmakefile
 
 # Include module makefiles
 include JavaScriptCore/GNUmakefile.am
 include WebCore/GNUmakefile.am
 include WebKitTools/GNUmakefile.am
+include WebKit/gtk/po/GNUmakefile.am
 
 # Build unit tests
 noinst_PROGRAMS += $(TEST_PROGS)
@@ -487,7 +511,8 @@ webkit_tests_ldadd = \
 
 TEST_PROGS += Programs/unittests/testwebframe \
        Programs/unittests/testwebbackforwardlist \
-       Programs/unittests/testwebhistoryitem
+       Programs/unittests/testwebhistoryitem \
+       Programs/unittests/testdownload
 
 # Add additional tests here
 Programs_unittests_testwebframe_SOURCES = WebKit/gtk/tests/testwebframe.c
@@ -502,6 +527,9 @@ Programs_unittests_testwebhistoryitem_SOURCES = WebKit/gtk/tests/testwebhistoryi
 Programs_unittests_testwebhistoryitem_CFLAGS = $(webkit_tests_cflags)
 Programs_unittests_testwebhistoryitem_LDADD = $(webkit_tests_ldadd)
 
+Programs_unittests_testdownload_SOURCES = WebKit/gtk/tests/testdownload.c
+Programs_unittests_testdownload_CFLAGS = $(webkit_tests_cflags)
+Programs_unittests_testdownload_LDADD = $(webkit_tests_ldadd)
 
 # Autogenerated sources
 BUILT_SOURCES := \
@@ -531,8 +559,8 @@ MAINTAINERCLEANFILES += \
 
 # Older automake versions (1.7) place Plo files in a different place so we need
 # to create the output directory manually.
-all-local:
-       mkdir -p $(top_builddir)/$(DEPDIR)/DerivedSources
+all-local: stamp-po
+       $(mkdir_p) $(top_builddir)/$(DEPDIR)/DerivedSources
 
 # remove built sources and program directories
 clean-local:
@@ -542,3 +570,9 @@ maintainer-clean-local: distclean-local
 
 distclean-local:
        -rm -rf $(GENSOURCES) $(GENPROGRAMS)
+
+install-data-local: po-install-data-local
+
+installdirs-data-local: po-installdirs-data-local
+
+uninstall-local: po-uninstall-local
index 8f736c4..d32b73e 100644 (file)
@@ -8,6 +8,7 @@ test -z "$srcdir" && srcdir=.
 ORIGDIR=`pwd`
 cd $srcdir
 
+GTKDOCIZE_FLAGS="--copy"
 LIBTOOLIZE_FLAGS="--force --automake"
 ACLOCAL_FLAGS="-I autotools"
 AUTOMAKE_FLAGS="--foreign --add-missing"
@@ -58,7 +59,7 @@ rm -rf $top_srcdir/autom4te.cache
 
 touch README INSTALL
 
-gtkdocize || exit $?
+gtkdocize $GTKDOCIZE_FLAGS || exit $?
 aclocal $ACLOCAL_FLAGS || exit $?
 $LIBTOOLIZE $LIBTOOLIZE_FLAGS || exit $?
 autoheader || exit $?
index 4940af8..be6d852 100644 (file)
@@ -2,7 +2,7 @@ AC_PREREQ(2.59)
 
 m4_define([webkit_major_version], [1])
 m4_define([webkit_minor_version], [1])
-m4_define([webkit_micro_version], [4])
+m4_define([webkit_micro_version], [6])
 
 AC_INIT([WebKit],[webkit_major_version.webkit_minor_version.webkit_micro_version],[http://bugs.webkit.org/])
 
@@ -24,7 +24,7 @@ AC_CONFIG_SRCDIR([WebCore/config.h])
 
 dnl # Libtool library version, not to confuse with API version
 dnl # see http://www.gnu.org/software/libtool/manual/html_node/Libtool-versioning.html#Libtool-versioning
-LIBWEBKITGTK_VERSION=4:0:2
+LIBWEBKITGTK_VERSION=6:0:4
 AC_SUBST([LIBWEBKITGTK_VERSION])
 
 AM_INIT_AUTOMAKE([foreign subdir-objects tar-ustar])
@@ -183,7 +183,7 @@ LIBXML_REQUIRED_VERSION=2.6
 
 # minimum GTK+ base dependencies
 PANGO_REQUIRED_VERSION=1.0
-GTK_REQUIRED_VERSION=2.8
+GTK_REQUIRED_VERSION=2.10
 
 # optional modules
 LIBSOUP_REQUIRED_VERSION=2.25.91
@@ -191,6 +191,7 @@ LIBXSLT_REQUIRED_VERSION=1.1.7
 SQLITE_REQUIRED_VERSION=3.0
 GSTREAMER_REQUIRED_VERSION=0.10
 GNOME_KEYRING_REQUIRED_VERSION=2.26.0
+ENCHANT_REQUIRED_VERSION=0.22
 
 # Available modules
 #
@@ -199,7 +200,12 @@ GNOME_KEYRING_REQUIRED_VERSION=2.26.0
 #
 # todo: webcore gtk
 WEBKIT_CHECK_DEPENDENCIES([glib unicode])
-                          
+
+GETTEXT_PACKAGE=$PACKAGE
+AC_SUBST(GETTEXT_PACKAGE)
+AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",
+                   [The gettext catalog name])
+
 PKG_CHECK_MODULES(LIBXML, libxml-2.0 >= $LIBXML_REQUIRED_VERSION)
 AC_SUBST(LIBXML_CFLAGS)
 AC_SUBST(LIBXML_LIBS)
@@ -218,6 +224,7 @@ if test "$with_target" = "directfb"; then
 else
    PKG_CHECK_MODULES(CAIRO, cairo >= $CAIRO_REQUIRED_VERSION)
    PKG_CHECK_MODULES(GTK, gtk+-2.0 >= $GTK_REQUIRED_VERSION)
+   PKG_CHECK_MODULES(ENCHANT, enchant >= $ENCHANT_REQUIRED_VERSION)
 
    if test "$with_target" = "x11" && test "$os_win32" = "no"; then
       # check for XT
@@ -244,6 +251,8 @@ AC_SUBST(GTK_CFLAGS)
 AC_SUBST(GTK_LIBS)
 AC_SUBST(CAIRO_CFLAGS)
 AC_SUBST(CAIRO_LIBS)
+AC_SUBST(ENCHANT_CFLAGS)
+AC_SUBST(ENCHANT_LIBS)
 
 # check whether to build with debugging enabled
 AC_MSG_CHECKING([whether to do a debug build])
@@ -287,6 +296,14 @@ AC_ARG_ENABLE(channel_messaging,
               [],[enable_channel_messaging="no"])
 AC_MSG_RESULT([$enable_channel_messaging])
 
+# check whether to enable JavaScript debugger/profiler support
+AC_MSG_CHECKING([whether to enable JavaScript debugger/profiler support])
+AC_ARG_ENABLE(javascript_debugger,
+              AC_HELP_STRING([--enable-javascript-debugger],
+                             [enable JavaScript debugger/profiler support [default=yes]]),
+              [],[enable_javascript_debugger="yes"])
+AC_MSG_RESULT([$enable_javascript_debugger])
+
 # check whether to enable HTML5 Offline Web Applications support
 AC_MSG_CHECKING([whether to enable HTML5 offline web applications support])
 AC_ARG_ENABLE(offline_web_applications,
@@ -625,6 +642,7 @@ AM_CONDITIONAL([ENABLE_DEBUG],[test "$enable_debug" = "yes"])
 AM_CONDITIONAL([ENABLE_DASHBOARD_SUPPORT],[test "$enable_dashboard_support" = "yes"])
 AM_CONDITIONAL([ENABLE_3D_TRANSFORMS],[test "$enable_3D_transforms" = "yes"])
 AM_CONDITIONAL([ENABLE_CHANNEL_MESSAGING],[test "$enable_channel_messaging" = "yes"])
+AM_CONDITIONAL([ENABLE_JAVASCRIPT_DEBUGGER],[test "$enable_javascript_debugger" = "yes"])
 AM_CONDITIONAL([ENABLE_OFFLINE_WEB_APPLICATIONS],[test "$enable_offline_web_applications" = "yes"])
 AM_CONDITIONAL([ENABLE_DOM_STORAGE],[test "$enable_dom_storage" = "yes"])
 AM_CONDITIONAL([ENABLE_DATABASE],[test "$enable_database" = "yes"])
@@ -651,6 +669,7 @@ AC_CONFIG_FILES([
 GNUmakefile
 WebKit/gtk/webkit-1.0.pc:WebKit/gtk/webkit.pc.in
 WebKit/gtk/webkit/webkitversion.h
+WebKit/gtk/docs/GNUmakefile
 WebKit/gtk/docs/version.xml
 ]
 )
@@ -673,6 +692,7 @@ Features:
  Dashboard support                                        : $enable_dashboard_support
  Geolocation support                                      : $enable_geolocation
  GNOME Keyring support                                    : $enable_gnomekeyring
+ JavaScript debugger/profiler support                     : $enable_javascript_debugger
  HTML5 offline web applications support                   : $enable_offline_web_applications
  HTML5 channel messaging support                          : $enable_channel_messaging
  HTML5 client-side session and persistent storage support : $enable_dom_storage
diff --git a/recipes/webkit/webkit-gtk/gtk-doc.make b/recipes/webkit/webkit-gtk/gtk-doc.make
new file mode 100644 (file)
index 0000000..354ffb7
--- /dev/null
@@ -0,0 +1,173 @@
+# -*- mode: makefile -*-
+
+####################################
+# Everything below here is generic #
+####################################
+
+if GTK_DOC_USE_LIBTOOL
+GTKDOC_CC = $(LIBTOOL) --mode=compile $(CC) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+GTKDOC_LD = $(LIBTOOL) --mode=link $(CC) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS)
+else
+GTKDOC_CC = $(CC) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+GTKDOC_LD = $(CC) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS)
+endif
+
+# We set GPATH here; this gives us semantics for GNU make
+# which are more like other make's VPATH, when it comes to
+# whether a source that is a target of one rule is then
+# searched for in VPATH/GPATH.
+#
+GPATH = $(srcdir)
+
+TARGET_DIR=$(HTML_DIR)/$(DOC_MODULE)
+
+EXTRA_DIST =                           \
+       $(content_files)                \
+       $(HTML_IMAGES)                  \
+       $(DOC_MAIN_SGML_FILE)           \
+       $(DOC_MODULE)-sections.txt      \
+       $(DOC_MODULE)-overrides.txt
+
+DOC_STAMPS=scan-build.stamp tmpl-build.stamp sgml-build.stamp html-build.stamp \
+          $(srcdir)/tmpl.stamp $(srcdir)/sgml.stamp $(srcdir)/html.stamp
+
+SCANOBJ_FILES =                 \
+       $(DOC_MODULE).args       \
+       $(DOC_MODULE).hierarchy  \
+       $(DOC_MODULE).interfaces \
+       $(DOC_MODULE).prerequisites \
+       $(DOC_MODULE).signals
+
+REPORT_FILES = \
+       $(DOC_MODULE)-undocumented.txt \
+       $(DOC_MODULE)-undeclared.txt \
+       $(DOC_MODULE)-unused.txt
+
+CLEANFILES = $(SCANOBJ_FILES) $(REPORT_FILES) $(DOC_STAMPS)
+
+if ENABLE_GTK_DOC
+all-local: html-build.stamp
+else
+all-local:
+endif
+
+docs: html-build.stamp
+
+#### scan ####
+
+scan-build.stamp: $(HFILE_GLOB) $(CFILE_GLOB)
+       @echo 'gtk-doc: Scanning header files'
+       @-chmod -R u+w $(srcdir)
+       cd $(srcdir) && \
+         gtkdoc-scan --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR) --ignore-headers="$(IGNORE_HFILES)" $(SCAN_OPTIONS) $(EXTRA_HFILES)
+       if grep -l '^..*$$' $(srcdir)/$(DOC_MODULE).types > /dev/null 2>&1 ; then \
+           CC="$(GTKDOC_CC)" LD="$(GTKDOC_LD)" CFLAGS="$(GTKDOC_CFLAGS)" LDFLAGS="$(GTKDOC_LIBS)" gtkdoc-scangobj $(SCANGOBJ_OPTIONS) --module=$(DOC_MODULE) --output-dir=$(srcdir) ; \
+       else \
+           cd $(srcdir) ; \
+           for i in $(SCANOBJ_FILES) ; do \
+               test -f $$i || touch $$i ; \
+           done \
+       fi
+       touch scan-build.stamp
+
+$(DOC_MODULE)-decl.txt $(SCANOBJ_FILES) $(DOC_MODULE)-sections.txt $(DOC_MODULE)-overrides.txt: scan-build.stamp
+       @true
+
+#### templates ####
+
+tmpl-build.stamp: $(DOC_MODULE)-decl.txt $(SCANOBJ_FILES) $(DOC_MODULE)-sections.txt $(DOC_MODULE)-overrides.txt
+       @echo 'gtk-doc: Rebuilding template files'
+       @-chmod -R u+w $(srcdir)
+       cd $(srcdir) && gtkdoc-mktmpl --module=$(DOC_MODULE) $(MKTMPL_OPTIONS)
+       touch tmpl-build.stamp
+
+tmpl.stamp: tmpl-build.stamp
+       @true
+
+tmpl/*.sgml:
+       @true
+
+
+#### xml ####
+
+sgml-build.stamp: tmpl.stamp $(HFILE_GLOB) $(CFILE_GLOB) $(DOC_MODULE)-sections.txt $(srcdir)/tmpl/*.sgml $(expand_content_files)
+       @echo 'gtk-doc: Building XML'
+       @-chmod -R u+w $(srcdir)
+       cd $(srcdir) && \
+       gtkdoc-mkdb --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR) --output-format=xml --expand-content-files="$(expand_content_files)" --main-sgml-file=$(DOC_MAIN_SGML_FILE) $(MKDB_OPTIONS)
+       touch sgml-build.stamp
+
+sgml.stamp: sgml-build.stamp
+       @true
+
+#### html ####
+
+html-build.stamp: sgml.stamp $(DOC_MAIN_SGML_FILE) $(content_files)
+       @echo 'gtk-doc: Building HTML'
+       @-chmod -R u+w $(srcdir)
+       rm -rf $(srcdir)/html
+       mkdir $(srcdir)/html
+       cd $(srcdir)/html && gtkdoc-mkhtml $(DOC_MODULE) ../$(DOC_MAIN_SGML_FILE)
+       test "x$(HTML_IMAGES)" = "x" || ( cd $(srcdir) && cp $(HTML_IMAGES) html )
+       @echo 'gtk-doc: Fixing cross-references'
+       cd $(srcdir) && gtkdoc-fixxref --module-dir=html --html-dir=$(HTML_DIR) $(FIXXREF_OPTIONS)
+       touch html-build.stamp
+
+##############
+
+clean-local:
+       rm -f *~ *.bak
+       rm -rf .libs
+
+distclean-local:
+       cd $(srcdir) && \
+         rm -rf xml $(REPORT_FILES) \
+                $(DOC_MODULE)-decl-list.txt $(DOC_MODULE)-decl.txt
+
+maintainer-clean-local: clean
+       cd $(srcdir) && rm -rf xml html
+
+install-data-local:
+       -installfiles=`echo $(srcdir)/html/*`; \
+       if test "$$installfiles" = '$(srcdir)/html/*'; \
+       then echo '-- Nothing to install' ; \
+       else \
+         $(mkinstalldirs) $(DESTDIR)$(TARGET_DIR); \
+         for i in $$installfiles; do \
+           echo '-- Installing '$$i ; \
+           $(INSTALL_DATA) $$i $(DESTDIR)$(TARGET_DIR); \
+         done; \
+         echo '-- Installing $(srcdir)/html/index.sgml' ; \
+         $(INSTALL_DATA) $(srcdir)/html/index.sgml $(DESTDIR)$(TARGET_DIR) || :; \
+         which gtkdoc-rebase >/dev/null && \
+           gtkdoc-rebase --relative --dest-dir=$(DESTDIR) --html-dir=$(DESTDIR)$(TARGET_DIR) ; \
+       fi
+       
+
+uninstall-local:
+       rm -f $(DESTDIR)$(TARGET_DIR)/*
+
+#
+# Require gtk-doc when making dist
+#
+if ENABLE_GTK_DOC
+dist-check-gtkdoc:
+else
+dist-check-gtkdoc:
+       @echo "*** gtk-doc must be installed and enabled in order to make dist"
+       @false
+endif
+
+dist-hook: dist-check-gtkdoc dist-hook-local
+       mkdir $(distdir)/tmpl
+       mkdir $(distdir)/xml
+       mkdir $(distdir)/html
+       -cp $(srcdir)/tmpl/*.sgml $(distdir)/tmpl
+       -cp $(srcdir)/xml/*.xml $(distdir)/xml
+       cp $(srcdir)/html/* $(distdir)/html
+       -cp $(srcdir)/$(DOC_MODULE).types $(distdir)/
+       -cp $(srcdir)/$(DOC_MODULE)-sections.txt $(distdir)/
+       cd $(distdir) && rm -f $(DISTCLEANFILES)
+       -gtkdoc-rebase --online --relative --html-dir=$(distdir)/html
+
+.PHONY : dist-hook-local docs
index 8473131..3c7ec06 100644 (file)
@@ -1,9 +1,9 @@
 DESCRIPTION = "WebKit browser engine, GTK+ edition"
-DEPENDS = "gtk-doc-native gtk-doc gnome-keyring libsoup-2.4 curl icu libxml2 cairo libxslt libxt libidn gnutls gtk+ gstreamer gst-plugins-base gnome-vfs bison-native flex-native gperf-native perl-native sqlite3"
+DEPENDS = "enchant gtk-doc-native gtk-doc gnome-keyring libsoup-2.4 curl icu libxml2 cairo libxslt libxt libidn gnutls gtk+ gstreamer gst-plugins-base gnome-vfs bison-native flex-native gperf-native perl-native sqlite3"
 
 SRCREV_FORMAT = "webcore-rwebkit"
 
-PV = "1.1.4+svnr${SRCREV}"
+PV = "1.1.6+svnr${SRCREV}"
 
 SRC_URI = "\
   svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptCore;proto=http \
@@ -19,6 +19,7 @@ SRC_URI = "\
   file://configure.ac \
   file://symbols.filter \
   file://GNUmakefile.am \
+  file://gtk-doc.make \
  "
 
 S = "${WORKDIR}/"
@@ -36,10 +37,6 @@ EXTRA_OECONF = "\
 
 EXTRA_AUTORECONF = " -I autotools "
 
-do_configure_prepend() {
-       touch gtk-doc.make
-}
-
 # Dolt gets used on x86 and ppc and hardcodes 'libtool'
 do_configure_append() {
        cp ${TARGET_PREFIX}libtool libtool || true
@@ -70,5 +67,5 @@ FILES_${PN}launcher = "${bindir}/GtkLauncher"
 FILES_${PN}launcher-dbg = "${bindir}/.debug/GtkLauncher"
 FILES_libjavascriptcore = "${libdir}/libJavaScriptCore.so.*"
 FILES_${PN}-webinspector = "${datadir}/webkit-1.0/webinspector/"
-
+FILES_${PN} += "${datadir}/webkit-1.0/resources/error.html"