rt2570: added driver for Ralink USB 802.11g WiFi stick
authorMarcin Juszkiewicz <hrw@openembedded.org>
Sat, 19 Aug 2006 15:22:24 +0000 (15:22 +0000)
committerMarcin Juszkiewicz <hrw@openembedded.org>
Sat, 19 Aug 2006 15:22:24 +0000 (15:22 +0000)
packages/netbase/netbase/tosa/interfaces
packages/rt2x00/.mtn2git_empty [new file with mode: 0644]
packages/rt2x00/rt2570_1.1.0-b2.bb [new file with mode: 0644]
packages/slcalc/slcalc_1.2.1.bb

index 92b0224..0da7168 100644 (file)
@@ -9,8 +9,8 @@ iface wlan0 inet dhcp
   wireless_type wlan-ng
   wireless_mode Managed
   pre-up modprobe prism2_usb
-  pre-up /sbin/usbctl on 1
-  post-down /sbin/usbctl off 1
+#  pre-up /sbin/usbctl on 1
+#  post-down /sbin/usbctl off 1
   post-down rmmod prism2_usb
 
 # Wired or wireless interfaces
diff --git a/packages/rt2x00/.mtn2git_empty b/packages/rt2x00/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/rt2x00/rt2570_1.1.0-b2.bb b/packages/rt2x00/rt2570_1.1.0-b2.bb
new file mode 100644 (file)
index 0000000..a3cc233
--- /dev/null
@@ -0,0 +1,17 @@
+DESCRIPTION = "Driver for Ralink rt2570 USB 802.11g WiFi sticks"
+HOMEPAGE = "http://rt2x00.serialmonkey.com/"
+SECTION = "kernel/modules"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/rt2400/rt2570-${PV}.tar.gz"
+
+inherit module
+
+S = "${WORKDIR}/${PN}-${PV}/Module/"
+
+EXTRA_OEMAKE = "KERNDIR=${STAGING_KERNEL_DIR}"
+
+do_install() {
+       install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra
+       install -m 0644 rt2570${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra/
+}
index fa5720e..a399def 100644 (file)
@@ -2,6 +2,7 @@ DESCRIPTION = "Scientific calculator with user definable constants and functions
 HOMEPAGE = "http://homepage3.nifty.com/cam/slcalc.htm"
 SECTION = "opie/applications"
 LICENSE = "GPL"
+PR = "r1"
 
 APPTYPE = "binary"
 APPDESKTOP = "${S}"
@@ -14,5 +15,5 @@ S = "${WORKDIR}/slcalc_source"
 
 do_install() {
        install -d ${D}${palmtopdir}/pics
-       install -m 0644 slcalc2.png ${D}${palmtopdir}/pics/
+       install -m 0644 slcalc2.png ${D}${palmtopdir}/pics/slcalc.png
 }