lm_sensors - Initial add.
authorRaymond Danks <raymond@edanks.com>
Wed, 31 May 2006 22:38:36 +0000 (22:38 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Wed, 31 May 2006 22:38:36 +0000 (22:38 +0000)
packages/lm_sensors/.mtn2git_empty [new file with mode: 0644]
packages/lm_sensors/lmsensors-apps_2.9.2.bb [new file with mode: 0644]

diff --git a/packages/lm_sensors/.mtn2git_empty b/packages/lm_sensors/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/lm_sensors/lmsensors-apps_2.9.2.bb b/packages/lm_sensors/lmsensors-apps_2.9.2.bb
new file mode 100644 (file)
index 0000000..cc5dfe4
--- /dev/null
@@ -0,0 +1,32 @@
+# lmsensors-apps .bb build file
+# Copyright (C) 2006, Advanced Micro Devices, Inc.  All Rights Reserved
+# Released under the MIT license (see /COPYING)
+
+HOMEPAGE="http://secure.netroedge.com/~lm78/"
+DESCRIPTION="Hardware health monitoring applications"
+MAINTAINER = "Raymond Danks <info-linux@geode.amd.com>"
+LICENSE = "GPL"
+
+SRC_URI="http://secure.netroedge.com/~lm78/archive/lm_sensors-${PV}.tar.gz"
+
+S="${WORKDIR}/lm_sensors-${PV}"
+
+PACKAGES="sensors-i2cdump sensors-i2cset sensors-i2cdetect"
+
+FILES_sensors-i2cdump="${bindir}/i2cdump"
+FILES_sensors-i2cset="${bindir}/i2cset"
+FILES_sensors-i2cdetect="${bindir}/i2cdetect"
+
+do_configure() {
+}
+
+do_compile() {
+       oe_runmake LINUX=${STAGING_KERNEL_DIR} user
+}
+
+APPS="${S}/prog/dump/i2cdump ${S}/prog/dump/i2cset ${S}/prog/detect/i2cdetect"
+
+do_install() {
+       install -d ${D}${bindir}
+       install -m 0755 ${APPS} ${D}${bindir}
+}