tightvnc: bump to 1.3.9
authorJunqian Gordon Xu <xjqian@gmail.com>
Sun, 21 Sep 2008 15:47:00 +0000 (15:47 +0000)
committerJunqian Gordon Xu <xjqian@gmail.com>
Sun, 21 Sep 2008 15:47:00 +0000 (15:47 +0000)
* fix hard coded path and package name
* note: only tightvnc-viewer is built and shipped

packages/vnc/tightvnc_1.3.9.bb [new file with mode: 0644]
packages/vnc/tightvnc_1.3dev7.bb [deleted file]

diff --git a/packages/vnc/tightvnc_1.3.9.bb b/packages/vnc/tightvnc_1.3.9.bb
new file mode 100644 (file)
index 0000000..ec6a705
--- /dev/null
@@ -0,0 +1,25 @@
+DESCRIPTION-${PN}-viewer = "A lightweight VNC viewer"
+HOMEPAGE = "http://www.tightvnc.com/"
+DEPENDS = "virtual/libx11 zlib libxmu libxaw"
+LICENSE = "GPL"
+
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/vnc-tight/${PN}-${PV}_unixsrc.tar.gz \
+           file://Makefile"
+
+S = "${WORKDIR}/vnc_unixsrc/vncviewer/"
+
+PACKAGES = "${PN}-viewer-dbg ${PN}-viewer"
+FILES_${PN}-viewer-dbg = "${bindir}/.debug"
+FILES_${PN}-viewer = "${bindir}/${PN}viewer"
+
+do_compile () {
+       install ${WORKDIR}/Makefile ${S}
+       oe_runmake
+}
+
+do_install () {
+       install -d ${D}${bindir}
+       install ${PN}viewer ${D}${bindir}
+}
diff --git a/packages/vnc/tightvnc_1.3dev7.bb b/packages/vnc/tightvnc_1.3dev7.bb
deleted file mode 100644 (file)
index 64d9748..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-DESCRIPTION = "A Unix VNC client"
-HOMEPAGE = "http://www.tightvnc.com/"
-DEPENDS = "virtual/libx11 zlib libxmu libxaw"
-LICENSE = "GPL"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/vnc-tight/tightvnc-1.3dev7_unixsrc.tar.gz \
-           file://Makefile"
-
-S = "${WORKDIR}/vnc_unixsrc/vncviewer/"
-
-PACKAGES = "tightvncviewer-dbg tightvncviewer"
-FILES_tightvncviewer = "/usr/bin/tightvncviewer"
-
-do_compile () {
-       install ${WORKDIR}/Makefile ${S}
-       oe_runmake
-}
-
-do_install () {
-       install -d ${D}${bindir}
-       install tightvncviewer ${D}${bindir}
-}
-