klibc: add x86 targets. close bug# 4567
authorJunqian Gordon Xu <xjqian@gmail.com>
Sun, 21 Sep 2008 06:33:39 +0000 (06:33 +0000)
committerJunqian Gordon Xu <xjqian@gmail.com>
Sun, 21 Sep 2008 06:33:39 +0000 (06:33 +0000)
packages/klibc/klibc-common.inc
packages/klibc/klibc-utils-static_1.5.bb
packages/klibc/klibc_1.5.bb

index 87fb649..ff67450 100644 (file)
@@ -17,6 +17,11 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
 KLIBC_ARCH = '${TARGET_ARCH}'
 KLIBC_ARCH_armeb = 'arm'
 KLIBC_ARCH_mipsel = 'mips'
+KLIBC_ARCH_x86 = 'i386'
+KLIBC_ARCH_i486 = 'i386'
+KLIBC_ARCH_i586 = 'i386'
+KLIBC_ARCH_i686 = 'i386'
+KLIBC_ARCH_pentium = 'i386'
 
 # the klibc code contains ARM instructions (for ARM), this
 # could be fixed, but for the moment:
index f7015ff..14a9f6b 100644 (file)
@@ -1,6 +1,6 @@
 require klibc-common.inc
 
-PR = "r10"
+PR = "r11"
 
 # We only want the static utils. klibc build both. So we install only what we want.                            
 do_install() {
index 70d2819..a607aa8 100644 (file)
@@ -1,2 +1,2 @@
 require klibc.inc
-PR = "r8"
+PR = "r9"