enchant_1.2.5.bb : add a new version and fix a problem with configure.in
authorGraeme Gregory <dp@xora.org.uk>
Fri, 14 Apr 2006 10:50:48 +0000 (10:50 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Fri, 14 Apr 2006 10:50:48 +0000 (10:50 +0000)
that was preventing aspell support building.

packages/enchant/enchant_1.2.5.bb [new file with mode: 0644]
packages/enchant/files/.mtn2git_empty [new file with mode: 0644]
packages/enchant/files/configure.patch [new file with mode: 0644]

diff --git a/packages/enchant/enchant_1.2.5.bb b/packages/enchant/enchant_1.2.5.bb
new file mode 100644 (file)
index 0000000..693b2d9
--- /dev/null
@@ -0,0 +1,27 @@
+DESCRIPTION = "Enchant Spell checker API Library"
+MAINTAINER  = "AbiWord Team"
+PRIORITY    = "optional"
+SECTION     = "libs"
+
+DEPENDS     = "aspell"
+RDEPENDS    = "aspell"
+
+inherit autotools pkgconfig
+
+PR = "r0"
+
+S = "${WORKDIR}/enchant-${PV}"
+
+SRC_URI = "http://www.abisource.com/downloads/enchant/${PV}/enchant-${PV}.tar.gz \
+           file://configure.patch;patch=1"
+
+EXTRA_OECONF = "--with-aspell-prefix=${STAGING_DIR}/${HOST_SYS} --enable-aspell"
+
+do_stage() {
+       oe_runmake install prefix=${STAGING_DIR} \
+              bindir=${STAGING_BINDIR} \
+              includedir=${STAGING_INCDIR} \
+              libdir=${STAGING_LIBDIR} \
+              datadir=${STAGING_DATADIR} \
+              mandir=${STAGING_DIR}/share/man
+}
diff --git a/packages/enchant/files/.mtn2git_empty b/packages/enchant/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/enchant/files/configure.patch b/packages/enchant/files/configure.patch
new file mode 100644 (file)
index 0000000..6f1f23e
--- /dev/null
@@ -0,0 +1,10 @@
+--- enchant-1.2.5/configure.in.orig    2006-04-14 11:08:20.000000000 +0100
++++ enchant-1.2.5/configure.in 2006-04-14 11:12:03.000000000 +0100
+@@ -147,6 +147,7 @@
+        LDFLAGS="-L$with_aspell_prefix/lib "$LDFLAGS
+        ASPELL_INC="-I$with_aspell_prefix/include"
+        ASPELL_LIBS="-L$with_aspell_prefix/lib -laspell"
++       aspell_prefix=$with_aspell_prefix
+    else
+        aspell_prefix=${prefix}
+        if test "x$prefix" = "xNONE"; then