e17: bump SRCREV and start adapting it to new-style staging
authorKoen Kooi <koen@openembedded.org>
Thu, 26 Nov 2009 13:20:22 +0000 (14:20 +0100)
committerKoen Kooi <koen@openembedded.org>
Thu, 26 Nov 2009 13:20:22 +0000 (14:20 +0100)
classes/efl.bbclass
conf/distro/include/sane-srcrevs.inc
recipes/efl1/ecore_svn.bb
recipes/efl1/evas-native_svn.bb
recipes/efl1/evas_svn.bb

index d4c3baa..900d9c7 100644 (file)
@@ -11,16 +11,19 @@ PE = "2"
 
 ARM_INSTRUCTION_SET = "arm"
 
-AUTOTOOLS_STAGE_PKGCONFIG = "1"
-# do NOT inherit pkgconfig here, see note in autotools_stage_all
 inherit autotools
 
+# evas-native looks at this var, so keep it
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
 do_configure_prepend() {
        touch config.rpath
 }
 
-do_stage() {
-       autotools_stage_all
+do_install_prepend () {
+       for i in `find ${S}/ -name "*.pc" -type f` ; do \
+               sed -i -e 's:-L${STAGING_LIBDIR}::g' -e 's:-I${STAGING_INCDIR}::g' $i
+       done
 }
 
 # This construction is stupid, someone with more E knowledge should change it to =+ or something
index ce98869..cff2d43 100644 (file)
@@ -340,7 +340,7 @@ SRCREV_pn-xserver-kdrive-glamo ?= "9b28d998424c77fbc057dd3a022ccbb122793a52"
 # Enlightenment Foundation Libraries
 # Caution: This is not alphabetically, but (roughly) dependency-sorted.
 # Please leave it like that.
-EFL_SRCREV ?= "43437"
+EFL_SRCREV ?= "43996"
 SRCREV_pn-edb-native ?= "${EFL_SRCREV}"
 SRCREV_pn-edb ?= "${EFL_SRCREV}"
 SRCREV_pn-eina-native ?= "${EFL_SRCREV}"
index 5be2dc8..a6c5195 100644 (file)
@@ -1,5 +1,5 @@
 require ecore.inc
-PR = "r6"
+PR = "r7"
 
 SRC_URI += "file://iconv.patch;patch=1 \
             file://exit_uclibc.patch;patch=1 \
@@ -27,7 +27,7 @@ EXTRA_OECONF = "\
   --disable-ecore-x-xcb \
   --disable-ecore-directfb \
   --disable-ecore-sdl \
-  --disable-ecore-evas-x11-gl \
+  --enable-ecore-evas-x11-gl \
   --disable-ecore-evas-dfb \
   --disable-ecore-evas-sdl \
   --disable-openssl \
index d3da665..0cb192c 100644 (file)
@@ -63,7 +63,7 @@ EXTRA_OECONF = "\
 
 
 # evas needs a different oe_libinstall, so copy/paste autotools_stage_all
-do_stage() {
+do_oldstage() {
         rm -rf ${STAGE_TEMP}
         mkdir -p ${STAGE_TEMP}
         oe_runmake DESTDIR="${STAGE_TEMP}" install
index 2177981..b73d815 100644 (file)
@@ -19,7 +19,6 @@ EXTRA_OECONF = "\
                --enable-software-x11           \
                --enable-software-16-x11        \
                --disable-software-xcb          \
-               --disable-gl-x11                        \
                --enable-xrender-x11            \
                --disable-xrender-xcb           \
                --disable-glitz-x11                     \