hostap-daemon: use version 0.5.10 by default
authorJeremy Laine <jeremy.laine@m4x.org>
Mon, 28 Apr 2008 15:39:55 +0000 (15:39 +0000)
committerJeremy Laine <jeremy.laine@m4x.org>
Mon, 28 Apr 2008 15:39:55 +0000 (15:39 +0000)
packages/hostap/hostap-daemon-0.5.10/.mtn2git_empty [new file with mode: 0644]
packages/hostap/hostap-daemon-0.5.10/makefile-cross.diff [new file with mode: 0644]
packages/hostap/hostap-daemon-0.6.3/.mtn2git_empty [deleted file]
packages/hostap/hostap-daemon-0.6.3/makefile-cross.diff [deleted file]
packages/hostap/hostap-daemon_0.5.1.bb [deleted file]
packages/hostap/hostap-daemon_0.5.10.bb [new file with mode: 0644]
packages/hostap/hostap-daemon_0.6.3.bb [deleted file]

diff --git a/packages/hostap/hostap-daemon-0.5.10/.mtn2git_empty b/packages/hostap/hostap-daemon-0.5.10/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/hostap/hostap-daemon-0.5.10/makefile-cross.diff b/packages/hostap/hostap-daemon-0.5.10/makefile-cross.diff
new file mode 100644 (file)
index 0000000..43b275c
--- /dev/null
@@ -0,0 +1,31 @@
+diff -urN hostapd-0.5.10.orig/Makefile hostapd-0.5.10/Makefile
+--- hostapd-0.5.10.orig/Makefile       2008-02-20 01:08:54.000000000 +0100
++++ hostapd-0.5.10/Makefile    2008-04-28 17:01:36.000000000 +0200
+@@ -1,10 +1,14 @@
++ifndef CC
+ CC=gcc
++endif
+ DIR_WPA_SUPPLICANT=.
+ ifndef CFLAGS
+ CFLAGS = -MMD -O2 -Wall -g
+ endif
++TARGET_PREFIX ?= /usr/local/bin/
++
+ # define HOSTAPD_DUMP_STATE to include SIGUSR1 handler for dumping state to
+ # a file (undefine it, if you want to save in binary size)
+ CFLAGS += -DHOSTAPD_DUMP_STATE
+@@ -333,10 +337,10 @@
+       fi
+ install: all
+-      for i in $(ALL); do cp $$i /usr/local/bin/$$i; done
++      for i in $(ALL); do cp $$i $(TARGET_PREFIX)/$$i; done
+ hostapd: $(OBJS)
+-      $(CC) -o hostapd $(OBJS) $(LIBS)
++      $(CC) $(LDFLAGS) -o hostapd $(OBJS) $(LIBS)
+ driver_conf.c: Makefile .config
+       rm -f driver_conf.c
diff --git a/packages/hostap/hostap-daemon-0.6.3/.mtn2git_empty b/packages/hostap/hostap-daemon-0.6.3/.mtn2git_empty
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/packages/hostap/hostap-daemon-0.6.3/makefile-cross.diff b/packages/hostap/hostap-daemon-0.6.3/makefile-cross.diff
deleted file mode 100644 (file)
index 9534199..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -urN hostapd.orig/Makefile hostapd/Makefile
---- hostapd.orig/Makefile      2007-05-28 19:26:55.000000000 +0200
-+++ hostapd/Makefile   2007-11-22 16:28:44.000000000 +0100
-@@ -6,6 +6,8 @@
- CFLAGS = -MMD -O2 -Wall -g
- endif
-+TARGET_PREFIX ?= /usr/local/bin/
-+
- # define HOSTAPD_DUMP_STATE to include SIGUSR1 handler for dumping state to
- # a file (undefine it, if you want to save in binary size)
- CFLAGS += -DHOSTAPD_DUMP_STATE
-@@ -361,10 +363,10 @@
-       fi
- install: all
--      for i in $(ALL); do cp $$i /usr/local/bin/$$i; done
-+      for i in $(ALL); do cp $$i $(TARGET_PREFIX)/$$i; done
- hostapd: $(OBJS)
--      $(CC) -o hostapd $(OBJS) $(LIBS)
-+      $(CC) $(LDFLAGS) -o hostapd $(OBJS) $(LIBS)
- OBJS_c = hostapd_cli.o ../src/common/wpa_ctrl.o ../src/utils/os_$(CONFIG_OS).o
- hostapd_cli: $(OBJS_c)
diff --git a/packages/hostap/hostap-daemon_0.5.1.bb b/packages/hostap/hostap-daemon_0.5.1.bb
deleted file mode 100644 (file)
index de3abdb..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-require hostap-daemon.inc
-
-PR = "r1"
-
-DEFAULT_PREFERENCE = "-1"
diff --git a/packages/hostap/hostap-daemon_0.5.10.bb b/packages/hostap/hostap-daemon_0.5.10.bb
new file mode 100644 (file)
index 0000000..f75efc4
--- /dev/null
@@ -0,0 +1,42 @@
+DESCRIPTION = "User space daemon for extended IEEE 802.11 management"
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "openssl ${@base_contains("COMBINED_FEATURES", "pci", "madwifi-ng", "",d)}"
+
+#we introduce MY_ARCH to get 'armv5te' as arch instead of the misleading 'arm' on armv5te builds
+MY_ARCH := "${PACKAGE_ARCH}"
+PACKAGE_ARCH = "${@base_contains('COMBINED_FEATURES', 'pci', '${MACHINE_ARCH}', '${MY_ARCH}', d)}"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
+       file://makefile-cross.diff;patch=1 \
+       file://defconfig \
+       file://init"
+
+S = "${WORKDIR}/hostapd-${PV}"
+
+export HAS_PCI = "${@base_contains('COMBINED_FEATURES', 'pci', 1, 0,d)}"
+
+inherit update-rc.d
+INITSCRIPT_NAME=hostapd
+
+do_configure() {
+       install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+       if [ "x$HAS_PCI" == "x1" ] ; then
+               echo "CONFIG_DRIVER_MADWIFI=y" >> .config
+               echo "CFLAGS += -I${STAGING_INCDIR}/madwifi-ng" >> .config
+       fi
+}
+
+do_compile() {
+       make
+}
+
+do_install() {
+       install -d ${D}${sbindir} ${D}${sysconfdir}/init.d
+       make TARGET_PREFIX=${D}${sbindir} install
+       install -m 0644 hostapd.conf ${D}${sysconfdir}
+       install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
+}
+
diff --git a/packages/hostap/hostap-daemon_0.6.3.bb b/packages/hostap/hostap-daemon_0.6.3.bb
deleted file mode 100644 (file)
index 37b710d..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-DESCRIPTION = "User space daemon for extended IEEE 802.11 management"
-HOMEPAGE = "http://hostap.epitest.fi"
-SECTION = "kernel/userland"
-PRIORITY = "optional"
-LICENSE = "GPL"
-DEPENDS = "openssl ${@base_contains("COMBINED_FEATURES", "pci", "madwifi-ng", "",d)}"
-
-DEFAULT_PREFERENCE = "-1"
-
-SRC_URI = "http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
-       file://makefile-cross.diff;patch=1 \
-       file://defconfig \
-       file://init"
-
-S = "${WORKDIR}/hostapd-${PV}/hostapd"
-
-export HAS_PCI = "${@base_contains('COMBINED_FEATURES', 'pci', 1, 0,d)}"
-
-inherit update-rc.d
-INITSCRIPT_NAME=hostapd
-
-do_configure() {
-       install -m 0644 ${WORKDIR}/defconfig ${S}/.config
-       if [ "x$HAS_PCI" == "x1" ] ; then
-               echo "CONFIG_DRIVER_MADWIFI=y" >> .config
-               echo "CFLAGS += -I${STAGING_INCDIR}/madwifi-ng" >> .config
-       fi
-}
-
-do_compile() {
-       CFLAGS='${CFLAGS}' CC='${CC}' make
-}
-
-do_install() {
-       install -d ${D}${sbindir} ${D}${sysconfdir}/init.d
-       make TARGET_PREFIX=${D}${sbindir} install
-       install -m 0644 hostapd.conf ${D}${sysconfdir}
-       install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
-}
-