procps: update to 3.2.7
authorKoen Kooi <koen@openembedded.org>
Fri, 13 Oct 2006 12:57:13 +0000 (12:57 +0000)
committerKoen Kooi <koen@openembedded.org>
Fri, 13 Oct 2006 12:57:13 +0000 (12:57 +0000)
packages/procps/procps-3.2.7/.mtn2git_empty [new file with mode: 0644]
packages/procps/procps-3.2.7/install.patch [new file with mode: 0644]
packages/procps/procps-3.2.7/pagesz-not-constant.patch [new file with mode: 0644]
packages/procps/procps-3.2.7/procmodule.patch [new file with mode: 0644]
packages/procps/procps-3.2.7/psmodule.patch [new file with mode: 0644]
packages/procps/procps_3.2.7.bb [new file with mode: 0644]

diff --git a/packages/procps/procps-3.2.7/.mtn2git_empty b/packages/procps/procps-3.2.7/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/procps/procps-3.2.7/install.patch b/packages/procps/procps-3.2.7/install.patch
new file mode 100644 (file)
index 0000000..9f1ef69
--- /dev/null
@@ -0,0 +1,27 @@
+--- procps-3.2.5.virgin/Makefile       2005-01-26 05:55:26.000000000 +0100
++++ procps-3.2.5/Makefile      2005-08-03 04:55:26.346984488 +0200
+@@ -30,7 +30,10 @@
+ install  := install -D --owner 0 --group 0
+ # Lame x86-64 /lib64 and /usr/lib64 abomination:
+-lib64    := lib$(shell [ -d /lib64 ] && echo 64)
++# lib64    := lib$(shell [ -d /lib64 ] && echo 64)
++
++# Equally lame hack to work around makefile lameness when the host arch is 64bit, but the target is not.
++lib64      := lib
+ usr/bin                  := $(DESTDIR)/usr/bin/
+ bin                      := $(DESTDIR)/bin/
+@@ -211,10 +214,10 @@
+ ###### install
+ $(BINFILES) : all
+-      $(install) --mode a=rx $(notdir $@) $@
++      $(install) -m 555 $(notdir $@) $@
+ $(MANFILES) : all
+-      $(install) --mode a=r $(notdir $@) $@
++      $(install) -m 444 $(notdir $@) $@
+ install: $(filter-out $(SKIP) $(addprefix $(DESTDIR),$(SKIP)),$(INSTALL))
+       cd $(usr/bin) && $(ln_f) skill snice
diff --git a/packages/procps/procps-3.2.7/pagesz-not-constant.patch b/packages/procps/procps-3.2.7/pagesz-not-constant.patch
new file mode 100644 (file)
index 0000000..8e9e1eb
--- /dev/null
@@ -0,0 +1,22 @@
+Index: procps-3.2.1/proc/devname.c
+===================================================================
+--- procps-3.2.1.orig/proc/devname.c   2004-03-18 05:43:50.000000000 +1100
++++ procps-3.2.1/proc/devname.c        2005-04-02 10:40:17.462138000 +1000
+@@ -227,7 +227,7 @@
+ /* number --> name */
+ unsigned dev_to_tty(char *restrict ret, unsigned chop, dev_t dev_t_dev, int pid, unsigned int flags) {
+-  static char buf[PAGE_SIZE];
++  static char buf[4096];
+   char *restrict tmp = buf;
+   unsigned dev = dev_t_dev;
+   unsigned i = 0;
+@@ -249,7 +249,7 @@
+   if((flags&ABBREV_TTY) && !strncmp(tmp,"tty",  3) && tmp[3]) tmp += 3;
+   if((flags&ABBREV_PTS) && !strncmp(tmp,"pts/", 4) && tmp[4]) tmp += 4;
+   /* gotta check before we chop or we may chop someone else's memory */
+-  if(chop + (unsigned long)(tmp-buf) <= sizeof buf)
++  if(chop + (unsigned long)(tmp-buf) < sizeof buf)
+     tmp[chop] = '\0';
+   /* replace non-ASCII characters with '?' and return the number of chars */
+   for(;;){
diff --git a/packages/procps/procps-3.2.7/procmodule.patch b/packages/procps/procps-3.2.7/procmodule.patch
new file mode 100644 (file)
index 0000000..fabfaba
--- /dev/null
@@ -0,0 +1,36 @@
+*** procps-3.2.5/proc/module.mk.orig   Sun Jul 24 11:53:49 2005
+--- procps-3.2.5/proc/module.mk        Sun Jul 24 11:54:32 2005
+***************
+*** 96,102 ****
+  #################### install rules ###########################
+  
+  $(lib)$(SOFILE) : proc/$(SONAME)
+!      $(install) --mode a=rx $< $@
+  
+  ifneq ($(SOLINK),$(SOFILE))
+  .PHONY: $(lib)$(SOLINK)
+--- 96,102 ----
+  #################### install rules ###########################
+  
+  $(lib)$(SOFILE) : proc/$(SONAME)
+!      $(install) -m 555 $< $@
+  
+  ifneq ($(SOLINK),$(SOFILE))
+  .PHONY: $(lib)$(SOLINK)
+***************
+*** 115,121 ****
+       $(ldconfig)
+  
+  $(usr/lib)$(ANAME) : proc/$(ANAME)
+!      $(install) --mode a=r $< $@
+  
+  # Junk anyway... supposed to go in /usr/include/$(NAME)
+  #INSTALL += $(addprefix $(include),$(HDRFILES))
+--- 115,121 ----
+       $(ldconfig)
+  
+  $(usr/lib)$(ANAME) : proc/$(ANAME)
+!      $(install) -m 444 $< $@
+  
+  # Junk anyway... supposed to go in /usr/include/$(NAME)
+  #INSTALL += $(addprefix $(include),$(HDRFILES))
diff --git a/packages/procps/procps-3.2.7/psmodule.patch b/packages/procps/procps-3.2.7/psmodule.patch
new file mode 100644 (file)
index 0000000..f298c1c
--- /dev/null
@@ -0,0 +1,21 @@
+*** procps-3.2.5/ps/module.mk.orig     Sun Jul 24 11:54:40 2005
+--- procps-3.2.5/ps/module.mk  Sun Jul 24 11:55:02 2005
+***************
+*** 33,40 ****
+  
+  
+  $(bin)ps: ps/ps
+!      $(install) --mode a=rx $< $@
+  
+  $(man1)ps.1 : ps/ps.1
+!      $(install) --mode a=r $< $@
+       -rm -f $(DESTDIR)/var/catman/cat1/ps.1.gz $(DESTDIR)/var/man/cat1/ps.1.gz
+--- 33,40 ----
+  
+  
+  $(bin)ps: ps/ps
+!      $(install) -m 555 $< $@
+  
+  $(man1)ps.1 : ps/ps.1
+!      $(install) -m 444 $< $@
+       -rm -f $(DESTDIR)/var/catman/cat1/ps.1.gz $(DESTDIR)/var/man/cat1/ps.1.gz
diff --git a/packages/procps/procps_3.2.7.bb b/packages/procps/procps_3.2.7.bb
new file mode 100644 (file)
index 0000000..0aaf82a
--- /dev/null
@@ -0,0 +1,56 @@
+LICENSE = "GPL"
+DESCRIPTION = "Procps is the package that has a bunch \
+of small useful utilities that give information \
+about processes using the /proc filesystem. The package \
+includes the programs ps, top, vmstat, w, kill, and skill."
+SECTION = "base"
+PRIORITY = "optional"
+DEPENDS = "ncurses"
+PR = "r5"
+
+SRC_URI = "http://procps.sourceforge.net/procps-${PV}.tar.gz \
+           file://install.patch;patch=1 \
+           file://procmodule.patch;patch=1 \
+           file://psmodule.patch;patch=1"
+
+
+
+inherit autotools 
+FILES = "${bindir}/top.${PN} ${base_bindir}/ps.${PN} ${bindir}/uptime.${PN} ${base_bindir}/kill.${PN} \
+        ${bindir}/free.${PN} ${bindir}/w ${bindir}/watch ${bindir}/pgrep ${bindir}/pmap ${bindir}/pwdx \
+        ${bindir}/snice ${bindir}/vmstat ${bindir}/slabtop ${bindir}/pkill ${bindir}/skill ${bindir}/tload \
+        ${base_sbindir}/sysctl.${PN}"
+
+EXTRA_OEMAKE = "CFLAGS=-I${STAGING_INCDIR} \
+               CPPFLAGS=-I${STAGING_INCDIR} \
+                LDFLAGS=-L${STAGING_LIBDIR} -Wl,--rpath-link,${STAGING_LIBDIR} \
+                CURSES=-lncurses \
+                install='install -D' \
+                ldconfig=echo"
+
+do_install_append () {
+       mv ${D}${bindir}/uptime ${D}${bindir}/uptime.${PN}
+       mv ${D}${bindir}/top ${D}${bindir}/top.${PN}
+       mv ${D}${base_bindir}/kill ${D}${base_bindir}/kill.${PN}
+       mv ${D}${base_bindir}/ps ${D}${base_bindir}/ps.${PN}
+       mv ${D}${bindir}/free ${D}${bindir}/free.${PN}
+       mv ${D}${base_sbindir}/sysctl ${D}${base_sbindir}/sysctl.${PN}
+}      
+
+pkg_postinst() {
+       update-alternatives --install ${bindir}/top top top.${PN} 90
+       update-alternatives --install ${bindir}/uptime uptime uptime.${PN} 90
+       update-alternatives --install ${base_bindir}/ps ps ps.${PN} 90
+       update-alternatives --install ${base_bindir}/kill kill kill.${PN} 90
+       update-alternatives --install ${bindir}/free free free.${PN} 90
+       update-alternatives --install ${base_sbindir}/sysctl sysctl sysctl.${PN} 90
+}
+
+pkg_postrm() {
+       update-alternatives --remove top top.${PN}
+       update-alternatives --remove ps ps.${PN}
+       update-alternatives --remove uptime uptime.${PN}
+       update-alternatives --remove kill kill.${PN}
+       update-alternatives --remove free free.${PN}
+       update-alternatives --remove sysctl sysctl.${PN}
+}