opkg: fix bug that occured with file names of exactly 100 chars in the tar file
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>
Wed, 11 Feb 2009 21:32:06 +0000 (22:32 +0100)
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>
Wed, 11 Feb 2009 21:32:06 +0000 (22:32 +0100)
packages/opkg/files/opkg_unarchive.patch [new file with mode: 0644]
packages/opkg/opkg-native_svn.bb
packages/opkg/opkg-nogpg-nocurl_svn.bb
packages/opkg/opkg-nogpg_svn.bb
packages/opkg/opkg-sdk_svn.bb
packages/opkg/opkg.inc
packages/opkg/opkg_svn.bb

diff --git a/packages/opkg/files/opkg_unarchive.patch b/packages/opkg/files/opkg_unarchive.patch
new file mode 100644 (file)
index 0000000..9e5ccfb
--- /dev/null
@@ -0,0 +1,13 @@
+--- trunk/libbb/unarchive.c.orig       2009-02-11 22:14:58.000000000 +0100
++++ trunk/libbb/unarchive.c    2009-02-11 22:15:07.000000000 +0100
+@@ -606,6 +606,10 @@
+                 tar_entry->name = concat_path_file(tar.formated.prefix, tar.formated.name);
+         }
++      if (strlen(tar_entry->name) > 100) {
++              tar_entry->name[100] = 0;
++      }
++
+       // tar_entry->name = xstrdup(tar.formated.name);
+ /*
index 57c6e61..82c74e0 100644 (file)
@@ -1,7 +1,7 @@
 require opkg.inc
 
 DEPENDS = "curl-native"
-PR = "r2"
+PR = "r3"
 
 target_libdir := "${libdir}"
 
index 4daa58f..71133cb 100644 (file)
@@ -10,7 +10,7 @@ SRC_URI += " \
            file://opkg_wget_nogpg_02_use_vfork_system.patch;patch=1 \
            file://opkg_wget_nogpg_03_fix_tmpdirs.patch;patch=1 \
           "
-PR = "r3"
+PR = "r4"
 
 SRCREV = "${SRCREV_pn-opkg}"
 
index f58df2f..a9297d7 100644 (file)
@@ -3,7 +3,7 @@ require opkg_svn.bb
 DEPENDS = "curl"
 PROVIDES += "opkg"
 
-PR = "r2"
+PR = "r3"
 
 SRCREV = "${SRCREV_pn-opkg}"
 
index c28fe97..d9b3727 100644 (file)
@@ -1,7 +1,7 @@
 require opkg.inc
 
 DEPENDS = "curl-sdk"
-PR = "r2"
+PR = "r3"
 target_libdir := "${libdir}"
 inherit sdk
 
index b586e70..bd16f92 100644 (file)
@@ -5,7 +5,8 @@ LICENSE = "GPL"
 DEPENDS = "curl gpgme"
 PV = "0.1.6+svnr${SRCREV}"
 
-SRC_URI = "svn://opkg.googlecode.com/svn;module=trunk;proto=http"
+SRC_URI = "svn://opkg.googlecode.com/svn;module=trunk;proto=http \
+       file://opkg_unarchive.patch;patch=1"
 S = "${WORKDIR}/trunk"
 
 inherit autotools pkgconfig
index 4cf1c5c..a472897 100644 (file)
@@ -1,6 +1,6 @@
 require opkg.inc
 
-PR = "r1"
+PR = "r2"
 
 PACKAGES =+ "libopkg-dev libopkg"