libgpg-error: unify. partly closes 1688.
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>
Fri, 2 May 2008 17:58:56 +0000 (17:58 +0000)
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>
Fri, 2 May 2008 17:58:56 +0000 (17:58 +0000)
packages/libgpg-error/libgpg-error.inc [new file with mode: 0644]
packages/libgpg-error/libgpg-error_0.7.bb
packages/libgpg-error/libgpg-error_1.0.bb
packages/libgpg-error/libgpg-error_1.3.bb
packages/libgpg-error/libgpg-error_1.4.bb

diff --git a/packages/libgpg-error/libgpg-error.inc b/packages/libgpg-error/libgpg-error.inc
new file mode 100644 (file)
index 0000000..20f62da
--- /dev/null
@@ -0,0 +1,28 @@
+DESCRIPTION = "GPG-Error library"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-${PV}.tar.gz \
+          file://pkgconfig.patch;patch=1"
+
+# move libgpg-error-config into -dev package
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}/*"
+
+inherit autotools binconfig pkgconfig
+
+do_stage() {
+       oe_libinstall -a -so -C src libgpg-error ${STAGING_LIBDIR}
+       install -d ${STAGING_BINDIR_CROSS}/
+       install -m 0755 src/gpg-error-config ${STAGING_BINDIR_CROSS}/
+
+       install -d ${STAGING_INCDIR}/
+       for X in gpg-error.h
+       do
+               install -m 0644 ${S}/src/$X ${STAGING_INCDIR}/$X
+       done
+
+       install -d ${STAGING_DATADIR}/aclocal
+       install -m 0644 src/gpg-error.m4 ${STAGING_DATADIR}/aclocal/
+}
index 7edea97..edbe91a 100644 (file)
@@ -1,29 +1,6 @@
+require libgpg-error.inc
+
 PR = "r4"
-DESCRIPTION = "GPG-Error library"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "GPL LGPL FDL"
 
 SRC_URI = "ftp://ftp.gnupg.org/gcrypt/alpha/libgpg-error/libgpg-error-${PV}.tar.gz \
           file://pkgconfig.patch;patch=1"
-
-# move libgpg-error-config into -dev package
-FILES_${PN} = "${libdir}/lib*.so.*"
-FILES_${PN}-dev += "${bindir}"
-
-inherit autotools binconfig pkgconfig
-
-do_stage() {
-       oe_libinstall -a -so -C src libgpg-error ${STAGING_LIBDIR}
-       install -d ${STAGING_BINDIR_CROSS}/
-       install -m 0755 src/gpg-error-config ${STAGING_BINDIR_CROSS}/
-
-       install -d ${STAGING_INCDIR}/
-       for X in gpg-error.h
-       do
-               install -m 0644 ${S}/src/$X ${STAGING_INCDIR}/$X
-       done
-
-       install -d ${STAGING_DATADIR}/aclocal
-       install -m 0644 src/gpg-error.m4 ${STAGING_DATADIR}/aclocal/
-}
index e520a23..bdbbed0 100644 (file)
@@ -1,29 +1,3 @@
-PR = "r1"
-DESCRIPTION = "GPG-Error library"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "GPL LGPL FDL"
-
-SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-${PV}.tar.gz \
-          file://pkgconfig.patch;patch=1"
-
-# move libgpg-error-config into -dev package
-FILES_${PN} = "${libdir}/lib*.so.*"
-FILES_${PN}-dev += "${bindir}/*"
-
-inherit autotools binconfig pkgconfig
+require libgpg-error.inc
 
-do_stage() {
-       oe_libinstall -a -so -C src libgpg-error ${STAGING_LIBDIR}
-       install -d ${STAGING_BINDIR_CROSS}/
-       install -m 0755 src/gpg-error-config ${STAGING_BINDIR_CROSS}/
-
-       install -d ${STAGING_INCDIR}/
-       for X in gpg-error.h
-       do
-               install -m 0644 ${S}/src/$X ${STAGING_INCDIR}/$X
-       done
-
-       install -d ${STAGING_DATADIR}/aclocal
-       install -m 0644 src/gpg-error.m4 ${STAGING_DATADIR}/aclocal/
-}
+PR = "r1"
index e520a23..bdbbed0 100644 (file)
@@ -1,29 +1,3 @@
-PR = "r1"
-DESCRIPTION = "GPG-Error library"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "GPL LGPL FDL"
-
-SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-${PV}.tar.gz \
-          file://pkgconfig.patch;patch=1"
-
-# move libgpg-error-config into -dev package
-FILES_${PN} = "${libdir}/lib*.so.*"
-FILES_${PN}-dev += "${bindir}/*"
-
-inherit autotools binconfig pkgconfig
+require libgpg-error.inc
 
-do_stage() {
-       oe_libinstall -a -so -C src libgpg-error ${STAGING_LIBDIR}
-       install -d ${STAGING_BINDIR_CROSS}/
-       install -m 0755 src/gpg-error-config ${STAGING_BINDIR_CROSS}/
-
-       install -d ${STAGING_INCDIR}/
-       for X in gpg-error.h
-       do
-               install -m 0644 ${S}/src/$X ${STAGING_INCDIR}/$X
-       done
-
-       install -d ${STAGING_DATADIR}/aclocal
-       install -m 0644 src/gpg-error.m4 ${STAGING_DATADIR}/aclocal/
-}
+PR = "r1"
index e520a23..bdbbed0 100644 (file)
@@ -1,29 +1,3 @@
-PR = "r1"
-DESCRIPTION = "GPG-Error library"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "GPL LGPL FDL"
-
-SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-${PV}.tar.gz \
-          file://pkgconfig.patch;patch=1"
-
-# move libgpg-error-config into -dev package
-FILES_${PN} = "${libdir}/lib*.so.*"
-FILES_${PN}-dev += "${bindir}/*"
-
-inherit autotools binconfig pkgconfig
+require libgpg-error.inc
 
-do_stage() {
-       oe_libinstall -a -so -C src libgpg-error ${STAGING_LIBDIR}
-       install -d ${STAGING_BINDIR_CROSS}/
-       install -m 0755 src/gpg-error-config ${STAGING_BINDIR_CROSS}/
-
-       install -d ${STAGING_INCDIR}/
-       for X in gpg-error.h
-       do
-               install -m 0644 ${S}/src/$X ${STAGING_INCDIR}/$X
-       done
-
-       install -d ${STAGING_DATADIR}/aclocal
-       install -m 0644 src/gpg-error.m4 ${STAGING_DATADIR}/aclocal/
-}
+PR = "r1"