chumby-kernel: add a patch to remove hard setting CROSS_COMPILE from Makefile
authorGuo Hongruan <camelguo@gmail.com>
Sun, 31 Jan 2010 23:10:18 +0000 (23:10 +0000)
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Mon, 1 Feb 2010 10:00:35 +0000 (11:00 +0100)
* linux-2.6.16-chumby-1.2.tar.gz set CROSS_COMPILE as arm-linux- hardly.
* It causes the AR used to compile chumby-kernel is arm-linux-, but it should be set dynamically
* according CROSS_COMPILE passed by openembedded

Signed-off-by: Guo Hongruan <camelguo@gmail.com>
Acked-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
recipes/linux/chumby-kernel/Makefile-remove-hard-setting-CROSS_COMPILE.patch [new file with mode: 0644]
recipes/linux/chumby-kernel_2.6.16-chumby-1.2.bb

diff --git a/recipes/linux/chumby-kernel/Makefile-remove-hard-setting-CROSS_COMPILE.patch b/recipes/linux/chumby-kernel/Makefile-remove-hard-setting-CROSS_COMPILE.patch
new file mode 100644 (file)
index 0000000..9a0be9a
--- /dev/null
@@ -0,0 +1,18 @@
+Makefile: remove hard setting CROSS_COMPILE
+
+* linux-2.6.16-chumby-1.2.tar.gz set CROSS_COMPILE as arm-linux- hardly
+* It causes the AR used to compiling linux kernel is arm-linux-ar, which doesn't exist in openembedded at all
+Index: linux-2.6.16/Makefile
+===================================================================
+--- linux-2.6.16.orig/Makefile 2010-02-01 16:19:36.000000000 +0800
++++ linux-2.6.16/Makefile      2010-02-01 16:20:02.000000000 +0800
+@@ -173,8 +173,7 @@
+ # Note: Some architectures assign CROSS_COMPILE in their arch/*/Makefile
+ ARCH          ?= $(SUBARCH)
+-#CROSS_COMPILE        ?=
+-CROSS_COMPILE = arm-linux-
++CROSS_COMPILE ?=
+ # Architecture as present in compile.h
+ UTS_MACHINE := $(ARCH)
index b6cdf48..4967c1e 100644 (file)
@@ -9,6 +9,7 @@ SRC_URI = "http://files.chumby.com/source/ironforge/build396/linux-2.6.16-chumby
            http://files.chumby.com/source/ironforge/build396/align.pl \
            file://chumby-override-cmdline.patch;patch=1 \
            file://disable-fbchanging.patch;patch=1 \
+           file://Makefile-remove-hard-setting-CROSS_COMPILE.patch;patch=1 \
            file://defconfig \
            "