classpath-initial 0.93: Use a patch that fits to classpath 0.93.
authorRobert Schuster <thebohemian@gmx.net>
Fri, 14 Nov 2008 12:48:30 +0000 (13:48 +0100)
committerRobert Schuster <thebohemian@gmx.net>
Fri, 14 Nov 2008 22:00:23 +0000 (23:00 +0100)
packages/classpath/classpath-initial_0.93.bb
packages/classpath/files/miscompilation-0.93.patch [new file with mode: 0644]

index 09bcde1..c36ea38 100644 (file)
@@ -5,13 +5,13 @@ require classpath-native.inc
 
 DESCRIPTION="Java1.4-compatible GNU Classpath variant that is used as bootclasspath for jikes-native."
 
-PR = "r5"
+PR = "r6"
 
 DEPENDS = "zip-native fastjar-native jikes-native gettext-native"
 
 SRC_URI += "\
        file://autotools.patch;patch=1 \
-       file://miscompilation.patch;patch=1 \
+       file://miscompilation-0.93.patch;patch=1 \
        "
 
 EXTRA_OECONF = "\
diff --git a/packages/classpath/files/miscompilation-0.93.patch b/packages/classpath/files/miscompilation-0.93.patch
new file mode 100644 (file)
index 0000000..99db6f3
--- /dev/null
@@ -0,0 +1,13 @@
+Index: classpath-0.93/native/jni/java-io/java_io_VMFile.c
+===================================================================
+--- classpath-0.93.orig/native/jni/java-io/java_io_VMFile.c    2006-09-23 07:17:45.000000000 +0200
++++ classpath-0.93/native/jni/java-io/java_io_VMFile.c 2008-11-14 13:41:27.000000000 +0100
+@@ -239,7 +239,7 @@
+ {
+ #ifndef WITHOUT_FILESYSTEM
+   const char *filename;
+-  int result;
++  volatile int result;
+   /* Don't use the JCL convert function because it throws an exception
+      on failure */