llvm2.6: Updated to newer SVN snapshot (includes some patches developed in OE).
authorRobert Schuster <robertschuster@fsfe.org>
Wed, 13 May 2009 11:34:30 +0000 (13:34 +0200)
committerRobert Schuster <robertschuster@fsfe.org>
Wed, 13 May 2009 11:34:30 +0000 (13:34 +0200)
llvm2.6-native: Dito.

recipes/llvm/llvm2.6-native_2.5+svnr20090504.bb [deleted file]
recipes/llvm/llvm2.6-native_2.5+svnr20090511.bb [new file with mode: 0644]
recipes/llvm/llvm2.6/llvm-fix-have_libpthread.patch [deleted file]
recipes/llvm/llvm2.6/llvm-fix-pthreads_h.patch [deleted file]
recipes/llvm/llvm2.6_2.5+svnr20090504.bb [deleted file]
recipes/llvm/llvm2.6_2.5+svnr20090511.bb [new file with mode: 0644]

diff --git a/recipes/llvm/llvm2.6-native_2.5+svnr20090504.bb b/recipes/llvm/llvm2.6-native_2.5+svnr20090504.bb
deleted file mode 100644 (file)
index 86397c9..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-require llvm-native.inc
-
-SRCREV = "70854"
-
-PV = "2.5+svnr${SRCREV}"
-
-PR = "r0"
-
-SRC_URI = "\
-  svn://llvm.org/svn/llvm-project/llvm/;proto=http;module=trunk \
-  file://fix-build.patch;patch=1 \
-  file://llvm-enable-threads-macro.patch;patch=1;pnum=0 \
-  file://llvm-debugonly-zeroormore.patch;patch=1;pnum=0 \
-"
-
-S = "${WORKDIR}/trunk"
-
-LLVM_RELEASE = "2.6"
diff --git a/recipes/llvm/llvm2.6-native_2.5+svnr20090511.bb b/recipes/llvm/llvm2.6-native_2.5+svnr20090511.bb
new file mode 100644 (file)
index 0000000..119e191
--- /dev/null
@@ -0,0 +1,17 @@
+require llvm-native.inc
+
+SRCREV = "71428"
+
+PV = "2.5+svnr${SRCREV}"
+
+PR = "r0"
+
+SRC_URI = "\
+  svn://llvm.org/svn/llvm-project/llvm/;proto=http;module=trunk \
+  file://fix-build.patch;patch=1 \
+  file://llvm-debugonly-zeroormore.patch;patch=1;pnum=0 \
+"
+
+S = "${WORKDIR}/trunk"
+
+LLVM_RELEASE = "2.6"
diff --git a/recipes/llvm/llvm2.6/llvm-fix-have_libpthread.patch b/recipes/llvm/llvm2.6/llvm-fix-have_libpthread.patch
deleted file mode 100644 (file)
index f1072d9..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-Index: trunk/include/llvm/Config/config.h.cmake
-===================================================================
---- trunk.orig/include/llvm/Config/config.h.cmake      2009-05-06 16:39:19.957841609 +0200
-+++ trunk/include/llvm/Config/config.h.cmake   2009-05-06 16:39:20.185842055 +0200
-@@ -194,7 +194,7 @@
- #cmakedefine HAVE_LIBPSAPI ${HAVE_LIBPSAPI}
- /* Define to 1 if you have the `pthread' library (-lpthread). */
--#undef HAVE_LIBPTHREAD
-+#cmakedefine HAVE_LIBPTHREAD ${HAVE_LIBPTHREAD}
- /* Define to 1 if you have the `udis86' library (-ludis86). */
- #undef HAVE_LIBUDIS86
-Index: trunk/cmake/config-ix.cmake
-===================================================================
---- trunk.orig/cmake/config-ix.cmake   2009-05-06 16:49:45.121841057 +0200
-+++ trunk/cmake/config-ix.cmake        2009-05-06 16:50:25.738552620 +0200
-@@ -98,6 +98,11 @@
-   if( HAVE_PTHREAD_H OR WIN32 )
-     set(ENABLE_THREADS 1)
-   endif()
-+
-+# FIXME: Actually check for the library
-+  if( HAVE_PTHREAD_H )
-+    set(HAVE_LIBPTHREAD 1)
-+  endif()
- endif()
- if( ENABLE_THREADS )
diff --git a/recipes/llvm/llvm2.6/llvm-fix-pthreads_h.patch b/recipes/llvm/llvm2.6/llvm-fix-pthreads_h.patch
deleted file mode 100644 (file)
index 6f17b85..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: include/llvm/Config/config.h.cmake
-===================================================================
---- include/llvm/Config/config.h.cmake (Revision 71077)
-+++ include/llvm/Config/config.h.cmake (Arbeitskopie)
-@@ -276,6 +276,9 @@
- /* Define to have the %a format string */
- #undef HAVE_PRINTF_A
-+/* Have pthread.h */
-+#cmakedefine HAVE_PTHREAD_H ${HAVE_PTHREAD_H}
-+
- /* Have pthread_mutex_lock */
- #cmakedefine HAVE_PTHREAD_MUTEX_LOCK ${HAVE_PTHREAD_MUTEX_LOCK}
diff --git a/recipes/llvm/llvm2.6_2.5+svnr20090504.bb b/recipes/llvm/llvm2.6_2.5+svnr20090504.bb
deleted file mode 100644 (file)
index 9ba13ce..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-require llvm.inc
-
-SRCREV = "70854"
-
-PV = "2.5+svnr${SRCREV}"
-
-PR = "r0"
-
-DEPENDS = "llvm-common llvm2.6-native"
-
-SRC_URI = "\
-  svn://llvm.org/svn/llvm-project/llvm/;proto=http;module=trunk \
-  file://fix-build.patch;patch=1 \
-  file://llvm-debugonly-zeroormore.patch;patch=1;pnum=0 \
-  file://llvm-fix-pthreads_h.patch;patch=1;pnum=0 \
-  file://llvm-fix-have_libpthread.patch;patch=1 \
-"
-
-S = "${WORKDIR}/trunk"
-
-LLVM_RELEASE = "2.6"
diff --git a/recipes/llvm/llvm2.6_2.5+svnr20090511.bb b/recipes/llvm/llvm2.6_2.5+svnr20090511.bb
new file mode 100644 (file)
index 0000000..035d021
--- /dev/null
@@ -0,0 +1,19 @@
+require llvm.inc
+
+SRCREV = "71428"
+
+PV = "2.5+svnr${SRCREV}"
+
+PR = "r0"
+
+DEPENDS = "llvm-common llvm2.6-native"
+
+SRC_URI = "\
+  svn://llvm.org/svn/llvm-project/llvm/;proto=http;module=trunk \
+  file://fix-build.patch;patch=1 \
+  file://llvm-debugonly-zeroormore.patch;patch=1;pnum=0 \
+"
+
+S = "${WORKDIR}/trunk"
+
+LLVM_RELEASE = "2.6"