vala[-native]: add patch to make ByteArray usable (pending upstream inclusion)
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>
Mon, 9 Feb 2009 21:23:36 +0000 (22:23 +0100)
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>
Mon, 9 Feb 2009 21:24:18 +0000 (22:24 +0100)
packages/vala/files/expose-bytesarray-struct.patch [new file with mode: 0644]
packages/vala/vala-native_0.5.6.bb
packages/vala/vala.inc
packages/vala/vala_0.5.6.bb

diff --git a/packages/vala/files/expose-bytesarray-struct.patch b/packages/vala/files/expose-bytesarray-struct.patch
new file mode 100644 (file)
index 0000000..ea01208
--- /dev/null
@@ -0,0 +1,18 @@
+#
+# Necessary to actually use BytesArray.
+# Signed-Off: Michael 'Mickey' Lauer <mlauer@vanille-media.de>
+#
+Index: vala/vapi/glib-2.0.vapi
+===================================================================
+--- vala/vapi/glib-2.0.vapi    (Revision 2422)
++++ vala/vapi/glib-2.0.vapi    (Arbeitskopie)
+@@ -3044,6 +3044,9 @@
+               public void sort (CompareFunc compare_func);
+               public void sort_with_data (CompareDataFunc compare_func);
+               public void set_size (uint length);
++
++              public uint len;
++              public uint8[] data;
+       }
+       /* N-ary Trees */
index 8feab50..84ed835 100644 (file)
@@ -1,5 +1,5 @@
 require vala_${PV}.bb
-PR = "r0"
+PR = "r1"
 
 inherit native
 DEPENDS = "glib-2.0-native"
index efe2900..c6f5aeb 100644 (file)
@@ -7,15 +7,14 @@ LICENSE = "LGPL"
 
 MAJV = "${@bb.data.getVar('PV',d,1)[:3]}"
 
-SRC_URI = "http://download.gnome.org/sources/vala/${MAJV}/vala-${PV}.tar.bz2"
+SRC_URI = "\
+  http://download.gnome.org/sources/vala/${MAJV}/vala-${PV}.tar.bz2 \
+  file://expose-bytesarray-struct.patch;patch=1 \
+"
 S = "${WORKDIR}/vala-${PV}"
 
-inherit autotools lib_package
+inherit autotools autotools_stage lib_package
 
 EXTRA_OECONF = "--enable-vapigen"
 
-do_stage() {
-       autotools_stage_all
-}
-
 FILES_${PN}-doc += ${datadir}/devhelp
index 8775f1a..f6ee943 100644 (file)
@@ -1,2 +1,2 @@
 require vala.inc
-PR = "r0"
+PR = "r1"