freetype-native_2.2.1.bb, freetype_2.2.1.bb : new versions of stable
authorGraeme Gregory <dp@xora.org.uk>
Mon, 10 Jul 2006 10:13:40 +0000 (10:13 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Mon, 10 Jul 2006 10:13:40 +0000 (10:13 +0000)
I did these when trying to track down problems with alignment errors so
I might as well check them in.
DEFAULT_PREFERENCE = "-1" for now as these are pretty core and could
do with review.

packages/freetype/freetype-2.2.1/.mtn2git_empty [new file with mode: 0644]
packages/freetype/freetype-2.2.1/configure.patch [new file with mode: 0644]
packages/freetype/freetype-2.2.1/no-hardcode.patch [new file with mode: 0644]
packages/freetype/freetype-native_2.2.1.bb [new file with mode: 0644]
packages/freetype/freetype_2.2.1.bb [new file with mode: 0644]

diff --git a/packages/freetype/freetype-2.2.1/.mtn2git_empty b/packages/freetype/freetype-2.2.1/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/freetype/freetype-2.2.1/configure.patch b/packages/freetype/freetype-2.2.1/configure.patch
new file mode 100644 (file)
index 0000000..2b62ddf
--- /dev/null
@@ -0,0 +1,41 @@
+--- freetype-2.2.1/builds/unix/configure.ac.orig       2006-07-10 10:31:58.000000000 +0100
++++ freetype-2.2.1/builds/unix/configure.ac    2006-07-10 10:33:50.000000000 +0100
+@@ -119,9 +119,9 @@
+ # Check for system zlib
+-# don't quote AS_HELP_STRING!
++# don't quote AC_HELP_STRING!
+ AC_ARG_WITH([zlib],
+-  AS_HELP_STRING([--without-zlib],
++  AC_HELP_STRING([--without-zlib],
+                  [use internal zlib instead of system-wide]))
+ if test x$with_zlib != xno && test -z "$LIBZ"; then
+   AC_CHECK_LIB([z], [gzsetparams], [AC_CHECK_HEADER([zlib.h], [LIBZ='-lz'])])
+@@ -135,9 +135,9 @@
+ # Whether to use Mac OS resource-based fonts.
+-# don't quote AS_HELP_STRING!
++# don't quote AC_HELP_STRING!
+ AC_ARG_WITH([old-mac-fonts],
+-  AS_HELP_STRING([--with-old-mac-fonts],
++  AC_HELP_STRING([--with-old-mac-fonts],
+                  [allow Mac resource-based fonts to be used]))
+ if test x$with_old_mac_fonts = xyes; then
+   orig_LDFLAGS="${LDFLAGS}"
+--- freetype-2.2.1/builds/unix/unix-cc.in.orig 2006-07-10 10:40:41.000000000 +0100
++++ freetype-2.2.1/builds/unix/unix-cc.in      2006-07-10 10:43:10.000000000 +0100
+@@ -14,8 +14,11 @@
+ CC           := @CC@
+ COMPILER_SEP := $(SEP)
++SHELL        := @SHELL@
++top_builddir := $(BUILD_DIR)
+-LIBTOOL ?= $(BUILD_DIR)/libtool
++
++LIBTOOL ?= @LIBTOOL@
+ # The object file extension (for standard and static libraries).  This can be
diff --git a/packages/freetype/freetype-2.2.1/no-hardcode.patch b/packages/freetype/freetype-2.2.1/no-hardcode.patch
new file mode 100644 (file)
index 0000000..6528975
--- /dev/null
@@ -0,0 +1,11 @@
+--- freetype-2.2.1/builds/unix/freetype-config.in.orig 2006-07-10 10:51:47.000000000 +0100
++++ freetype-2.2.1/builds/unix/freetype-config.in      2006-07-10 10:52:27.000000000 +0100
+@@ -16,7 +16,7 @@
+ libdir=@libdir@
+ enable_shared=@enable_shared@
+ wl=@wl@
+-hardcode_libdir_flag_spec='@hardcode_libdir_flag_spec@'
++hardcode_libdir_flag_spec=''
+ usage()
+ {
diff --git a/packages/freetype/freetype-native_2.2.1.bb b/packages/freetype/freetype-native_2.2.1.bb
new file mode 100644 (file)
index 0000000..bc9ad11
--- /dev/null
@@ -0,0 +1,23 @@
+include freetype_${PV}.bb
+inherit native
+DEPENDS = ""
+FILESPATH = "${FILE_DIRNAME}/freetype-${PV}:${FILE_DIRNAME}/freetype:${FILE_DIRNAME}/files"
+
+EXTRA_OEMAKE=
+
+DEFAULT_PREFERENCE = "-1"
+
+do_configure() {
+       (cd builds/unix && gnu-configize) || die "failure running gnu-configize"
+       oe_runconf
+}
+
+do_stage() {
+       autotools_stage_includes
+       oe_libinstall -so -a -C objs libfreetype ${STAGING_LIBDIR}
+}
+
+do_install() {
+       :
+}
+
diff --git a/packages/freetype/freetype_2.2.1.bb b/packages/freetype/freetype_2.2.1.bb
new file mode 100644 (file)
index 0000000..7a3f99f
--- /dev/null
@@ -0,0 +1,37 @@
+DESCRIPTION = "Freetype font rendering library"
+SECTION = "libs"
+LICENSE = "freetype"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
+          file://configure.patch;patch=1 \
+           file://no-hardcode.patch;patch=1"
+S = "${WORKDIR}/freetype-${PV}"
+
+inherit autotools pkgconfig binconfig
+
+DEFAULT_PREFERENCE = "-1"
+
+LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
+EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
+
+do_configure() {
+       cd builds/unix
+       gnu-configize
+       aclocal -I .
+       autoconf
+       cd ${S}
+       oe_runconf
+}
+
+do_compile_prepend() {
+       ${BUILD_CC} -o objs/apinames src/tools/apinames.c
+}
+
+do_stage() {
+       autotools_stage_includes
+       oe_libinstall -so -a -C objs libfreetype ${STAGING_LIBDIR}
+}
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}"