openjade 1.3.2: Fix messing up compiler arguments.
authorRobert Schuster <thebohemian@gmx.net>
Tue, 19 Aug 2008 23:42:03 +0000 (23:42 +0000)
committerRobert Schuster <thebohemian@gmx.net>
Tue, 19 Aug 2008 23:42:03 +0000 (23:42 +0000)
openjade-native 1.3.2: Fix messing up compiler arguments.

packages/openjade/openjade-native_1.3.2.bb
packages/openjade/openjade_1.3.2.bb

index 11a3ca8..822c47d 100644 (file)
@@ -15,8 +15,12 @@ EXTRA_OECONF = "--enable-spincludedir=${STAGING_INCDIR}/OpenSP \
                 --enable-splibdir=${STAGING_LIBDIR} \
                --enable-default-catalog=${sysconfdir}/sgml/catalog \
                --enable-default-search-path=${datadir}/sgml"
+
 acpaths = "-I ${S}/config"
-CFLAGS_prepend = "-I${S}/include"
+
+# Trailing whitespace is important. Otherwise compiler arguments will be messed
+# up, resulting in a fail in do_configure.
+CFLAGS_prepend = "-I${S}/include "
 
 do_configure () {
        mv config/configure.in .
index 7b1272b..dcbfd88 100644 (file)
@@ -12,8 +12,12 @@ inherit autotools
 
 EXTRA_OECONF = "--enable-spincludedir=${STAGING_INCDIR}/OpenSP \
                 --enable-splibdir=${STAGING_LIBDIR}"
+
 acpaths = "-I ${S}/config"
-CFLAGS_prepend = "-I${S}/include"
+
+# Trailing whitespace is important. Otherwise compiler arguments will be messed
+# up, resulting in a fail in do_configure.
+CFLAGS_prepend = "-I${S}/include "
 
 do_configure_prepend () {
         mv config/configure.in .