patcher on FreeBSD:
authorHolger Freyther <zecke@selfish.org>
Sun, 17 Jul 2005 12:38:14 +0000 (12:38 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Sun, 17 Jul 2005 12:38:14 +0000 (12:38 +0000)
-Patch patcher to use gpatch on FreeBSD

packages/patcher/files/.mtn2git_empty [new file with mode: 0644]
packages/patcher/files/freebsd_gpatch.patch [new file with mode: 0644]
packages/patcher/patcher-native_20040913.bb

diff --git a/packages/patcher/files/.mtn2git_empty b/packages/patcher/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/patcher/files/freebsd_gpatch.patch b/packages/patcher/files/freebsd_gpatch.patch
new file mode 100644 (file)
index 0000000..f7e107a
--- /dev/null
@@ -0,0 +1,28 @@
+On FreeBSD the default patch program has a different command line
+interface than GNU patch. Make patcher use the GNU patch.
+
+
+--- patcher.py.old     Mon Sep 13 21:59:05 2004
++++ patcher.py Sun Jul 17 14:24:50 2005
+@@ -631,8 +631,8 @@
+       my $res;
+       # ... then we look if the patch would apply cleanly ...
+-      print "DEBUG: patch --dry-run $opt\n" if $debug > 1;
+-      $res = system("patch --dry-run $opt >$patchlog 2>/dev/null");
++      print "DEBUG: gpatch --dry-run $opt\n" if $debug > 1;
++      $res = system("gpatch --dry-run $opt >$patchlog 2>/dev/null");
+       if ($res != 0) {
+               unless ($do_force) {
+                       unlink($patchlog);
+@@ -669,8 +669,8 @@
+       # Finally we apply the patch. No need to create backup copies with -b,
+       # that has been done by PutIntoPatch()
+       $opt = "-f $opt" if $do_force;
+-      print  "DEBUG: patch $opt\n" if $debug > 1;
+-      $res = system("patch $opt >$patchlog");
++      print  "DEBUG: gpatch $opt\n" if $debug > 1;
++      $res = system("gpatch $opt >$patchlog");
+       unlink($patchlog);
+       $res = 0 if $do_force && $res == 256;
+       if ($res != 0) {
index e1ac1c1..1d49d0e 100644 (file)
@@ -11,6 +11,7 @@ PR = "r1"
 inherit native
 
 SRC_URI = "http://www.holgerschurig.de/files/linux/patcher-${PV}.tar.bz2"
+SRC_URI_append_build-fbsd = " file://freebsd_gpatch.patch;patch=1 "
 S = "${WORKDIR}/patcher"
 
 PATCHCLEANCMD = ""