Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
authorKoen Kooi <koen@openembedded.org>
Tue, 28 Jun 2005 11:53:12 +0000 (11:53 +0000)
committerKoen Kooi <koen@openembedded.org>
Tue, 28 Jun 2005 11:53:12 +0000 (11:53 +0000)
into bitbake.utwente.nl:/home/koen/OE/openembedded

2005/06/28 13:52:52+02:00 utwente.nl!koen
gnome-power_0.0.5.bb, libwnck_2.8.1.bb:  new file
hal_0.5.2.bb:  stage libs + headers

2005/06/28 13:08:58+02:00 utwente.nl!koen
hal_0.5.2.bb:  inherit pkgconfig

BKrev: 42c13a28BTxVjEgHqRMV-YVQqJM3SA

packages/gnome/gnome-power_0.0.5.bb [new file with mode: 0644]
packages/gnome/libwnck_2.8.1.bb [new file with mode: 0644]
packages/hal/hal_0.5.2.bb

diff --git a/packages/gnome/gnome-power_0.0.5.bb b/packages/gnome/gnome-power_0.0.5.bb
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/gnome/libwnck_2.8.1.bb b/packages/gnome/libwnck_2.8.1.bb
new file mode 100644 (file)
index 0000000..e69de29
index fc807a7..d02970e 100644 (file)
@@ -10,9 +10,16 @@ LICENSE = "GPL LGPL AFL"
 SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz"
 S = "${WORKDIR}/hal-${PV}"
 
-inherit autotools
+inherit autotools pkgconfig
 
 EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
                --with-expat=${STAGING_LIBDIR}/.. \
                --with-dbus-sys=${sysconfdir}/dbus-1/system.d \
                --with-hotplug=${sysconfdir}/hotplug.d"
+
+do_stage() {
+       autotools_stage_includes
+       install -d ${STAGING_LIBDIR}
+       install -m 755 libhal/.libs/libhal.so.1.0.0 ${STAGING_LIBDIR}/libhal.so
+       install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
+}