update kernel
authorschon <schon@dev03-server>
Thu, 22 Sep 2011 02:43:30 +0000 (11:43 +0900)
committerschon <schon@dev03-server>
Thu, 22 Sep 2011 02:43:30 +0000 (11:43 +0900)
recipes/linux/files/vuplus/dvb-include-2.6.18-5.3.patch
recipes/linux/files/vuplus/linux-2.6.18-dvb-core.patch
recipes/linux/linux-bm750_2.6.18.bb
recipes/linux/linux-vusolo_2.6.18.bb
recipes/linux/linux-vuultimo_2.6.18.bb
recipes/linux/linux-vuuno_2.6.18.bb

index 26fffb6..7ef2a5a 100644 (file)
@@ -109,7 +109,7 @@ Index: include/linux/dvb/frontend.h
  } fe_guard_interval_t;
  
  
-@@ -239,7 +257,138 @@
+@@ -239,7 +257,139 @@
        struct dvb_frontend_parameters parameters;
  };
  
@@ -205,6 +205,7 @@ Index: include/linux/dvb/frontend.h
 +      SYS_CMMB,
 +      SYS_DAB,
 +      SYS_DVBT2,
++      SYS_TURBO,
 +} fe_delivery_system_t;
 +
 +struct dtv_cmds_h {
@@ -305,7 +306,7 @@ Index: include/linux/dvb/version.h
 -#define DVB_API_VERSION 3
 -#define DVB_API_VERSION_MINOR 1
 +#define DVB_API_VERSION 5
-+#define DVB_API_VERSION_MINOR 3
++#define DVB_API_VERSION_MINOR 4
  
  #endif /*_DVBVERSION_H_*/
 Index: include/linux/dvb/net.h
index 1b55cad..948e928 100644 (file)
@@ -395,7 +395,7 @@ Index: drivers/media/dvb/dvb-core/dvb_frontend.h
  };
  
  #define MAX_EVENT 8
-@@ -138,23 +316,73 @@
+@@ -138,23 +316,76 @@
        int                       eventr;
        int                       overflow;
        wait_queue_head_t         wait_queue;
@@ -444,6 +444,9 @@ Index: drivers/media/dvb/dvb-core/dvb_frontend.h
 +
 +      /* ISDB-T specifics */
 +      u32                     isdbs_ts_id;
++
++      /* DVB-T2 specifics */
++      u32                     dvbt2_plp_id;
 +};
 +
  struct dvb_frontend {
index ee447a6..5a903bb 100755 (executable)
@@ -1,6 +1,6 @@
 require linux-vuplus-2.6.18.inc
 
-PR = "r11"
+PR = "r12"
 
 SRC_URI += "\
        file://bm750_defconfig \
index bdc606e..8654f9a 100644 (file)
@@ -1,6 +1,6 @@
 require linux-vuplus-2.6.18.inc
 
-PR = "r14"
+PR = "r15"
 
 SRC_URI += "\
        file://vusolo_defconfig \
index 6b2e677..d14cff4 100755 (executable)
@@ -1,6 +1,6 @@
 require linux-vuplus-2.6.18.inc
 
-PR = "r14"
+PR = "r15"
 
 SRC_URI += "\
        file://vuultimo_defconfig \
index 0892244..ae2f9a3 100755 (executable)
@@ -1,6 +1,6 @@
 require linux-vuplus-2.6.18.inc
 
-PR = "r14"
+PR = "r15"
 
 SRC_URI += "\
        file://vuuno_defconfig \