bluez4: changed globs in FILES_${PN}-dev to make package_rpm happy
authorMarcin Juszkiewicz <hrw@openembedded.org>
Wed, 4 Mar 2009 21:16:03 +0000 (22:16 +0100)
committerMarcin Juszkiewicz <hrw@openembedded.org>
Thu, 19 Mar 2009 19:22:37 +0000 (20:22 +0100)
RPM building does not handle ${libdir}/*/*.la :(

recipes/bluez/bluez4_4.31.bb

index 5063950..15e8b00 100644 (file)
@@ -4,14 +4,14 @@ PRIORITY = "optional"
 DEPENDS = "gst-plugins-base alsa-lib libusb-compat dbus-glib"
 HOMEPAGE = "http://www.bluez.org"
 LICENSE = "GPL"
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "\
   http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
   file://fix-dfutool-usb-declaration-mismatch.patch;patch=1 \
   file://sbc-thumb.patch;patch=1 \
 #  file://hid2hci_usb_init.patch;patch=1 \
-"    
+"
 S = "${WORKDIR}/bluez-${PV}"
 
 inherit autotools pkgconfig
@@ -52,7 +52,8 @@ FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so"
 FILES_${PN} += "${libdir}/bluetooth/plugins/*.so"
 FILES_${PN}-dev += "\
   ${libdir}/bluetooth/plugins/*.la \
-  ${libdir}/*/*.la \
+  ${libdir}/alsa-lib/*.la \
+  ${libdir}/gstreamer-0.10/*.la \
 "
 FILES_${PN}-dbg += "\
   ${libdir}/bluetooth/plugins/.debug \