gnome-panel: fix "couldn't find scrollkeeper" error on Gnome-less host (#4802)
authorDenys Dmytriyenko <denis@denix.org>
Mon, 8 Dec 2008 22:14:04 +0000 (17:14 -0500)
committerDenys Dmytriyenko <denis@denix.org>
Mon, 8 Dec 2008 22:14:04 +0000 (17:14 -0500)
packages/gnome/gnome-panel/scrollkeeper.patch [new file with mode: 0644]
packages/gnome/gnome-panel_2.24.0.bb

diff --git a/packages/gnome/gnome-panel/scrollkeeper.patch b/packages/gnome/gnome-panel/scrollkeeper.patch
new file mode 100644 (file)
index 0000000..29b8703
--- /dev/null
@@ -0,0 +1,16 @@
+diff -u gnome-panel-2.24.0.orig/configure.in gnome-panel-2.24.0/configure.in
+--- gnome-panel-2.24.0.orig/configure.in       2008-09-22 17:21:55.000000000 -0400
++++ gnome-panel-2.24.0/configure.in    2008-11-04 15:32:39.000000000 -0500
+@@ -296,9 +296,9 @@
+ dnl scrollkeeper checks
+ AC_PATH_PROG(SCROLLKEEPER_CONFIG, scrollkeeper-config,no)
+-if test x$SCROLLKEEPER_CONFIG = xno; then
+-  AC_MSG_ERROR(Couldn't find scrollkeeper-config. Please install the scrollkeeper package)
+-fi
++dnl if test x$SCROLLKEEPER_CONFIG = xno; then
++dnl   AC_MSG_ERROR(Couldn't find scrollkeeper-config. Please install the scrollkeeper package)
++dnl fi
+ AM_GCONF_SOURCE_2
index b96d985..743e0fa 100644 (file)
@@ -3,6 +3,8 @@ DEPENDS = "librsvg libgweather startup-notification libwnck orbit2 gtk+ libgnome
 
 inherit gnome pkgconfig
 
+SRC_URI += "file://scrollkeeper.patch;patch=1"
+
 do_configure_prepend() {
         sed -i -e s:help:: ${S}/Makefile.am
 }
@@ -15,6 +17,7 @@ FILES_${PN} =+ "${datadir}/gnome* \
                 ${datadir}/icons"
 
 EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+EXTRA_OECONF = "--disable-scrollkeeper"
 
 do_stage() {
         autotools_stage_all