subversion: added 1.4.3 version with DEFAULT_PREFERENCE of -1.
authorMichael Krelin <hacker@klever.net>
Wed, 9 May 2007 11:56:33 +0000 (11:56 +0000)
committerMichael Krelin <hacker@klever.net>
Wed, 9 May 2007 11:56:33 +0000 (11:56 +0000)
this version seems to accept neon 0.26 without brute force,
which in turn doesn't need force to use gnutls.

packages/subversion/subversion_1.4.3.bb [new file with mode: 0644]

diff --git a/packages/subversion/subversion_1.4.3.bb b/packages/subversion/subversion_1.4.3.bb
new file mode 100644 (file)
index 0000000..c0a2a02
--- /dev/null
@@ -0,0 +1,29 @@
+DESCRIPTION = "The Subversion (svn) client"
+SECTION = "console/network"
+DEPENDS = "apr-util neon"
+RDEPENDS = "neon"
+LICENSE = "Apache/BSD"
+HOMEPAGE = "http://subversion.tigris.org"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
+           file://disable-revision-install.patch;patch=1 \
+          file://neon-detection.patch;patch=1"
+
+EXTRA_OECONF = "--with-neon=${STAGING_DIR}/${TARGET_SYS} \
+                --without-berkeley-db --without-apxs --without-apache \
+                --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
+                --with-apr-util=${STAGING_BINDIR_CROSS}"
+
+
+inherit autotools
+
+export LDFLAGS += " -L${STAGING_LIBDIR} "
+
+do_configure() {
+       gnu-configize
+       libtoolize --force
+       aclocal -I build/ -I build/ac-macros/ && autoconf
+       oe_runconf
+}