duma: add duma-2.5.7, a red-zone memory allocator
authorPhilipp Zabel <philipp.zabel@gmail.com>
Sun, 19 Aug 2007 10:57:33 +0000 (10:57 +0000)
committerPhilipp Zabel <philipp.zabel@gmail.com>
Sun, 19 Aug 2007 10:57:33 +0000 (10:57 +0000)
packages/duma/.mtn2git_empty [new file with mode: 0644]
packages/duma/duma_2.5.7.bb [new file with mode: 0644]

diff --git a/packages/duma/.mtn2git_empty b/packages/duma/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/duma/duma_2.5.7.bb b/packages/duma/duma_2.5.7.bb
new file mode 100644 (file)
index 0000000..d4bc416
--- /dev/null
@@ -0,0 +1,27 @@
+DESCRIPTION = "A Red-Zone memory allocator to detect unintended memory access"
+HOMEPAGE = "http://duma.sourceforge.net"
+LICENSE = "GPL LGPL"
+SECTION = "devel"
+DEPENDS = "qemu-native"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/duma/duma_2_5_7.tar.gz"
+
+S = "${WORKDIR}/duma_2_5_7"
+
+EXTRA_OECONF = "-e"
+
+do_configure () {
+       oe_runmake createconf
+       qemu-${TARGET_ARCH} -L ${STAGING_DIR}/${HOST_SYS} ./createconf
+}
+
+do_compile () {
+       oe_runmake libduma.a libduma.so.0.0
+}
+
+do_install () {
+       install -d ${D}${base_bindir}
+       install -d ${D}${base_libdir}
+       install -d ${D}${mandir}/man3
+       oe_runmake install prefix="${D}" MAN_INSTALL_DIR="${D}${mandir}/man3"
+}